Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 01-30-2005, 12:10 AM   #1
veightkiller
Scooby Guru
 
Member#: 78967
Join Date: Jan 2005
Chapter/Region: VIC
Location: vancouver B.C
Vehicle:
2011 335i
Black

Default gauge cluster problem...

i know it's stupid but i tried to modd my gauge cluster to change my bulbs and sand it.. but i didn't take my time,so i removed the needles...and when i put it back on my car the needles doesn't seat right at all and sticky..is there anyway to fix it???

thank's
* Registered users of the site do not see these ads.
veightkiller is offline  
Old 01-30-2005, 01:07 AM   #2
cnk
Scooby Guru
 
Member#: 10757
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2013 BRZ Limited 6MT
DGM

Default

Answered your post in the other forum. Cross posting is against the Board rules.

Calvin
cnk is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sti gauge cluster problems crpwrx Electrical & Lighting 3 05-22-2009 01:09 PM
2006 WRX Gauge Cluster Problem Impreza127 Subaru Conversions 17 09-14-2006 12:58 PM
2006 WRX Gauge Cluster Problem Impreza127 Electrical & Lighting 0 09-06-2006 08:04 AM
Gauge cluster problem scoobyimprza Subaru Conversions 4 10-03-2005 07:41 PM
Gauge cluster problem scoobyimprza Electrical & Lighting 3 09-19-2005 08:58 AM


All times are GMT -4. The time now is 07:13 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.