Welcome to the North American Subaru Impreza Owners Club Sunday December 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Interior & Exterior Modification

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-14-2005, 09:33 PM   #1
veightkiller
Scooby Guru
 
Member#: 78967
Join Date: Jan 2005
Chapter/Region: VIC
Location: vancouver B.C
Vehicle:
2011 335i
Black

Default Guys I need your help about my STi cluster

i just bought and installed my sti gauge cluster V8..i didn't cut any wire's co'z im not really sure wich wire needs to be cut..if you can show me a picture it will help alot...and my radio is not working..there's no power on it...does it mean i blow up some fuse when im installing the gauge??? the dccd in on and the rear diff. temp. is on how can i turn does one off????
i installed it on my 02 wrx wagon...
thank's in advance
* Registered users of the site do not see these ads.
veightkiller is offline   Reply With Quote
Old 02-14-2005, 09:41 PM   #2
ATX25RS
Scooby Guru
 
Member#: 4597
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Laredo, Texas
Vehicle:
2011 Mitsu Outlander
Sport (Ex-Suby owner X3)

Default

try posting in the electrical and lighting forum....they have a lot of info in there.
ATX25RS is offline   Reply With Quote
Old 02-14-2005, 09:42 PM   #3
veightkiller
Scooby Guru
 
Member#: 78967
Join Date: Jan 2005
Chapter/Region: VIC
Location: vancouver B.C
Vehicle:
2011 335i
Black

Default

thank's men....
veightkiller is offline   Reply With Quote
Old 02-15-2005, 06:07 AM   #4
bingwrx
Scooby Newbie
 
Member#: 79684
Join Date: Jan 2005
Location: Waihi Beach, New Zealand
Vehicle:
2004 Impreza WRX
Red/Blue

Default

Remove the bulbs that light the dccd and rear diff. temp from the back of the cluster.
bingwrx is offline   Reply With Quote
Old 02-15-2005, 11:28 AM   #5
smdandb2
Scooby Specialist
 
Member#: 70656
Join Date: Sep 2004
Chapter/Region: RMIC
Location: Trampoline Land
Vehicle:
Old Mazda3 Hatch
Shelby Lancer #623

Default

Quote:
Originally Posted by veightkiller
i just bought and installed my sti gauge cluster V8..i didn't cut any wire's co'z im not really sure wich wire needs to be cut..if you can show me a picture it will help alot...and my radio is not working..there's no power on it...does it mean i blow up some fuse when im installing the gauge??? the dccd in on and the rear diff. temp. is on how can i turn does one off????
i installed it on my 02 wrx wagon...
thank's in advance
Well, you obviously knew a wire needed to be cut in order for it to work. Why did you continue installing it? There are 1000s of threads about this topic!
smdandb2 is offline   Reply With Quote
Old 02-15-2005, 05:10 PM   #6
kunfuzion
Scooby Specialist
 
Member#: 1094
Join Date: Mar 2000
Chapter/Region: SCIC
Location: CA
Vehicle:
'85 Levin Hatch
color of rust

Default

do a search. its been covered, multiple times.
kunfuzion is offline   Reply With Quote
Old 02-15-2005, 11:57 PM   #7
veightkiller
Scooby Guru
 
Member#: 78967
Join Date: Jan 2005
Chapter/Region: VIC
Location: vancouver B.C
Vehicle:
2011 335i
Black

Default

thank you guys for all ur opinions..i already cut the wire on pin 28.i didn't notice the pin numbers co'z they're too small..anyways im happy with my new gauge cluster..with a shift light and red color specially the needles go back and fourth when i start my car even thou it's a lil bit expensive i'd say it's worthy "for me"
veightkiller is offline   Reply With Quote
Old 02-16-2005, 02:55 AM   #8
cnk
Scooby Guru
 
Member#: 10757
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2013 BRZ Limited 6MT
DGM

Default

Quote:
Originally Posted by bingwrx
Remove the bulbs that light the dccd and rear diff. temp from the back of the cluster.
There are no bulbs on the 04+ STi clusters. They use LED's. The only way to turn the lights off is to use some electrical tape from behind to cover up the display.

Calvin
cnk is offline   Reply With Quote
Old 02-16-2005, 06:49 AM   #9
bingwrx
Scooby Newbie
 
Member#: 79684
Join Date: Jan 2005
Location: Waihi Beach, New Zealand
Vehicle:
2004 Impreza WRX
Red/Blue

Default

Bulbs/LED's, whatever, I just noticed that the circuit board on the back of my WRX cluster has all the fittings for an sti, just no LED's in place and a bit less soldering I guess, if you remove the LED then then that specific symbol aint gonna light up, simple.
bingwrx is offline   Reply With Quote
Old 02-16-2005, 01:09 PM   #10
cnk
Scooby Guru
 
Member#: 10757
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2013 BRZ Limited 6MT
DGM

Default

Have you seen the location of the LED's on a real STi gauge? There's no room to fit a soldering iron in to remove the LED. Plus, why take the risk of removing the needles and not having them line up correctly afterwards? It takes a few seconds to lift the edge and slip electrical tape under to cover the display.

The circuit boards are different. . .you would know this if you ever looked at the two gauges up close. Just use the electrical tape. . .even simpler.

Calvin
cnk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
i need help whit my sti cluster 2007 to fit in the wrx 2006 subaru_west Electrical & Lighting 2 01-12-2008 05:44 AM
guys i need your help about my sti cluster veightkiller Electrical & Lighting 2 02-15-2005 02:12 AM
attn: nice guy...we need your help yuzo Hawaii Impreza Club Forum -- HIIC 9 02-02-2002 10:06 PM
Guys i need your help please read!!! Future Subaru Driver1 General Forum Archive 4 05-31-2000 08:17 AM
Guys I need your help please read!!! Future Subaru Driver1 Technical Forum Archive 1 05-30-2000 09:44 PM


All times are GMT -4. The time now is 02:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.