Welcome to the North American Subaru Impreza Owners Club Wednesday August 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-14-2005, 08:44 PM   #1
veightkiller
Scooby Guru
 
Member#: 78967
Join Date: Jan 2005
Chapter/Region: VIC
Location: vancouver B.C
Vehicle:
2011 335i
Black

Default guys i need your help about my sti cluster

1st of all sorry for posting two thread's in different forum...

i just bought and installed my sti gauge cluster V8..i didn't cut any wire's co'z im not really sure wich wire needs to be cut..if you can show me a picture it will help alot...and my radio is not working..there's no power on it...does it mean i blow up some fuse when im installing the gauge??? the dccd in on and the rear diff. temp. is on how can i turn does one off????
i installed it on my 02 wrx wagon...
* Registered users of the site do not see these ads.
veightkiller is offline   Reply With Quote
Old 02-15-2005, 12:03 AM   #2
InfamousDX
Scooby Guru
 
Member#: 25413
Join Date: Sep 2002
Chapter/Region: Tri-State
Location: North NJ
Default

You blew a fuse if you didn't cut wire #B28. It's easy... go to the middle harness... look for hte TINY ass numbers and look for 28... snip it. The end, no more blown radio fuse.

As for the DCCD and rear diff.. you're stuck. Either crack open the cluster and take out those bulbs (which I don't recommend messing with really... sti cluster isn't as easily accessible as the wrx)... or open the plastic an put black elec. tape.. or get used to it. I got used to it.
InfamousDX is offline   Reply With Quote
Old 02-15-2005, 01:12 AM   #3
veightkiller
Scooby Guru
 
Member#: 78967
Join Date: Jan 2005
Chapter/Region: VIC
Location: vancouver B.C
Vehicle:
2011 335i
Black

Default

^^^ thank's alot men ..i appriciate your help..
veightkiller is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
i need help whit my sti cluster 2007 to fit in the wrx 2006 subaru_west Electrical & Lighting 2 01-12-2008 04:44 AM
Guys I need your help about my STi cluster veightkiller Interior & Exterior Modification 9 02-16-2005 12:09 PM
attn: nice guy...we need your help yuzo Hawaii Impreza Club Forum -- HIIC 9 02-02-2002 09:06 PM
Guys i need your help please read!!! Future Subaru Driver1 General Forum Archive 4 05-31-2000 07:17 AM
Guys I need your help please read!!! Future Subaru Driver1 Technical Forum Archive 1 05-30-2000 08:44 PM


All times are GMT -4. The time now is 02:30 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.