Welcome to the North American Subaru Impreza Owners Club Sunday February 7, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-01-2005, 12:08 PM   #1
smain38ehampton
Scooby Newbie
 
Member#: 79420
Join Date: Jan 2005
Location: Ct
Vehicle:
00 2.5 rs
blue

Exclamation Check engine light!!

i put an apexi safc2 in my car about a 2 months ago. the car ran really well. but the check engine light was on. i didnt feel anything different with the car it just ran better. i have to go to emissions in CT and i know you dont pass with a check engine light on. so i took out the safc and the check engine light is still on. why is this? is there something else wrong with the car? or is it still reading the safc?
* Registered users of the site do not see these ads.
smain38ehampton is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-01-2005, 12:09 PM   #2
smain38ehampton
Scooby Newbie
 
Member#: 79420
Join Date: Jan 2005
Location: Ct
Vehicle:
00 2.5 rs
blue

Exclamation

oh yea the check engine light came on once i put the safc in the car. i think like 2 minutes after i started the car with the safc in there.
smain38ehampton is offline   Reply With Quote
Old 03-01-2005, 12:12 PM   #3
Geek Guy
Scooby Specialist
 
Member#: 8151
Join Date: Jul 2001
Chapter/Region: South East
Location: Rally Tools LLC
Vehicle:
2002 WRX Rally Car
Atlantic Rally Cup Champ!

Default

go to autozone and get the code read. People are not usually telepathic here.
Geek Guy is offline   Reply With Quote
Old 03-01-2005, 12:20 PM   #4
JewPac42
Scooby Guru
 
Member#: 23260
Join Date: Aug 2002
Chapter/Region: BAIC
Location: -=3/1 Jew Crew=-
Vehicle:
Patr ick Willis
for Rookie of the year

Default

You need to get the code pulled, then you need to go here: http://forums.nasioc.com/forums/showthread.php?t=298963 to find out what the code means, then search for other people who have had the same code and what they did to fix it.
JewPac42 is offline   Reply With Quote
Old 03-01-2005, 12:46 PM   #5
edaniele1212
Scooby Newbie
 
Member#: 71013
Join Date: Sep 2004
Chapter/Region: NESIC
Location: around Springfield, MA
Vehicle:
2004 WRX STi
Java Black/Goldies

Default

I guess you could try disconnecting the battery and holding the brake for a few seconds to reset the ECU. It's free and it might work!!!
edaniele1212 is offline   Reply With Quote
Old 03-01-2005, 12:52 PM   #6
JewPac42
Scooby Guru
 
Member#: 23260
Join Date: Aug 2002
Chapter/Region: BAIC
Location: -=3/1 Jew Crew=-
Vehicle:
Patr ick Willis
for Rookie of the year

Default

Quote:
Originally Posted by edaniele1212
I guess you could try disconnecting the battery and holding the brake for a few seconds to reset the ECU. It's free and it might work!!!
Yah, but if he goes in, the ECU will give a not ready code and he will fail emissions. He doesnt need a quick fix, he needs to fix the problem.
JewPac42 is offline   Reply With Quote
Old 03-01-2005, 01:14 PM   #7
Uncle Scotty
*** Banned ***
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK buy Nates beans
westcoastroasting.com

Default

Any time you get a CEL, you really need to know what it is....some are harmeless....some not. It would be real dumb to let a simple fix turn into a major problem just 'cuz you ignored your car screaming 'HELP'.....
Uncle Scotty is offline   Reply With Quote
Old 03-01-2005, 01:23 PM   #8
Monsito
Scooby Specialist
 
Member#: 40581
Join Date: Jul 2003
Chapter/Region: MWSOC
Location: Chicago
Vehicle:
04 STi
Blue

Default

My Check Engine Light is on, what is wrong type questions. Any question related to a CEL is worthless unless you list your car type and the PXXXX CEL code. Without both pieces of information you won't get a straight answer. Listing your modifications and the time line between your last mod(s) and the new CEL helps too.

http://forums.nasioc.com/forums/showthread.php?t=718033
Monsito is offline   Reply With Quote
Old 03-01-2005, 01:30 PM   #9
Leadfoot77
Scooby Specialist
 
Member#: 74268
Join Date: Nov 2004
Chapter/Region: NESIC
Location: Boston, MA
Vehicle:
2013 STi
DGM

Default

Resetting your ECU by disconnecting the battery is NOT fixing hte problem by any means - it's simply erasing your computer's memory of it. People who suggest that as a "fix" should probably stop modding their cars before they blow them up!
Leadfoot77 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light, VDC light is on, and cruise control light is flashing grimace09 Normally Aspirated Powertrain 7 08-09-2012 04:42 PM
Check engine light, VDC light is on, and cruise control and sport light is flashing Legacymun2k6 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 5 01-30-2010 01:47 PM
check engine light, wierd engine trouble? gipoliceman Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 01-14-2003 10:04 PM
Engine coolant temp sensor check engine light? rhdude Mid Atlantic Impreza Club -- MAIC 2 11-09-2002 03:42 AM
Engine vibrating, check engine light on codemunky Service & Maintenance 2 09-15-2002 08:50 AM

All times are GMT -4. The time now is 05:41 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.