Welcome to the North American Subaru Impreza Owners Club Tuesday July 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-03-2005, 07:30 PM   #1
StealthWagon
Scooby Newbie
 
Member#: 30823
Join Date: Dec 2002
Location: Boulder, Co/Bellingham, WA
Vehicle:
2004 WRX STI
Blue/Gold

Default poltec endlinks making lots of noise, normal?

I've had poltec front and rear endlinks on my STI for about 1 year. They have become very noisy, i was wondering if anyone else had this problem? Should I replace them or deal with it?
The noise was there before my coilovers and the same after the install.

My setup is: Cusco f/r swaybars, zeal V6 coilovers (stock struts and pinks before)
* Registered users of the site do not see these ads.
StealthWagon is offline   Reply With Quote
Old 03-03-2005, 07:39 PM   #2
peterex
Scooby Specialist
 
Member#: 27021
Join Date: Oct 2002
Chapter/Region: MWSOC
Location: IL
Vehicle:
2010 WRX

Default

Have you tried regreasing the bearings?
peterex is offline   Reply With Quote
Old 03-03-2005, 08:10 PM   #3
nhluhr
John Wayne Toilet Paper
Moderator
 
Member#: 7327
Join Date: Jun 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2008 Mazdaspeed3
2006 Wrangler Sport

Default

Quote:
Originally Posted by StealthWagon
I've had poltec front and rear endlinks on my STI for about 1 year. They have become very noisy, i was wondering if anyone else had this problem? Should I replace them or deal with it?
The noise was there before my coilovers and the same after the install.

My setup is: Cusco f/r swaybars, zeal V6 coilovers (stock struts and pinks before)
Mine did the same thing after awhile - the pillowballs loosened up. I've had better luck with the Hotchkis H/D endlinks which are a cast-housing with a full balljoint similar to in your front suspension. They've proven to be more durable AND they have a grease port built into the back of them to keep them greased, but I've never greased them and have had no issues.

Looking at the Hotchkis website, I don't see them there so i don't know if they still make them, but this is what they look like:

nhluhr is offline   Reply With Quote
Old 03-04-2005, 08:39 AM   #4
PolTec Inc
Vendor
 
Member#: 41768
Join Date: Aug 2003
Location: Chicago, IL
Default

Quote:
Originally Posted by StealthWagon
I've had poltec front and rear endlinks on my STI for about 1 year. They have become very noisy, i was wondering if anyone else had this problem? Should I replace them or deal with it?
The noise was there before my coilovers and the same after the install.

My setup is: Cusco f/r swaybars, zeal V6 coilovers (stock struts and pinks before)
I assume that you checked all the bolts and made sure that they are tight, if so, send us some pictures so that we can confirm that they were installed properly and we will work with you to get you replacement parts.

Thank you

Dariusz
www.poltec.us
info@poltec.us
708/308-0947
PolTec Inc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bmw working on new systems that make use of heat normally lost AVANTI R5 Non-Subaru News & Rumors 2 10-22-2009 10:35 AM
New Brake Pads Making Lots of Noise wrxphantom Brakes, Steering & Suspension 4 05-12-2009 09:20 AM
My tranny is making lots of noise... Im thinking input bearing? Jaredm83 Transmission (AT/MT) & Driveline 4 01-25-2006 12:37 PM
GP moto coilovers= lots of noise. knotty_dread Brakes, Steering & Suspension 2 09-30-2005 11:46 PM


All times are GMT -4. The time now is 04:17 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.