Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-11-2005, 12:33 AM   #1
H2OSB
Scooby Newbie
 
Member#: 71310
Join Date: Sep 2004
Chapter/Region: BAIC
Location: Modesto, CA
Vehicle:
'06 LGT Sedan
SWP

Default Weak, slow right turn signal

I just replaced my headlights on my '97 LOB (with aftermarket, factory style lights). After the replacement, everything seemed to be working fine. Today, however, I find no front right turn signal. The flash is very slow. Dash turn indicatior, and rear light both glow, but VERY faintly (I noticed the problem during the day and thought the dash indicator and rear light were not working, however, at night they are weak but there.). I did a search and found no one with a similar problem. I'm going to replace the bulb with the one I salvaged from the old headlights, however, from what I read, if the bulb was blown, my flash would be too fast.

Any help would be appreciated

H2OSB
* Registered users of the site do not see these ads.
H2OSB is offline   Reply With Quote
Old 03-11-2005, 01:21 AM   #2
H2OSB
Scooby Newbie
 
Member#: 71310
Join Date: Sep 2004
Chapter/Region: BAIC
Location: Modesto, CA
Vehicle:
'06 LGT Sedan
SWP

Default

Nevermind. Problem solved. Even though the bulb and socket are brand new, it was a contact issue. I simply removed and insert the bulb into the socket several times until there was a bit of scuffing on the contacts. After that, problem was gone.

Thanks any who contemplated helping.

H2OSB
H2OSB is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vibration on slow right turn Robert OB Service & Maintenance 3 05-28-2009 06:45 PM
Front Right Turning Signal Acting Up goldenej20child Electrical & Lighting 1 05-14-2007 12:21 AM
Help: Right turn signal flashing twice as fast... Silver04DE Electrical & Lighting 10 09-09-2004 09:06 AM
impreza front right turn signal lamp White 2.5rs Private 'For Sale' Classifieds 0 07-30-2003 02:28 PM
right front turn signal fuse? soob2k General Forum Archive 1 03-10-2001 02:14 PM


All times are GMT -4. The time now is 01:42 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.