Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Southern California Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Southern California Impreza Club Forum -- SCIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-21-2005, 02:08 AM   #1
machantu
Scooby Newbie
 
Member#: 82852
Join Date: Mar 2005
Location: Anaheim, CA
Vehicle:
2003 Impreza WRX
Rally Blue

Default CEL Problem - Need ADVICE!

I bought my 2003 WRX about a week ago from a SMALL dealer in Hawthorne. After driving it out from the lot for about 30 miles, the CEL came on. So, I called my dealer about the problem and brought it back to him to fix. He made me wait an entire day and said that he turned off the CEL for the time being but he could not determine the cause of the problem till the CEL comes on again.

So I told him to run it for a day and fix the problem that was causing the CEL came on. Apparently, he did not want to bring it into a Subaru dealer because they could not honor the warranty due to the mods in my car and wanted to charge. I collected the car today, the dealer told me he cleaned some contact points, and he ran the car for 30 miles (this is true because I noted the odometer) and the CEL was off when I collected it. So off I went out of the lot with the car, and after about 40 miles the CEL came back on...

Brought it to Autozone, there were 3 error codes:

P0244 - Turbo Solenoid Wastegate A/Range Performance
P0546 - EGT Sensor High Bank 1 Sensor 1
P0546 - EGT Sensor High Bank 1 Sensor 1

From what ppl have been telling me, it has been heavily modified. Pics below:
http://s91696424.onlinehome.us/gallery/Subaru

Can anyone recommend me a good place to go to get the engine condition evaluated and have the mods documented in the OC or LA area? Would appreciate any advice..
* Registered users of the site do not see these ads.
machantu is offline   Reply With Quote
Old 03-21-2005, 10:39 AM   #2
KMount
Scooby Specialist
 
Member#: 21104
Join Date: Jul 2002
Chapter/Region: SCIC
Location: Jorba Linda
Vehicle:
05 Legacy. Black,
Black, Blacker than Black

Default

wrong forum...try the engine threads
KMount is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
P0134 CEL - again?! Need advice on what went wrong Hyper Service & Maintenance 3 12-25-2008 09:26 PM
CEL problem, need help! Skeet Newbies & FAQs 2 05-07-2008 06:30 PM
CEL Problem - Need ADVICE! machantu Factory 2.0L Turbo Powertrain 40 04-24-2005 04:06 PM
Dealer won't fix my P0304 CEL problem, need advice please! WRXMod Warranty Issues & SOA Problems 5 12-20-2001 06:04 PM
Alarm Problem...need advice Soob Car Audio, Video & Security 0 06-21-2001 02:57 PM


All times are GMT -4. The time now is 04:39 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.