Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-28-2005, 12:49 PM   #1
97subGT
Scooby Newbie
 
Member#: 41323
Join Date: Aug 2003
Location: Granger IN
Vehicle:
2002 WRX
Sedona

Default spark plug problem

i have a wrx with a 2.5 sti short block with stock 2.0 heads and stock intake manfold. pretty much everything else is stock except for a perrin up pipe and a injen colder intake.

first the engine will start to sound like it is knocking pretty loud after about 10mins of driving. and then when i remove the suspected plug you are able to freely turn the porcelien (from tip to tip) inside of the metal part. i have driven the car with this setup for about 700 miles and this has happen twice in two different cylenders. The plugs that i am using are denso Iridiums

has anybody else had this problem or know how to fix this problem if so how did you fix? i am think colder plugs.
* Registered users of the site do not see these ads.
97subGT is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Coil pack or spark plug problems? dt311 Factory 2.0L Turbo Powertrain 1 05-31-2005 02:38 PM
Weird spark plug problem jasona Normally Aspirated Powertrain 9 04-29-2005 06:27 PM
Check Engine light + Spark Plug problem elum Factory 2.0L Turbo Powertrain 15 08-14-2004 03:06 AM
spark plug problem now fatray Factory 2.0L Turbo Powertrain 7 09-30-2002 09:00 PM
spark plug problem? knightsnke Factory 2.0L Turbo Powertrain 1 04-27-2002 09:12 PM


All times are GMT -4. The time now is 02:26 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.