Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-11-2013, 11:21 PM   #1
Dirtisthefunstuff
Scooby Newbie
 
Member#: 288269
Join Date: Jul 2011
Chapter/Region: Tri-State
Location: New York
Default

Hey guys, does anyone know of any issues with any part of the 05 lgt?

Im looking at one that has stock turbo with a perrin intake, perrin front mount intercooler, some exhaust mods that the dude didnt know the brand of off hand, and a tune. I think im forgetting something... Ill chime in when i remember.

I just want to know of anything i should be aware of.
Thanks in advance

Edit: its a 5 speed manual trans
Edit 2: it doesnt have the o2 sensor in it for some reason. What would i do about this? OEM? Wideband?
* Registered users of the site do not see these ads.

Last edited by Dirtisthefunstuff; 07-11-2013 at 11:58 PM.
Dirtisthefunstuff is offline   Reply With Quote
Old 07-12-2013, 08:09 AM   #2
PA-Outback2000
Scooby Specialist
 
Member#: 161832
Join Date: Oct 2007
Chapter/Region: Tri-State
Location: PA
Vehicle:
2000 Outback Limited
Black

Default

don't get the car. a few unknowns with brands and parts, esp the o2 sensor missing. that should be the 1st thing replaced!
PA-Outback2000 is offline   Reply With Quote
Old 07-12-2013, 09:45 AM   #3
BXWRX77
Scooby Newbie
 
Member#: 263699
Join Date: Nov 2010
Chapter/Region: Tri-State
Location: Bronx NY
Vehicle:
2005 Legacy GT Wagon
Black

Default

Being the owner of a 05 LGT, I will tell you this (run away), Unless you know the full Maintenace history, I would be very leary of it, I bought mine with 80K 24 days later the Motor Blew, everthing was working fine just boom. Contact Mike at AZP Intstalls and have them go over the car before you buy.

I wish I did!
BXWRX77 is offline   Reply With Quote
Old 07-12-2013, 01:59 PM   #4
Dirtisthefunstuff
Scooby Newbie
 
Member#: 288269
Join Date: Jul 2011
Chapter/Region: Tri-State
Location: New York
Default

PA-outback - he didnt remember off hand the name of the exhaust, im sure he knows it (i woke him up when i called about the car to look at it), and the 02 sensor just died recently, i spoke with the owner earlier. i know you cant take everything the seller says for granted lol, im going back to check it out little better sometime this weekend, would rather not test drive without the 02 sensor though.

Would the brand of the exhaust really matter that much though..?

BXWRX - ahhhh how many people keep full maintenance history now-a-days? lol i have to talk to him more still about it. And im in the process of contacting the shop that did the tune on the car to talk to them about it, ill keep AZP installs in mind though.

So what happened with your LGT that the motor blew? did you ever find out why? thats really crappy

thank you both for your input

Last edited by Dirtisthefunstuff; 07-12-2013 at 02:09 PM.
Dirtisthefunstuff is offline   Reply With Quote
Old 07-12-2013, 03:02 PM   #5
BXWRX77
Scooby Newbie
 
Member#: 263699
Join Date: Nov 2010
Chapter/Region: Tri-State
Location: Bronx NY
Vehicle:
2005 Legacy GT Wagon
Black

Default

This is the forum you want to be on for Legacy's

http://www.legacygt.com/forums/

Never found out why it blew, we think the turbo went and was replaced, but the never checked to make sure they got all the metal out of the block. It all worked out in the end, NY lemon law was in effect (under 30 days). now I am a owner of a 05 LGT wagon with a Brand new Longblock (8k in parts) from Subaru with warrenty

Mike from AZP had a real nice built Outback with forged internals they were selling for a client that they did all the work for. also check out the classifieds on LGT there are a few for sale. take a look!

Last edited by BXWRX77; 07-12-2013 at 03:04 PM. Reason: spelling
BXWRX77 is offline   Reply With Quote
Old 07-12-2013, 04:55 PM   #6
Dirtisthefunstuff
Scooby Newbie
 
Member#: 288269
Join Date: Jul 2011
Chapter/Region: Tri-State
Location: New York
Default

Awesome thanks ill check it out.


Hey im in nj now, ever been to any meets out this way?
Dirtisthefunstuff is offline   Reply With Quote
Old 07-12-2013, 05:54 PM   #7
BXWRX77
Scooby Newbie
 
Member#: 263699
Join Date: Nov 2010
Chapter/Region: Tri-State
Location: Bronx NY
Vehicle:
2005 Legacy GT Wagon
Black

Default

No, not in NJ. I did go with my kids to one, their friend has a WRX, so he asked if we could take the LGT.

But I felt out of place being 51

Last edited by BXWRX77; 07-12-2013 at 08:22 PM. Reason: ??
BXWRX77 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:04 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.