Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-02-2005, 11:23 PM   #1
scobaru
Scooby Guru
 
Member#: 31345
Join Date: Dec 2002
Chapter/Region: MWSOC
Location: Wisconsin
Vehicle:
05 LGT, GC8, NA
blue, white, blue

Default 1.8 idleing running rich problem

I have a friend how has a 95 impreza L with a 1.8 motor from a 93 running the 93 ECU. Its an automatic and it wont pass emissions. its running rich and has a brand new cat and 02 sensor. the idle will jump and it will want to idle at around 200rpms.

could it be possible that its a valcum leak? what else should I look into?
* Registered users of the site do not see these ads.
scobaru is offline   Reply With Quote
Old 04-02-2005, 11:54 PM   #2
Homemade WRX
Scooby Guru
 
Member#: 33782
Join Date: Mar 2003
Chapter/Region: MAIC
Location: 3MI Racing LLC
Vehicle:
96 bastard child
search FIRST, then PM!!!

Default

has he had his obd-I codes pulled?...maybe vacuum leak, also check the MAF sensor...see if it is clean and still good
Homemade WRX is offline   Reply With Quote
Old 04-07-2005, 03:05 PM   #3
scobaru
Scooby Guru
 
Member#: 31345
Join Date: Dec 2002
Chapter/Region: MWSOC
Location: Wisconsin
Vehicle:
05 LGT, GC8, NA
blue, white, blue

Default

update I could still use some help the car idles fine just rough no codes the MAF sensor is clean. the idle does'nt jump. it runs crazy rich fuel pressure is about 28psi which is what I checked to be correct the fuel pressure regulator is getting valcum that was checked.
scobaru is offline   Reply With Quote
Old 04-07-2005, 04:53 PM   #4
Storm
Scooby Guru
 
Member#: 5218
Join Date: Mar 2001
Chapter/Region: MWSOC
Location: SAUL'S Motorsports
Vehicle:
96L Most Over-
Developed Beater

Default

Is the MAF from the same year as the ECU? It may be getting the wrong signal.

Jay Storm
Storm is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1.8 idle problem nikesb1111 Normally Aspirated Powertrain 12 06-20-2009 09:31 PM
Erratic idle, running rich RsnSun Factory 2.5L Turbo Powertrain 2 02-09-2009 04:03 PM
Car won't idle, running rich any suggestions fstwrx Factory 2.0L Turbo Powertrain 4 08-27-2007 04:40 PM
Running Rich problem under load. boostedscooby2002 Factory 2.0L Turbo Powertrain 8 08-30-2006 09:20 AM
1.8->2.2 rich @ idle question drewdogg Subaru Conversions 1 01-20-2006 12:48 PM


All times are GMT -4. The time now is 03:32 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.