Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-04-2005, 05:53 PM   #1
Roro
Scooby Newbie
 
Member#: 79361
Join Date: Jan 2005
Location: Alabama
Vehicle:
2004 WRX Wagon
San Remo Red

Default New Car and Cobb Nightmare..not cobbs fault

So my new (to me) 2k4 WRX Wagon is nice and pretty. Well when I bought her in Jan. she had 5500 miles. Got her from Subaru of Gwinette..nice guys and all.

So my first mod of course is a Cobb Accessport. Well guess what... somehow (I love this) my ECU is already married to an AP. GREAT!!

So I call Cobb and they're great. Answer the phone fast, polite and all and they say that they can fix it, but they need my ECU and AP. Yeah, cause I have time to be without my car. I wish there was another way they could do it. He said my dealer may be able to just reflash it and kill the marriage info.

Call my dealer in Gwinette... Of course the guy I bought it from is out and Gary is a great guy, I am not mad at him. I am angry at the guy who traded my car in for an STi and didn't unmarry his AP. So since Gary isn't there, I call my local dealer, and I knew this would happen. The tech isn't in so the guy in service has NO idea what I can do. He doesn't know if it can be reflashed or what. So I get to call back tomorrow.

It's bad enough that I had to wait a few days to enjoy my new toy since I was out of town and it shipped WAY faster than expected (kudos to Cobb) but now, I have to wait to find a solution to this problem

Anyone else experience this or have a solution or know the guy from Ft. Rucker, AL driving around in an STi that did this? LOL

Oh well thanks for listening.

-Rory
* Registered users of the site do not see these ads.
Roro is offline   Reply With Quote
Old 04-04-2005, 06:05 PM   #2
fastsubie
Scooby Specialist
 
Member#: 21999
Join Date: Jul 2002
Chapter/Region: Tri-State
Location: Central PA
Vehicle:
2012 Wrx
OBP

Default

The guy that had the car before you got it must be a dumbass. I hope you get it fixed up soon.

Fess
fastsubie is offline   Reply With Quote
Old 04-04-2005, 06:54 PM   #3
phantomsr
Scooby Newbie
 
Member#: 69071
Join Date: Aug 2004
Location: Edmonton
Vehicle:
2002 Stg2-WRX Wagon
WRB & Dust

Default

Just think, they guy that sold you the car without unmarrying the AP probably sold that AP to someone else who's in a similar predicament to you.
phantomsr is offline   Reply With Quote
Old 04-05-2005, 02:12 AM   #4
Bishop
NASIOC Supporter
 
Member#: 59993
Join Date: Apr 2004
Chapter/Region: International
Location: WWAAYY west of the Mississippi
Vehicle:
Ass, grass or cash
no one rides for free!!

Default

that guy should be banned from ever owning a subaru.

hope everything works out.
Bishop is offline   Reply With Quote
Old 04-05-2005, 03:12 AM   #5
Roro
Scooby Newbie
 
Member#: 79361
Join Date: Jan 2005
Location: Alabama
Vehicle:
2004 WRX Wagon
San Remo Red

Default

Quote:
Originally Posted by phantomsr
Just think, they guy that sold you the car without unmarrying the AP probably sold that AP to someone else who's in a similar predicament to you.



Didn't think about that. Or he tried it on his STi to find out it didn't work. Wish I knew how to find him.
Roro is offline   Reply With Quote
Old 04-05-2005, 10:08 AM   #6
WRXRgr
Scooby Specialist
 
Member#: 54942
Join Date: Feb 2004
Chapter/Region: South East
Vehicle:
2004 WRX

Default

Quote:
Originally Posted by Roro


Didn't think about that. Or he tried it on his STi to find out it didn't work. Wish I knew how to find him.
Got a buddy who's a cop? Depending on how much time has passed, you might try running the VIN...if DMV records haven't been updated yet, you might be able to get his name & old address that way. Guess you already tried the dealership for that info, and they refused?
WRXRgr is offline   Reply With Quote
Old 04-05-2005, 10:16 AM   #7
wrx2.0 555
Scooby Specialist
 
Member#: 21383
Join Date: Jul 2002
Chapter/Region: South East
Vehicle:
2010 Trek
EX-5

Default

Quote:
Originally Posted by Roro


Didn't think about that. Or he tried it on his STi to find out it didn't work. Wish I knew how to find him.
The dealer should know.............shouldnt they?????
wrx2.0 555 is offline   Reply With Quote
Old 04-05-2005, 11:21 AM   #8
Roro
Scooby Newbie
 
Member#: 79361
Join Date: Jan 2005
Location: Alabama
Vehicle:
2004 WRX Wagon
San Remo Red

Default

They can't give out that information. Gary called me back this morning so I'm going to call Scott at Subaru Gwinette and see what he thinks. Ugh! This sucks. Well if this doesn't work it looks like the ECU will be pulled. Anyone know a how-to on pulling it?
Roro is offline   Reply With Quote
Old 04-05-2005, 11:28 AM   #9
wrx2.0 555
Scooby Specialist
 
Member#: 21383
Join Date: Jul 2002
Chapter/Region: South East
Vehicle:
2010 Trek
EX-5

Default

Quote:
Originally Posted by Roro
They can't give out that information.
I can appreciate that...But cant they call this person themselves and let him know? This is a problem for the both you--he just may not realize it yet...

Just a suggestion---Good Luck---
wrx2.0 555 is offline   Reply With Quote
Old 04-05-2005, 12:08 PM   #10
Slack
Scooby Specialist
 
Member#: 17548
Join Date: Apr 2002
Location: Atlanta, Ga
Default

Yeah, Scott is the man to talk to @ Subaru of Gwinnett. Also, you could call Jason Porter @ Topspeedsales.com . Both are well versed in Subaru tuning.


Mick
Slack is offline   Reply With Quote
Old 04-05-2005, 12:30 PM   #11
jac04
Scooby Specialist
 
Member#: 49895
Join Date: Dec 2003
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
09 Forester
06 Legacy 2.5i Wagon

Default

Quote:
Originally Posted by Roro
Anyone know a how-to on pulling it?
I checked my factory service manual. Basically, it says to disconnect the battery, pull up the carpet, pull off the shield, unpluge the ECU, then remove. It looks really simple.
jac04 is offline   Reply With Quote
Old 04-05-2005, 04:29 PM   #12
Roro
Scooby Newbie
 
Member#: 79361
Join Date: Jan 2005
Location: Alabama
Vehicle:
2004 WRX Wagon
San Remo Red

Default

Well I left scott a message so I hope he knows if Subaru can just reflash it. I don't have the money to be carless for a few days...
Roro is offline   Reply With Quote
Old 04-05-2005, 06:43 PM   #13
finnRex
RIP Donny
Moderator
 
Member#: 21095
Join Date: Jul 2002
Chapter/Region: TXIC
Location: Miss you, Charlie Murphy.
Vehicle:
RIP KTH & LMFH
'09 Crystal red Tintcoat

Default

Dude, I hope you get everything straightened out. Sorry to hear that you're gonna have to be out of your car for a few days.



Mika
finnRex is offline   Reply With Quote
Old 04-05-2005, 08:21 PM   #14
Drews_WRX
Scooby Specialist
 
Member#: 20354
Join Date: Jun 2002
Chapter/Region: SCIC
Location: Rancho Cucamonga, CA
Vehicle:
2005 SRT-4
POS Mopar stage 2

Default

Havent really read this thread but just wanted to give props to Trey@COBB for his timely responses to my emails.....he responded in less than 10 minutes with the answers I was looking for.

btw- I have COBB AP stage 2 and the company has been nothing but the best to work with. Customer service/support is high on my list. And now the street tuner....now they have good products.
Drews_WRX is offline   Reply With Quote
Old 04-06-2005, 10:55 AM   #15
Roro
Scooby Newbie
 
Member#: 79361
Join Date: Jan 2005
Location: Alabama
Vehicle:
2004 WRX Wagon
San Remo Red

Default

Anyone have a spare ecu I can borrow?
Roro is offline   Reply With Quote
Old 04-12-2005, 12:03 AM   #16
John__Gotti
Scooby Specialist
 
Member#: 70598
Join Date: Sep 2004
Chapter/Region: W. Canada
Location: Red Deer, Alberta
Vehicle:
The Oil patch, as
fun as it sounds

Default

Funny, the first AP I bought was from a guy who didn't unmarry it from his ecu after he traded it in for a sti. Can't believe people are still doing this.
John__Gotti is offline   Reply With Quote
Old 04-12-2005, 01:53 PM   #17
The Professor
Scooby Newbie
 
Member#: 23183
Join Date: Aug 2002
Chapter/Region: Tri-State
Location: PA
Vehicle:
2002 Cobb StageIIWRX
WR Blue

Default

Many of them probably don't realize what they are doing and are focused on their new toy (STi) since they clearly could not or were unwilling to do what it took to get enough "go" out of the WRX. When you go in to look at an STi (not buy one) and the salesman makes you an offer you are too excited to shop around (ALWAYS SHOP AROUND) and you buy the damn thing that night after 6 hours of negotiation......the last thing on your mind is unmarrying your AP.
As far as fixing yours I would think it pretty easy to fix. The ECU can be removed by my wife in minutes. It's under the passenger side carpet. If the dealer won't help by clearing out the ecu with a reflash (they should) send it to Cobb and they should be able to correct it. Annoying...but totally correctable.
The Professor is offline   Reply With Quote
Old 04-12-2005, 10:15 PM   #18
bmwm750
Scooby Newbie
 
Member#: 84359
Join Date: Apr 2005
Location: Rochester NY
Vehicle:
2005 WRX STi
Silver

Default

I recently looked into purchasing a used AP for my 05 STi. Apparently the guy didnt umarry it properly. I called COBB and they will re-set it for $395. Needless to say I didn't purchase that and just didnt want the risk/hassle of buying used to I got a new one. Extremely happy with it.

The only thought I'd have to your problem is either send the ECU to Cobb (I would think they could clear it out), have the dealer re-flash it and erase the Cobb map and marrying info, or replace the ECU.

I would try to have the dealer get ahold of the guy who traded it in and see if he still has the AP to unmarry it. If you bought it from a dealer they really should work with you to take care of this.
bmwm750 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New car - and for once, it's not a Subaru. :shock: Teh Legacy Off-Topic 35 04-07-2008 06:41 AM
Cobb vs not-Cobb WJM South East Region Forum 121 01-22-2005 08:45 PM
My new car wont run, possibly not all cylinders working??? grundig5 Factory 2.0L Turbo Powertrain 26 04-22-2004 01:25 PM
Well, got a new car... and no its not a Subie sjt Bay Area Impreza Club Forum -- BAIC 25 12-19-2001 01:44 AM


All times are GMT -4. The time now is 11:46 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.