Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid West Subaru Owners Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid West Subaru Owners Club Forum -- MWSOC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-13-2005, 09:38 PM   #1
underground-mpyre
Scooby Specialist
 
Member#: 30351
Join Date: Nov 2002
Location: Indianapolis
Vehicle:
1999 GC8 STI V7 6spd
Silver Coupe

OMGHi2U Hks intake and a check engine light.

I have a HKS intake and I get a check engine light. Now before I start, I have OBDII tested and get twice MAF sensor failure. Is it do to the intake(which a few has said) or the MAF bad? Someone also said to check if it is the intake to unplug the ECU for 15 minutes to reset it, would that test really work? I don't mind replacing the MAF, but would like to try other things before I spend the money. By the way, I am getting real $h!tty gas mileage
* Registered users of the site do not see these ads.
underground-mpyre is offline   Reply With Quote
Old 04-14-2005, 04:20 PM   #2
underground-mpyre
Scooby Specialist
 
Member#: 30351
Join Date: Nov 2002
Location: Indianapolis
Vehicle:
1999 GC8 STI V7 6spd
Silver Coupe

Default

bump. help please
underground-mpyre is offline   Reply With Quote
Old 04-14-2005, 04:59 PM   #3
RiftsWRX
Scooby Guru
 
Member#: 6124
Join Date: Apr 2001
Chapter/Region: MWSOC
Location: Glendale Hts, IL, USA
Vehicle:
2000 NFR AP1 S2000
'07 Honda FIT sport (5MT)

Default

Quote:
Originally Posted by underground-mpyre
I have a HKS intake and I get a check engine light. Now before I start, I have OBDII tested and get twice MAF sensor failure. Is it do to the intake(which a few has said) or the MAF bad? Someone also said to check if it is the intake to unplug the ECU for 15 minutes to reset it, would that test really work? I don't mind replacing the MAF, but would like to try other things before I spend the money. By the way, I am getting real $h!tty gas mileage
I notice you have a swap. Is it a full swap? Down to the harnesses and ECU?

Also, is the sensor in the right way? The plug should face the FRONT of the car, finally the sensor should be straight up and down, it WILL throw a wrong signal if it's cocked to one side.

Hmmm

Also, have you tried a stock airbox lid, for example?

What is te EXACT code you're throwing?

Jorge (RiftsWRX)
www.ProjectWRX.com
RiftsWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hks and a check engine light underground-mpyre Factory 2.0L Turbo Powertrain 2 04-14-2005 04:24 PM
HKS intake and a check engine light. underground-mpyre Engine Management & Tuning 0 04-13-2005 09:34 PM
HKS intake and a check engine light underground-mpyre Subaru Conversions 0 04-13-2005 08:50 PM
new intake and check engine light nyyankees003 Legacy Forum 4 10-06-2004 11:46 PM
...i'm in pasadena and my check engine light is on... tre.c Southern California Impreza Club Forum -- SCIC 4 07-27-2004 10:34 PM


All times are GMT -4. The time now is 04:37 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.