Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-16-2005, 02:04 PM   #1
IllNastyImpreza
Scooby Guru
 
Member#: 36333
Join Date: May 2003
Chapter/Region: NESIC
Location: East Kingston NH
Vehicle:
DIY project: life
I need more TIME!

Default check engine light came on...why did yours?

Ok so my 97 L is still running great, BUT...I was driving yesterday and out of the blue, the dreaded CEL comes on ! why is this happening to me! I just bought the car like 2 months ago! 76,000 on the clock.

My question is, have u ever got a CEL? Why? when? what the hell would cause it to come on?
* Registered users of the site do not see these ads.

Last edited by IllNastyImpreza; 04-26-2005 at 03:31 AM.
IllNastyImpreza is offline   Reply With Quote
Old 04-16-2005, 02:15 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

This is really a service and maintenance question rather than engine management.
Your CEL is telling you that the ECU has detected one or more of over a hundred or so potential problems and set a trouble code. In order to find the actual problem and fix it, you have to get the code(s) read. You can go to Autozone where they do this for free, or find someone in your local forum with a scanner who can read it for you.
Until you do this, and then post the code along with your vehicle information in the proper forum (Service) we can't help you any further.
Mulder is offline   Reply With Quote
Old 04-20-2005, 12:14 AM   #3
IllNastyImpreza
Scooby Guru
 
Member#: 36333
Join Date: May 2003
Chapter/Region: NESIC
Location: East Kingston NH
Vehicle:
DIY project: life
I need more TIME!

Default

I was more wondering why other people got CELS...
Mine is emissions related, so I'm not sure If I really care or not...I think its just running rich.

My budy(dodge tech.) told me that the government will pay for a new cat if destroyed before 80,000 miles. Is this true for Subaru's also?
IllNastyImpreza is offline   Reply With Quote
Old 04-20-2005, 06:46 AM   #4
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Other people get CELs for many different reasons. There is no way to compare your situation to anyone else's until you have it scanned and post the code. Most codes are considered "emission related" so that doesn't narrow it down. And, "just running rich" is not good at all, over time a rich condition will cause the cat to overheat and eventually clog.
There is an 8/80 emission warranty that covers the cat(s) and ECU. However if there is a problem that is causing rich running it must be corrected before the cat is replaced, or the new one will be ruined as well.
Mulder is offline   Reply With Quote
Old 04-26-2005, 03:30 AM   #5
IllNastyImpreza
Scooby Guru
 
Member#: 36333
Join Date: May 2003
Chapter/Region: NESIC
Location: East Kingston NH
Vehicle:
DIY project: life
I need more TIME!

Default

The guy @ autozone just told me it was emissions related. He said to get an exact code I would have to go to the dealer. Is where anywhere else I can get it read to find out the code?
IllNastyImpreza is offline   Reply With Quote
Old 04-26-2005, 07:05 AM   #6
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

That's BS, he could have easily given you the code but for some reason chose not to. Find another Autozone that is more cooperative, or post in NESIC for help.
Mulder is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
('93-'01) Check Engine Light came on 96Imprezer Impreza Forum 1 04-16-2001 10:25 AM
Installed S-AFC, Check Engine light came on... HELP! JP Money Technical Forum Archive 14 09-06-2000 09:52 AM


All times are GMT -4. The time now is 11:32 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.