Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-16-2005, 06:15 PM   #1
xcntrk75
Scooby Specialist
 
Member#: 60224
Join Date: Apr 2004
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2008 FXT Sports 2.5
Dark Grey Metallic

Default Speedometer Help Needed…

I finished my WRX engine and transmission swap and can’t seem to get my speedometer working. I know my VSS is working and have the proper speed signal at my ECU as confirmed by my OBD-II reader and multi-meter (0v – 5v alternating). My problem is with the difference in wiring at the combination meter between my 98 Legacy, and that of my WRX VSS.

My existing speedometer gauge originally had a 2-wire VSS direct feed (from my old tranny), then sent the speed signal output to my original ECU as seen here:


I’m now running a WRX transmission which is using the 3-wire VSS (1-power, 1-ground, 1-speed signal). I have the speed signal directly feeding my new ECU and connected to what use to be the output wire in the diagram above. Obviously this isn’t working. The original two VSS wires aren’t hooked up to anything either. I tried feeding the speed signal to each of these wires individually with no luck.

WRX VSS & Combination Meter wiring as a reference:


Anybody who has any advice or input please respond as I’m at my wits-end.
* Registered users of the site do not see these ads.
xcntrk75 is offline   Reply With Quote
Old 04-17-2005, 06:06 PM   #2
xcntrk75
Scooby Specialist
 
Member#: 60224
Join Date: Apr 2004
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2008 FXT Sports 2.5
Dark Grey Metallic

Default

Anybody swap transmissions over and get their speedo working?

All comments appreciated…
xcntrk75 is offline   Reply With Quote
Old 04-17-2005, 10:44 PM   #3
agterlik
Scooby Specialist
 
Member#: 41626
Join Date: Aug 2003
Chapter/Region: NWIC
Location: Mt Vernon, WA
Vehicle:
SPB We make people
quit teh internet

Default

Wouldnt you want to hook the signal going from the ecu to the input signal on the combination meter?
agterlik is offline   Reply With Quote
Old 04-18-2005, 07:26 AM   #4
xcntrk75
Scooby Specialist
 
Member#: 60224
Join Date: Apr 2004
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2008 FXT Sports 2.5
Dark Grey Metallic

Default

Beats me, that’s why I’m asking…

Seriously though, if I were to hook it up as my original was, I would feed the speed signal from the VSS to my speedometer, then feed the output to my ECU. I haven’t tried this yet mainly because my speedo wants a two-wire input from the VSS and my new WRX one is only one-wire.

Anybody….thoughts…comments…
xcntrk75 is offline   Reply With Quote
Old 04-18-2005, 11:46 AM   #5
Jaxx
NASIOC Supporter
 
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Boise,Idaho,USA
Vehicle:
The 93 Imp W/EJ20K
flat black

Default

the second wire is power to make the sensor work
i would try tranny->ecu->pin 5

edit: now that i think abou it
use the 98 speed sensor
tranny->speedo->ecu

Last edited by Jaxx; 04-18-2005 at 11:59 AM.
Jaxx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help needed with coilover installation - VA (Woodbridge/Manassas) dc.fireman Mid Atlantic Impreza Club -- MAIC 24 06-06-2010 12:04 AM
Speedometer off.. need help! Drake13 Electrical & Lighting 11 07-14-2008 11:18 PM
speedometer help 25rsESP Electrical & Lighting 2 01-10-2007 07:15 AM
speedometer help winorlose2221 Newbies & FAQs 3 08-04-2006 01:52 PM
speedometer help winorlose2221 Texas Impreza Club Forum -- TXIC 0 08-04-2006 01:54 AM


All times are GMT -4. The time now is 01:39 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.