Welcome to the North American Subaru Impreza Owners Club Friday December 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Canada Region Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Regional Areas > Canada Region Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-26-2001, 01:30 AM   #1
chinaman
Scooby Newbie
 
Member#: 6731
Join Date: May 2001
Location: edmonton
Vehicle:
2000 2.5rs
perl blue

Default To edmonton scooby owner. did u recieve from the dealer

it said our car is needed to replace a new fron oxygen (air/fuel ration) sensor.

do we need to replace it ? ?

by oly the 2000 model year subaur legacy and out back with auto transmiisino and the 2.5 rs stick and auto will recieve this letter.
* Registered users of the site do not see these ads.
chinaman is offline   Reply With Quote
Old 07-26-2001, 02:16 AM   #2
FengShui
Scooby Specialist
 
Member#: 6300
Join Date: May 2001
Location: Formerly E-town, Houston Now
Default

2000 2.5RS Impreza too? i did not receive any thing in the mail.
Mark, Chris, anyone receive a recall?

Peace out,
Mykael
FengShui is offline   Reply With Quote
Old 07-26-2001, 02:53 AM   #3
markus
Scooby Specialist
 
Member#: 438
Join Date: Oct 1999
Chapter/Region: W. Canada
Location: St. Albert, AB, Canada
Vehicle:
2004 STi
White on Gold

Default It's taken them long enought to get these out!!!

Yup!

Got it in today's mail. I've been expecting this one for about 8 months already.

If its anything like the O2 sensor that went on the wife's Legacy, when the O2 sensor goes, it takes part of the ECU with it.

This is a common failure with the MY2000 MAP system and you should simply take it in for a warranty replacement once you get the letter.

No worries, just take the car in and get let SOC take care of it.
markus is offline   Reply With Quote
Old 07-26-2001, 07:31 PM   #4
chinaman
Scooby Newbie
 
Member#: 6731
Join Date: May 2001
Location: edmonton
Vehicle:
2000 2.5rs
perl blue

Thumbs down WHAT

haha
ok, i was driving home after summer school!
guess what!
my engine light REALLY did went on!!!
guess i have tot ake it to the dealer now!
subaru do predict things right!

Anyone got their engine light went on ????
anyone?
chinaman is offline   Reply With Quote
Old 07-26-2001, 07:36 PM   #5
chinaman
Scooby Newbie
 
Member#: 6731
Join Date: May 2001
Location: edmonton
Vehicle:
2000 2.5rs
perl blue

Default

by the way
this is not a big problem right?
caz i dun plan to take it to the dealer tomorow.
maybe sat. or somthing.
is that aligrht?
any advice?
chinaman is offline   Reply With Quote
Old 07-26-2001, 09:21 PM   #6
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

i haven't gotten any sort of a letter or anything. they might have mailed it to beaverlodge where i live. is the letter needed for the o2 sensor recall?
inpreza kid is offline   Reply With Quote
Old 07-26-2001, 09:49 PM   #7
FengShui
Scooby Specialist
 
Member#: 6300
Join Date: May 2001
Location: Formerly E-town, Houston Now
Default

Fellas,

Went to SC after i got my letter . They are busy like HEll. Got an appointment for next Thursday morning (02 sensor change). Not all cars are affected apparently but still they are changing it. Same time changing my rear sway bar from stock 13mm to 18mm.
Dealing with mechanic, Paul Swanson, the expert on Impreza. By the way the Blue impreza with the body kit, saskatchewan plate, is in the shop. Blown gasket??.....Quite a mess.
Any date set up for the Red Deer meet in August?

Peace out,
Mykael
FengShui is offline   Reply With Quote
Old 07-27-2001, 12:55 AM   #8
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

i can be worng but i think the blue one has nitrous on it. i seen it at subaru city when i was getting my rear bearing replaced.
inpreza kid is offline   Reply With Quote
Old 07-27-2001, 03:52 AM   #9
chinaman
Scooby Newbie
 
Member#: 6731
Join Date: May 2001
Location: edmonton
Vehicle:
2000 2.5rs
perl blue

Default

what's wrong with that blue impreza wiht nos? ?
chinaman is offline   Reply With Quote
Old 08-01-2001, 07:45 AM   #10
V6
Scooby Specialist
 
Member#: 2703
Join Date: Oct 2000
Location: Edmonton, AB
Vehicle:
Y2K GC8
Silver forever

Default

So have all i-club E-town MY00-01 RS owners have reveived the letter and changed the O2 sensor?

PS. I also did not receive any letter from Subaru also.

So is that I can just drive my car to Subaru and ask them to replace the O2 sensor for free without any question asked?

I remember when I just bought my car I ask them so I need to change the O2 sensor coz all US RS need to replace the O2 sensor, but those guys in the service department (in front of the computer, etc...) said just the US RS need to be fix because of the weather in US.

Now I am sure that those guys in the service department don't really know the RS really well.
V6 is offline   Reply With Quote
Old 08-01-2001, 11:53 AM   #11
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

v6 i haven't gotten any sort of recall letters too. maybe us auto guys aren't infected. haha.
inpreza kid is offline   Reply With Quote
Old 08-01-2001, 03:34 PM   #12
schlong8
Scooby Specialist
 
Member#: 2104
Join Date: Aug 2000
Chapter/Region: W. Canada
Location: Edmonton, Alberta, Canada
Vehicle:
MY00 2.5RS
Silverthorne

Default

I haven't gotten my letter either....and i have a 5spd.
schlong8 is offline   Reply With Quote
Old 08-01-2001, 05:54 PM   #13
Keiho
Sea to Sky - OWNED
Moderator
 
Member#: 610
Join Date: Dec 1999
Chapter/Region: VIC
Location: Vancouver, BC, Canada
Vehicle:
2003 Lexus IS300
Graphite Gray Pearl

Default

I got mine.

No more stupid CEL for me.

And the head mechanic at a dealer said it was my exhaust that was causing the problem...
Keiho is offline   Reply With Quote
Old 08-01-2001, 06:13 PM   #14
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

so not all of us are infected?
inpreza kid is offline   Reply With Quote
Old 08-01-2001, 10:02 PM   #15
Penphoe
Friendly Neighbourhood
Moderator
 
Member#: 269
Join Date: Sep 1999
Chapter/Region: VIC
Location: Burnaby, B.C., Canada
Vehicle:
2005 ABP LGT LTD BP6
00 Impreza RS GM6 RIP

Default What's your VIN?

I don't have mine with me right now, but I have NOT received a letter like that from SOC. I've got one of the earliest MY00's - built in July 1999.

LaterZ!
Darren!!
Penphoe is offline   Reply With Quote
Old 08-01-2001, 10:54 PM   #16
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

Penphoe i have one of the earlier built impreza's too. last 4 digits of my vin is 2379. haha. i guess its a good thing that not all of us are infected.
inpreza kid is offline   Reply With Quote
Old 08-01-2001, 11:17 PM   #17
ratpaws
Scooby Newbie
 
Member#: 4471
Join Date: Feb 2001
Location: Edmonton, AB, Canada
Default

I just got my notice in the mail today, so my guess is that they are sending them out in stages so as not to overwhelm the dealerships. I have had no trouble so far but I plan to make an appointment to have the change done as a pro-active step to ensure that nothing does happen.
BTW I also have an early MY00 2.5 I took delivery in early November 99 and the last four digits of my VIN are 1473.
ratpaws is offline   Reply With Quote
Old 08-02-2001, 12:21 AM   #18
Penphoe
Friendly Neighbourhood
Moderator
 
Member#: 269
Join Date: Sep 1999
Chapter/Region: VIC
Location: Burnaby, B.C., Canada
Vehicle:
2005 ABP LGT LTD BP6
00 Impreza RS GM6 RIP

Default Guess what I got...

Yup. Got home from school this evening, and there was the SOC letter waiting for me. It doesn't say anything about all vehicles must have their O2 sensor changed, it just says that some vehicles MAY have to have their O2 sensor changed.

Me, I have had only 1 CE light, and that was for something else. I'm going to talk to my dealership here in Vancouver about it. I doubt if I'll need to bring my car in. Never had any problems with it.

And here's the last 4 digits of my VIN - 0809. Yup, it's an early one!

LaterZ!
Darren!!
Penphoe is offline   Reply With Quote
Old 08-02-2001, 12:32 AM   #19
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

wow. i guess most to all impreza owners are going to get this letter. oh well. whats not to like about getting a free new o2 sensor.
inpreza kid is offline   Reply With Quote
Old 09-03-2001, 10:20 PM   #20
tulit
Scooby Specialist
 
Member#: 338
Join Date: Sep 1999
Chapter/Region: E. Canada
Location: Toronto
Vehicle:
09 STi
White

Default

hehe. I have you all beat. I have Impreza #0073.

I haven't had a problem with my front O2 yet, though my rear O2 went bad.

Has anyone had their O2 sensor replaced yet? What exactly did they do? If its just the front O2, thats fine, but I dont want them changing the ECU.

Thanks.
tulit is offline   Reply With Quote
Old 09-03-2001, 10:52 PM   #21
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

i got mine changed about 2 weeks ago. they replaced the front o2 sensor. it took 30 for the car to cool down and another 15 or so to change the o2 sensor so 45mins in all. i don't think they did anything to the ecu but check for codes.
inpreza kid is offline   Reply With Quote
Old 09-03-2001, 11:03 PM   #22
Keiho
Sea to Sky - OWNED
Moderator
 
Member#: 610
Join Date: Dec 1999
Chapter/Region: VIC
Location: Vancouver, BC, Canada
Vehicle:
2003 Lexus IS300
Graphite Gray Pearl

Default

Well, for what it's worth...I got a new O2 sensor...and I still got a CE light after that. I just reset the bloody thing and it hasn't come back yet, though I'm sure it will. The quirks of owning such a funky car I guess.
Keiho is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What did you get as a loaner car from the dealer? Chandy69 Warranty Issues & SOA Problems 44 02-06-2008 12:45 PM
Did SOA override your warranty denial from the dealer? ItalianGuy Transmission (AT/MT) & Driveline 21 08-09-2007 05:31 PM
Did anyone else get this from the dealer in Brooklyn? Bbasso Tri-State Area Forum 7 05-14-2007 10:36 AM
IF anyone is going to buy somethin from the dealer anytime soonnn.... szeny SWIC Private Classifieds 12 01-02-2007 11:14 AM
Do you need to buy from the dealer who will do service on your car? RhinoRex Newbies & FAQs 2 03-23-2003 06:41 AM


All times are GMT -4. The time now is 09:44 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.