Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-19-2005, 01:53 AM   #1
happyparrot
Scooby Newbie
 
Member#: 61896
Join Date: May 2004
Location: Kirkland, Wa.
Vehicle:
1998 2.5rs S/C
RBP

Unhappy I think I blew a piston ring or cracked my head, what do you think?

The car drives normally and sounds normal, but today after I took her out for a spin the oil light was flickering. So I turned her off and checked the oil levels and there was plenty of oil. But as I was removing the dip-stick it sucked in a huge amount of air. So I started up the car and removed the oil cap, there was air puffing in and out of the oil fill tube. I smelled the air and it had a hint of fuel. So here's what I'm thinking it can be:
- I cracked the head and the compressed air is pushed into the oil lines.
- I blew a oil seal O-ring on the piston with same result
- Bad PCV (somehow forcing air inside the crank case???)
Here's the strange thing, you would think that with one cylinder loosing so much compression the engine would misfire, but it hasn't and it's running as smooth as new. I'll do a compression check on Saturday to see what's going on the inside.
I would like your input as far as what you think it is? Anyone else experience this? If someone wouldn't mind doing me a favor, go out to your car start it up, remove the oil cap and see if it sucks air in and spurts it out, maybe it's supposed to do it .
Thanks for your responses
-Daniel
* Registered users of the site do not see these ads.
happyparrot is offline   Reply With Quote
Old 04-19-2005, 11:52 AM   #2
powerlabs
Scooby Specialist
 
Member#: 45790
Join Date: Oct 2003
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2006 Corvette C6 Z51
SUPERCHARGED

Default

Nope, no pressure fluctuations with the oil cap open.
powerlabs is offline   Reply With Quote
Old 04-19-2005, 02:21 PM   #3
happyparrot
Scooby Newbie
 
Member#: 61896
Join Date: May 2004
Location: Kirkland, Wa.
Vehicle:
1998 2.5rs S/C
RBP

Default

Quote:
Originally Posted by powerlabs
Nope, no pressure fluctuations with the oil cap open.
Thanks for checking it out, now there is no doubt I have a problem
happyparrot is offline   Reply With Quote
Old 04-19-2005, 05:29 PM   #4
sidewayz
Scooby Specialist
 
Member#: 5810
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: Easton PA
Vehicle:
2001 S366 2.5RS

Default

it is normal for any car to make "puffing" noises with the oil cap off. its called valve over lap. dont sweat it.
You could have a bad oil pressure sender. its located right behind the alt.
sidewayz is offline   Reply With Quote
Old 04-19-2005, 05:56 PM   #5
happyparrot
Scooby Newbie
 
Member#: 61896
Join Date: May 2004
Location: Kirkland, Wa.
Vehicle:
1998 2.5rs S/C
RBP

Default

Quote:
Originally Posted by sidewayz
it is normal for any car to make "puffing" noises with the oil cap off. its called valve over lap. dont sweat it.
You could have a bad oil pressure sender. its located right behind the alt.
I also thought of this, but I'm pretty sure I've removed the oil cap before and it didn't do the air puffing thing before.
I checked the compression today, here are my results:
cyl 1: 175psi
cyl 2: 176psi
cyl 3: 175psi
cyl 4: 178psi
happyparrot is offline   Reply With Quote
Old 04-19-2005, 05:59 PM   #6
OneOBS
Scooby Specialist
 
Member#: 63076
Join Date: May 2004
Location: Caulifornia
Vehicle:
2004 Outback Sport
Red!

Default

Sounds like you have nothing to worry about. It could easily just be the oil pressure sender. What weight oil are you running?
OneOBS is offline   Reply With Quote
Old 04-19-2005, 06:45 PM   #7
Tim Sanderson
Scooby Guru
 
Member#: 6486
Join Date: May 2001
Chapter/Region: MWSOC
Location: S.E. wisconsin
Vehicle:
00 Impreza 2.5 RS
Blue Ridge Pearl

Default

Remove oil pressure sender and install a mechanical oil guage in there and see what your oil pressure is. It's 1/8" npt. Get a guage that goes to at least 80 psi. Once you determine that your oil pressure is good then you can condemn the pressure sender.
Tim Sanderson is offline   Reply With Quote
Old 04-19-2005, 07:24 PM   #8
happyparrot
Scooby Newbie
 
Member#: 61896
Join Date: May 2004
Location: Kirkland, Wa.
Vehicle:
1998 2.5rs S/C
RBP

Default

Thanks a lot for the input guys, I'll go install a mechanical oil pressure gauge on the car with in the next 4 hours (after I finish home work) I'll let you know what my oil pressure readings are.
Ones again thanks for the input it is really appreciated.
happyparrot is offline   Reply With Quote
Old 04-19-2005, 11:07 PM   #9
twizzstyle
Scooby Guru
 
Member#: 18941
Join Date: May 2002
Chapter/Region: NWIC
Location: Kenmore, Washington
Vehicle:
2005 Lotus Elise
Orange

Default

check your PM's (about that bumper!)
twizzstyle is offline   Reply With Quote
Old 04-20-2005, 12:41 AM   #10
happyparrot
Scooby Newbie
 
Member#: 61896
Join Date: May 2004
Location: Kirkland, Wa.
Vehicle:
1998 2.5rs S/C
RBP

Default

Quote:
Originally Posted by twizzstyle
check your PM's (about that bumper!)
I did, I'm waiting on an answer from my brother, I'll let you know as soon as I hear something.
I checked the oil pressure, and its
about 85-90psi at idle.
happyparrot is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My plans for upgrading my suspension, what do you think/Question shamrock 05 Brakes, Steering & Suspension 28 05-15-2009 10:55 PM
Thinking of changing my Rims.. what do you think? brcewane Interior & Exterior Modification 7 03-06-2005 08:54 PM
Upgrading my old Omori gauges for my STi, what do you think? Corn-Picker Interior & Exterior Modification 21 12-29-2004 03:23 PM
Keep my '01 RS, or get a WRX? What do you think? IMPRZME General Community 25 05-18-2002 07:10 PM
18's on my Subie, what do you think??? Rimmie General Forum Archive 32 06-24-2000 03:07 PM


All times are GMT -4. The time now is 06:09 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.