Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-17-2005, 04:40 PM   #1
taphonomist
Scooby Newbie
 
Member#: 58654
Join Date: Apr 2004
Location: Cincinnati, OH
Vehicle:
2002 WRX
bLue

Default Cooling system problem?

I just did a complete radiator flush, and when I was burping the hoses, I heard a clicking sound down near the thermostat for each burp. It's clearly something being kicked around as the coolant is flowing. I'm not sure, but it sounds like a little piece of metal or a rock or something like that. Is this something that I should be worried about? I revved it up to see if driving the water pump harder might flush it out, but no dice. I'm wondering if there is just something sitting right in front of the thermostat, and I just need to get it completely warmed up and then rev it to flush it out. I hate sunday projects when work comes so early on monday!!!

taphonomist
* Registered users of the site do not see these ads.
taphonomist is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cooling system problem gakusya Service & Maintenance 15 02-11-2011 09:00 PM
"Burping" Cooling System Problems.. STI_KLR Factory 2.0L Turbo Powertrain 31 11-03-2008 03:16 PM
Cooling system problem - car idles at 3k racer_x Factory 2.0L Turbo Powertrain 5 10-22-2008 01:28 PM
i have a big cooling system problem! TheBryman Service & Maintenance 11 06-12-2007 02:21 PM
I'm confused. Cooling system problems... fastenova Legacy Forum 10 04-16-2005 10:15 PM


All times are GMT -4. The time now is 07:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.