Welcome to the North American Subaru Impreza Owners Club Thursday September 3, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-21-2005, 06:49 PM   #1
dlewis
Scooby Newbie
 
Member#: 76948
Join Date: Dec 2004
Chapter/Region: NESIC
Location: Portland, ME
Vehicle:
2002 Impreza Wrx
WRB

Default Smoke After New turbo Install

Hey guys, I just installed a SBR gtr-12 turbo on my Wrx along with rc engineering 650cc injectors and heat range 7 plugs. Im getting a lot of smoke it appears to be coolant smoke when I get on my car. Its untuned as of now but that will change shortly. When it smokes its a huge cloud of smoke like its just pouring out. What could be the problem? I smelt it it smells like coolant. When I just drive easy it doesnt smoke at all but as soon as I begin to boost it will smoke. I replaced this from my stocker because the stock turbo had its oil seals going and it also would smoke when i got on it. What do you gurus think could possibly be wrong with this?
* Registered users of the site do not see these ads.
dlewis is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-21-2005, 07:07 PM   #2
Starkiller
Scooby Specialist
 
Member#: 82741
Join Date: Mar 2005
Chapter/Region: NESIC
Location: Bristol, CT
Vehicle:
2007 350Z Silver

Default

Is your new turbo water cooled? If it isn't, hopefully you closed up the old coolant line that went into the stock turbo.
Starkiller is offline   Reply With Quote
Old 04-21-2005, 07:12 PM   #3
dlewis
Scooby Newbie
 
Member#: 76948
Join Date: Dec 2004
Chapter/Region: NESIC
Location: Portland, ME
Vehicle:
2002 Impreza Wrx
WRB

Default

the slowboy racing turbo is oil and water cooled.It beats me on what it could be.
dlewis is offline   Reply With Quote
Old 04-21-2005, 07:48 PM   #4
dlewis
Scooby Newbie
 
Member#: 76948
Join Date: Dec 2004
Chapter/Region: NESIC
Location: Portland, ME
Vehicle:
2002 Impreza Wrx
WRB

Default

bump..
dlewis is offline   Reply With Quote
Old 04-21-2005, 08:14 PM   #5
overdose
Scooby Specialist
 
Member#: 46399
Join Date: Oct 2003
Chapter/Region: MWSOC
Location: Grand Rapids, MI
Vehicle:
0000 Knows nothing,
about nothing.

Default

Check the IACV gasket, pressurize the charge pipe and see what leaks, check the compression with all the plugs out yadda yadda
overdose is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
? about after my new turbo install mucky Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 04-22-2008 09:55 AM
After new turbo install, feels like fuel cut-off at 7psi.... WRXfoME Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 10-19-2007 02:43 PM
new turbo installed. smoke screen, low o2 voltage, no boost chris124816 Normally Aspirated with bolt-on Forced Induction Powertrain 24 01-20-2006 06:44 AM
how much est. horses...after new turbo and IC install SWEETWRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 0 08-29-2002 03:45 PM
Is it normal for a car to smoke after an uppie installation? Corn-Picker Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 02-11-2002 03:58 AM


All times are GMT -4. The time now is 04:58 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.