Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-26-2005, 01:52 AM   #1
Jobey
Scooby Newbie
 
Member#: 75679
Join Date: Nov 2004
Default my Front O2 sensor caused CEL, will I pass Emissions??

MY 2002 Impreza 2.5RS

I need to get emissions done this week..
don't really have the $$ or time this week to fix the CEL problem that was triggered by the front O2 sensor (code was found by dealer when scanned)

Anyone know if this would pass emissions??
Any tips to help it pass better? Run the cat HOT...use high octane gas..etc..
* Registered users of the site do not see these ads.
Jobey is offline   Reply With Quote
Old 04-26-2005, 07:07 AM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
05 GTO/11 Sonata(!)

Default

What state are you in? It depends on the emission inspection program in your particular state and locality. If they do an OBDII scan you will definitely fail, even if they don't you may still fail for the CEL.
Mulder is offline   Reply With Quote
Old 04-26-2005, 12:06 PM   #3
Jobey
Scooby Newbie
 
Member#: 75679
Join Date: Nov 2004
Default

I'm in Toronto, Canada..
Jobey is offline   Reply With Quote
Old 04-26-2005, 12:59 PM   #4
UkNuck
Scooby Guru
 
Member#: 21808
Join Date: Jul 2002
Chapter/Region: E. Canada
Location: National Capital Region
Vehicle:
02 GroceryGettAr
Nonemore Black

Default

Def. the _front_ one?

If so I'd have thought you'd have other issues besides emissions... did the dealer clear the CEL (and if so, why?) Do you have the actual code? Any mods?

I just passed Ontario emissions with a borderline P0420 _rear_ O2 code (basically on and off all winter - in fact came on again the day after the test), due to having only a single hi-flow cat. That's on a wrx where there's supposed to be 3. The NO and HC were still WAY below limits.

I don't know what would've happened if I'd had the code at the time of the test. I believe they use OBDII _at least_ to poll the cat temp - they told me mine was not up to temp when they hooked it up (despite a 25 min drive) and the machine made them go through a '3 min warm up' before taking the readings.
UkNuck is online now   Reply With Quote
Old 04-27-2005, 06:52 PM   #5
Jobey
Scooby Newbie
 
Member#: 75679
Join Date: Nov 2004
Default

Def the front one..
the code the dealer pulled up was P0130
cleared it...and hasn't came back

I went to get emissions...since the light was off...and passed..
bone stock car though..
Jobey is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Time to replace my front o2 sensor... BlkTS02 Normally Aspirated Powertrain 13 07-30-2011 11:36 PM
Front o2 sensor tool in MA? Emissions FAIL! segerton New England Impreza Club Forum -- NESIC 10 03-15-2010 05:59 PM
O2 sensor, will wideband pass emissions sciroccokid Factory 2.0L Turbo Powertrain 2 01-11-2008 09:50 AM
Is my front O2 sensor gone? thejean Factory 2.0L Turbo Powertrain 36 12-04-2006 12:12 AM
Screwed up my front O2 sensor the Dabbler Normally Aspirated with bolt-on Forced Induction Powertrain 10 08-28-2001 12:48 PM


All times are GMT -4. The time now is 09:58 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.