Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-01-2005, 05:55 PM   #1
BlueFish
Scooby Specialist
 
Member#: 50896
Join Date: Dec 2003
Chapter/Region: SCIC
Location: SOCAL
Vehicle:
2006 STi
WRB

Default Help Please

I took my intake manufold out and re instaled it and I removed the TGVs. After I put the mnufold back on the car. I instald Perrin Fuel Rails. Now the car does not go over 10psi. The restrictor on the waist gate is on. What else can cause this problem. Please let me know if you have had this problem.

Thanx
* Registered users of the site do not see these ads.
BlueFish is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need some help please cel plus more!!!! thrasher679 Factory 2.0L Turbo Powertrain 1 06-04-2010 09:21 AM
02 bugeye help...04 blob eye help..please help either or sammyswrxsti Interior & Exterior Modification 18 09-22-2008 02:39 PM
blitz gauge wiring help please PLEASE!!! :) orlandowrx Factory 2.0L Turbo Powertrain 1 10-01-2002 11:36 PM
HELP PLEASE! FINAL STAGE on hella install.. please shoot me with some quick (repost) gerardchau Interior & Exterior Modification 10 02-26-2001 11:29 PM
HELP PLEASE! FINAL STAGE on hella install.. please shoot me with some quick answer! gerardchau General Forum Archive 2 02-20-2001 10:49 PM


All times are GMT -4. The time now is 07:12 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.