Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-04-2005, 06:09 PM   #1
Yellow_turbo
Scooby Newbie
 
Member#: 5937
Join Date: Apr 2001
Location: granby, Canada, Quebec
Vehicle:
2005 Legacy GT
Satin White Pearl

Default Boost Creep Problem

Hi!

I have a STi V5 RA Setup in my car. (Brighton 1999)

Sometimes, in 4-5th gear, i have boost creep...(between 17-19psi)

My car is 99.9% stock Version 5 JDM

- TurboSMart BOV
- STi Usdm Muffler
- Straight through mid-pipe (custom)
- Stock air box
- Stock V5 Catalytic converter

What i think...it's maybe that my catalystic converter is plugged !?!?

Can somebody help me with that !?

Thank you!

Martin
* Registered users of the site do not see these ads.
Yellow_turbo is offline   Reply With Quote
Old 05-06-2005, 09:06 AM   #2
legacy92ej22t
Scooby Specialist
 
Member#: 42659
Join Date: Sep 2003
Chapter/Region: MAIC
Location: Williamsport PA/SilvrSprngs MD
Vehicle:
92 Legacy turbo5mt
All go and no show...

Default

You might have more luck in the conversion forum. Most of the guys here have USDM turbo motors. More people are probably familiar with the JDM setups over there.

What is your stock boost level? Do you run an after market DP?
legacy92ej22t is offline   Reply With Quote
Old 05-07-2005, 04:28 PM   #3
Yellow_turbo
Scooby Newbie
 
Member#: 5937
Join Date: Apr 2001
Location: granby, Canada, Quebec
Vehicle:
2005 Legacy GT
Satin White Pearl

Default

Quote:
Originally Posted by legacy92ej22t
You might have more luck in the conversion forum. Most of the guys here have USDM turbo motors. More people are probably familiar with the JDM setups over there.

What is your stock boost level? Do you run an after market DP?
Thank you!!!

My DP is the stock V5 one!!!

I think that my BOV can be the problem.... It's a TurboSmart V-port ....

I tried to put more tension on the spring (it's adjustable) and i think that it solved the problem... (My problem is Intermittent)

Do you think it's possible...

Thanks

Martin
Yellow_turbo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Particularly Strong Stage I 06 STI AP - Boost Creep Problems Dyno Flash Proven Power Bragging 42 01-13-2007 09:51 PM
Boost Creep Problem... Yellow_turbo Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 05-04-2005 02:48 PM
boost creep problem, where to port wastegate? SilverCWestWRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 03-02-2005 12:34 PM
Boost creep problem Lo0mis Normally Aspirated with bolt-on Forced Induction Powertrain 11 11-30-2003 02:41 PM
Boost creep problem..... Red Rocket Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 11-01-2002 04:34 AM


All times are GMT -4. The time now is 06:49 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.