Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-04-2005, 07:01 PM   #1
Quarintine
Scooby Newbie
 
Member#: 57610
Join Date: Mar 2004
Default ecutek after bc

Ok here is my problem, and maybe someone can make some sense out of it and help me out. A couple of months ago my car ran 1 bar stock, and I installed a Blitz SBC electronic boost controller. Then later I took the car to a Ecutek tuner and put in a pre-programmed map in my car that was supposed to get me 1.4 bar, but for some reason the aftermarket bc only allowed 1.3 bar. So now I removed the bc so that I can get my 1.4 bar from ecutek tune. Except after I removed it I only got 1 bar (stock boost level). Why is that? I checked all my connections and they seem just like it was stock. Do I have to reset my ecu? someone please help.
* Registered users of the site do not see these ads.
Quarintine is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Braking noise after BC racing COs installed choiboi Brakes, Steering & Suspension 5 03-12-2008 09:57 AM
ECUTEK reflash and BC joeyd02 Newbies & FAQs 14 02-02-2005 01:07 AM
new EcuTek dealer in BC patr Vancouver Impreza Club Forum -- VIC 34 10-11-2004 01:47 AM
For sale in MD... engine,dogbox,BC,ECUtek dothespeedlimit Mid Atlantic Impreza Club -- MAIC 9 04-22-2004 03:38 PM


All times are GMT -4. The time now is 01:43 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.