Welcome to the North American Subaru Impreza Owners Club Friday May 27, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 05-16-2005, 03:07 PM   #1
Impreza_RSTi
Scooby Newbie
 
Member#: 86458
Join Date: May 2005
Default Evap sensor problem & P0457 code questions!? plz help.

I got a USDM STi engine swap in my RS. I used my ODBII scanner to pre-test the emission sensors but the Evap sensor is always "not ready" and the code P0457 throw out once a while. I am sure I have tightened the gas cap completely and these problem should be related.

I have checked those hose under the red maniford, no loosing hose was found so far.
anyone has idea what the problem is?
* Registered users of the site do not see these ads.

Last edited by Impreza_RSTi; 05-17-2005 at 05:30 PM.
Impreza_RSTi is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-16-2005, 05:03 PM   #2
subbyspeed
Scooby Specialist
 
Member#: 16274
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Columbus,OH
Vehicle:
2001 GM6 2.0L vf30
e30 black/rust

Default

Between the RS and the wrx, at least the GC to the GD, there is an extra evap sensor thats on the GD. I'd look into that. plus you could have a leak somewhere in the system.. double check any vacuum connections on the engine and by the canister in the back..
subbyspeed is offline   Reply With Quote
Old 05-16-2005, 07:03 PM   #3
SWAT
Scooby Specialist
 
Member#: 12493
Join Date: Nov 2001
Chapter/Region: BAIC
Location: Nor Cal
Vehicle:
2000 Impreza STi V6
White

Default

where is that sensor located at?
SWAT is offline   Reply With Quote
Old 05-17-2005, 11:13 AM   #4
subbyspeed
Scooby Specialist
 
Member#: 16274
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Columbus,OH
Vehicle:
2001 GM6 2.0L vf30
e30 black/rust

Default

i'll have to check my books when i get home.. I'm thinkin in the back by the canister, but i'll look and see.
subbyspeed is offline   Reply With Quote
Old 05-17-2005, 05:30 PM   #5
Impreza_RSTi
Scooby Newbie
 
Member#: 86458
Join Date: May 2005
Default

if you find the answer from ur books, please let me know
Impreza_RSTi is offline   Reply With Quote
Old 05-20-2005, 09:25 PM   #6
Impreza_RSTi
Scooby Newbie
 
Member#: 86458
Join Date: May 2005
Default

the O2 and catalyst sensors take forever to be "ready" if I use ODBII scanner to check, is it normal to all Subarus?
Impreza_RSTi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: STi evap canister with lines and evap sensor (bOOsted) Engine/Power/Exhaust 5 07-15-2013 02:57 PM
HELP!!! Problem with 2nd O2 sensor running a lean code? JTS88 Newbies & FAQs 7 05-25-2009 08:35 PM
EJ22T running rich, O2 sensor wires & error codes in all 4 injectors s'ko Legacy Forum 2 07-09-2008 08:26 AM
P0457 Code Keep getting it Works Engine Management & Tuning 16 07-04-2003 12:19 PM
OBD-II: P0457 code Drews_WRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 0 06-02-2003 06:28 PM

All times are GMT -4. The time now is 08:00 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.