Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-18-2005, 09:22 PM   #1
Inprogress
Scooby Specialist
 
Member#: 65166
Join Date: Jun 2004
Chapter/Region: TXIC
Location: Sugar Land
Vehicle:
2008 EVO X

Default Cel : P0031

Well I got the wires checked out for my P0031 CEL code for the front 02 sensor and the shop said they look fine but they said its possible the CEL is being thrown if the car is running really really rich which in my case my car is running really really rich, does that sound right? Could my CEL for the front 02 sensor be thrown because i'm running so rich? And can i still get my car tuned with this light being on?
* Registered users of the site do not see these ads.
Inprogress is offline   Reply With Quote
Old 05-18-2005, 09:51 PM   #2
fat angel
Scooby Specialist
 
Member#: 81630
Join Date: Feb 2005
Chapter/Region: South East
Location: in the south.
Default

i would call the tuner and ask them if it can still be done. i dont see any reason why it couldnt be done.
fat angel is offline   Reply With Quote
Old 05-18-2005, 09:54 PM   #3
Scooby South
Subtly Outspoken
Moderator
 
Member#: 238
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: 2013 Limited SWP BRZ and a
Vehicle:
99 Ver6 Recreation
JDM Speedwagon 3 LSDs..:)

Default

Clear the code then tune....Ask yourself this.."When I get tuned and paying my hard earned money for the optimum performance I want, Why would I not get the Light fixed to make sure is 100% when I go to the dyno to get the most hp I can??"

I would throw this in as well...Maybe your running rich BECAUSE of the front 02 Sensor is bad...either way...Get it fixed First..

Bill
Scooby South is offline   Reply With Quote
Old 05-18-2005, 09:58 PM   #4
Scooby South
Subtly Outspoken
Moderator
 
Member#: 238
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: 2013 Limited SWP BRZ and a
Vehicle:
99 Ver6 Recreation
JDM Speedwagon 3 LSDs..:)

Default

I will also throw this in...MOST reputable tuners Wont touch the car tuning wise, if there is a issue with a NEEDED sensor..I know we don't..

Bill
Scooby South is offline   Reply With Quote
Old 05-18-2005, 10:44 PM   #5
Inprogress
Scooby Specialist
 
Member#: 65166
Join Date: Jun 2004
Chapter/Region: TXIC
Location: Sugar Land
Vehicle:
2008 EVO X

Default

dang, in that case ya i'll call the shop to double check first and ill take a look at the sensor myself and see whatsup...

thanks
Inprogress is offline   Reply With Quote
Old 05-18-2005, 10:48 PM   #6
Scooby South
Subtly Outspoken
Moderator
 
Member#: 238
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: 2013 Limited SWP BRZ and a
Vehicle:
99 Ver6 Recreation
JDM Speedwagon 3 LSDs..:)

Default

Quote:
Originally Posted by Inprogress
dang, in that case ya i'll call the shop to double check first and ill take a look at the sensor myself and see whatsup...

thanks

Good luck
Scooby South is offline   Reply With Quote
Old 05-18-2005, 10:59 PM   #7
Inprogress
Scooby Specialist
 
Member#: 65166
Join Date: Jun 2004
Chapter/Region: TXIC
Location: Sugar Land
Vehicle:
2008 EVO X

Default

thanks, and ive heard that getting to the primary 02 sensor is a pain, is it something i can flash a light at and just see myself?
Inprogress is offline   Reply With Quote
Old 05-19-2005, 02:35 PM   #8
Inprogress
Scooby Specialist
 
Member#: 65166
Join Date: Jun 2004
Chapter/Region: TXIC
Location: Sugar Land
Vehicle:
2008 EVO X

Default

Could a generic 02 sensor be used, like one picked up from Autozone, etc?
Inprogress is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL : P1507 ... please help! HappyEeyore Normally Aspirated Powertrain 3 10-02-2009 02:16 PM
White smoke with CEL code P0031 Seanohue Service & Maintenance 4 04-27-2009 09:54 PM
cel code p0031 - front o2 sensor sjs0433 Factory 2.0L Turbo Powertrain 7 04-18-2007 04:24 PM
Cel : P0442 Evaporative Emission Control System Leak Detected (small Leak)?? mrtrex Factory 2.0L Turbo Powertrain 4 05-09-2006 07:45 PM
Tranny : CEL : Cherry Hill Subaru WRX02CRH Newbies & FAQs 3 07-03-2001 01:32 PM


All times are GMT -4. The time now is 02:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.