Welcome to the North American Subaru Impreza Owners Club Monday October 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-20-2005, 11:35 PM   #1
Acejam2k
Scooby Specialist
 
Member#: 42645
Join Date: Sep 2003
Chapter/Region: NESIC
Location: MA
Vehicle:
2007 STI
Crystal Gray Metallic

Default MY2000 BE Rattling under engine area

my car has a rattling noise. a while back the heat shield was loose, and I put a clamp over it to stop the rattle. Is there more than one heat shield on these cars which has been known to rattle?

also, the cover which goes underneath the engine (under the oil filter, etc, the BIG cover) is broken. The side points hold it in, as do the points in the front of the car, but the part where it goes into the bottom of the car near the differential/jacking point area has cracked and compeltely broken off.

I wanna replace this. Any idea on price, and if it is ok to drive around without it on for a few days?
* Registered users of the site do not see these ads.
Acejam2k is offline   Reply With Quote
Old 05-20-2005, 11:38 PM   #2
fibuz
Scooby Specialist
 
Member#: 53410
Join Date: Jan 2004
Chapter/Region: SWIC
Location: Tucson, AZ / Port Angeles, WA
Vehicle:
BE-> GD->GR->SG->BL
WAawd.org

Default

Quote:
Originally Posted by Acejam2k
my car has a rattling noise. a while back the heat shield was loose, and I put a clamp over it to stop the rattle. Is there more than one heat shield on these cars which has been known to rattle?
probably...

Quote:
also, the cover which goes underneath the engine (under the oil filter, etc, the BIG cover) is broken. The side points hold it in, as do the points in the front of the car, but the part where it goes into the bottom of the car near the differential/jacking point area has cracked and compeltely broken off.

I wanna replace this. Any idea on price, and if it is ok to drive around without it on for a few days?
Yeah, you can take it off...just replace it with some rally armor skid plates I'd assume they would be about the same price as OEM subaru. Lemme look into the part number/price of the OEM in a few minutes for you.

fibuz
fibuz is offline   Reply With Quote
Old 05-21-2005, 12:11 AM   #3
fibuz
Scooby Specialist
 
Member#: 53410
Join Date: Jan 2004
Chapter/Region: SWIC
Location: Tucson, AZ / Port Angeles, WA
Vehicle:
BE-> GD->GR->SG->BL
WAawd.org

Default

It looks like this is what you're looking for:

To 06-00 Manufacture date:
56410AE06A Under Cover Com Fstn $97.97 $74.65 $74.65

From 07-00+ Manufacture date:
56410AE12B Under Cover Com Fobk $103.90 $79.17 $79.17

Good luck,

fibuz
fibuz is offline   Reply With Quote
Old 05-21-2005, 01:27 AM   #4
dalemcc
Scooby Newbie
 
Member#: 42821
Join Date: Sep 2003
Location: Sarnia, Ont. Canada
Vehicle:
2006 Legacy 2.5i SE
2002 Legacy GT

Default

Heat shields suck on these cars! I have 4 clamps stopping the rattle on mine.
dalemcc is offline   Reply With Quote
Old 05-21-2005, 01:57 AM   #5
IronMonkeyL255
Scooby Specialist
 
Member#: 38120
Join Date: Jun 2003
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
1991 Rio Red
Legacy Turbo

Default

I have no rattles......

Then again, they just don't make 'em like they used to

Mine just has tons of wind noise....
IronMonkeyL255 is offline   Reply With Quote
Old 05-21-2005, 10:29 PM   #6
omahasubaru
Scooby Guru
 
Member#: 1594
Join Date: Jun 2000
Chapter/Region: MWSOC
Location: Gretna, NE
Vehicle:
1995 WRX
2002 Legacy

Default

No rattles on our 02 Legacy.
omahasubaru is offline   Reply With Quote
Old 05-22-2005, 02:03 PM   #7
fastenova
Scooby Specialist
 
Member#: 38829
Join Date: Jun 2003
Chapter/Region: NWIC
Location: Tigard, OR
Vehicle:
Not your usual 1997
Legacy GT

Default

I just ripped the heat shields off. I had to have my y-pipe welded in a couple of spots because the heat shields are welded in place at a few spots. When I tore them off it took out a few little chunks of the pipe and made some exhaust leaks. But it was nothing that $20 at the local exhaust shop didn't fix. I have been in grass and off road quite a bit with no fires or issues.

As far as your splash guard goes: Is it plastic? I know on my BD the guy I bought the car from swapped the plastic one for a metal skid plate from an OB of the same vintage... You can get those from a junkyard for next to nothin'. Not sure about that equipment on a BE tho.

You're fine to drive around with that off. It's just a splash guard to help keep water from getting up into your engine. Definately replace it with something metal if you go off road at all, or even just to protect your oil pan from rocks or something on the highway.


On a sidenote, I heard about some guy who was following a pickup filled with firewood. A piece of firewood fell off and landed right in front of his car and knocked a nice hole in his oil pan, among other things. Moral of the story: Skidplates are good.
fastenova is offline   Reply With Quote
Old 05-23-2005, 01:06 AM   #8
Dark Anghell
Scooby Newbie
 
Member#: 74910
Join Date: Nov 2004
Vehicle:
2001 Legacy OB wagon
Maroon

Default

does it rattle only at certain RPM? because mine rattles as well and i can't figure out what it is, it only happens at 1500-2000RPM. So can i just take 'em off and put some heat wrap around the pipes?
Dark Anghell is offline   Reply With Quote
Old 05-23-2005, 10:15 AM   #9
TRH_legacy2k
Scooby Newbie
 
Member#: 66222
Join Date: Jul 2004
Chapter/Region: NESIC
Location: Saratoga Springs, NY
Vehicle:
2000 Legacy
'68 Spitfire

Default

I have one that rattles (more like a .5 second buzz) when I shift... almost sounds like a blow-off though!

haha...take THAT turbo car!
TRH_legacy2k is offline   Reply With Quote
Old 05-23-2005, 10:46 AM   #10
iamrazor
Scooby Guru
 
Member#: 52324
Join Date: Jan 2004
Chapter/Region: NESIC
Location: Pelham, NH
Vehicle:
2011 WRX LTD (FS)
1990 T30 miata

Default

TRH: I have the same thing. its the heat shields. which ones, I dont know. as soon as i get a good day, they're coming off. I've already had them tack welded when i had my exhuast put on. As far as i'm concerned, that was their last chance to stay....
iamrazor is offline   Reply With Quote
Old 05-23-2005, 02:21 PM   #11
fastenova
Scooby Specialist
 
Member#: 38829
Join Date: Jun 2003
Chapter/Region: NWIC
Location: Tigard, OR
Vehicle:
Not your usual 1997
Legacy GT

Default

Dark Anghell: Yes, generally at 1200-2000 RPM. Tear 'em off!
fastenova is offline   Reply With Quote
Old 05-24-2005, 10:10 AM   #12
TRH_legacy2k
Scooby Newbie
 
Member#: 66222
Join Date: Jul 2004
Chapter/Region: NESIC
Location: Saratoga Springs, NY
Vehicle:
2000 Legacy
'68 Spitfire

Default

Quote:
Originally Posted by iamrazor
TRH: I have the same thing. its the heat shields. which ones, I dont know. as soon as i get a good day, they're coming off. I've already had them tack welded when i had my exhuast put on. As far as i'm concerned, that was their last chance to stay....
phew! for a while, I thought it was something more serious.. I'm glad to see someone else has the same problem!

if you happen to take them off one at a time and figure out which one, let me know!
TRH_legacy2k is offline   Reply With Quote
Old 05-28-2005, 07:38 PM   #13
Aken
Scooby Specialist
 
Member#: 41308
Join Date: Aug 2003
Chapter/Region: MWSOC
Location: West Allis, WI
Vehicle:
2006 ABP Legacy GT
'02 F4i / '07 ZX-10R

Default

Wow Ace - stop mimmicking the problems I'm having with my car.

My heat shield has been rattling for ages, sounds like complete ass when I rev my engine (which I do often - silly 5MT transmissions ), and on a recent trip back from Madison (1.5 hour drive for me), I stopped to look at a car for sale for a friend of mine, and when I went back towards my car I saw the plastic under-engine piece had a nice chunk hanging down from it.

I'm glad to hear it's under $80, though. I didn't want to pay much to get a new one.

Hey fibuz, what are the rally skid plates you're talking about? Maybe I'll upgrade part of my car for once.
Aken is offline   Reply With Quote
Old 05-28-2005, 07:48 PM   #14
fibuz
Scooby Specialist
 
Member#: 53410
Join Date: Jan 2004
Chapter/Region: SWIC
Location: Tucson, AZ / Port Angeles, WA
Vehicle:
BE-> GD->GR->SG->BL
WAawd.org

Default

Quote:
Originally Posted by Aken
Hey fibuz, what are the rally skid plates you're talking about? Maybe I'll upgrade part of my car for once.
something like this(not for legacy specifically, but I'm sure if they don't have it, they can fabricate it):



http://www.rallyarmor.com/rally_skid...kidplates.html
fibuz is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turbo rattle or Engine rattle? Help Please wrx747 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 11 04-20-2012 07:52 PM
Rattling under car under load. wfofromthegetgo Transmission (AT/MT) & Driveline 0 04-07-2006 05:37 PM
Noise/rattle under the hood enough to effect knock sensor? anyone have this happen? mpower22 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 21 09-16-2005 05:14 PM
MY2000 BE Sway bar Acejam2k Legacy Forum 28 03-22-2005 05:25 PM
Rattling under acceleration... possibly clutch? mpaone Service & Maintenance 5 05-09-2003 06:17 PM


All times are GMT -4. The time now is 06:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.