Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-20-2005, 10:40 PM   #276
crystalhelix
Scooby Guru
 
Member#: 35313
Join Date: Apr 2003
Chapter/Region: MAIC
Location: SpryRacing.com AgileAuto.com
Vehicle:
Spry Forester
Silver Spark

Default

Quote:
Originally Posted by JRSCCivic98
Just a suggestion Justin, but why not email him this info instead of posting on the web for the entire world to see? Just a thought, but privacy is sometimes the best policy... I would delete your post and send this info directly to him via email. Just a thought.
What can you find out from my ECU, just curious? I'll PM him now.

Thanks,
Justin
* Registered users of the site do not see these ads.
crystalhelix is offline   Reply With Quote
Old 06-20-2005, 10:48 PM   #277
Quack
Scooby Specialist
 
Member#: 57264
Join Date: Mar 2004
Chapter/Region: MWSOC
Location: Aurora, OH
Vehicle:
2004 18g Wagon - WRB
PDX Tuned - 329whp/315wtq

Default

because it's useless to us.
it also means that you can't follow directions because the pop-up box says to e-mail the info to him j/k

here's some info for those who missed it the 1st time around
Quote:
Originally Posted by calvinc
there seems to be some BIG confusion as to what the ecuassist is for. it is only there so that i could build up a database of what ecu's were out there and what parameters they supported. it is also there so that i can code for a nice ascii string and tell you in english what your ecu type is. few problems with the ecuassist stuff:
1) a few of you are running 1 type of ecu with a certain ecu cover and id but completely different firmware software, which means they will never match.
2) its a rather annoying little message box each time you use the app.

I've removed the ecuassist stuff from v1.0.40 - please note that this WILL NOT affect the functionality of the application

On startup the ecu responds with a bit mapping of what parameters are supported. this is done and the data item list is generated regardless of whether it understands your ecu id or not.

v1.0.40 will be available in the next few days...
Calvin.
Quack is offline   Reply With Quote
Old 06-20-2005, 11:35 PM   #278
crystalhelix
Scooby Guru
 
Member#: 35313
Join Date: Apr 2003
Chapter/Region: MAIC
Location: SpryRacing.com AgileAuto.com
Vehicle:
Spry Forester
Silver Spark

Default

Quote:
Originally Posted by Quack
because it's useless to us.
it also means that you can't follow directions because the pop-up box says to e-mail the info to him j/k

here's some info for those who missed it the 1st time around
I PM'd him, Geeze!
crystalhelix is offline   Reply With Quote
Old 06-21-2005, 05:10 AM   #279
calvinc
Scooby Newbie
 
Member#: 73190
Join Date: Oct 2004
Location: South Africa
Vehicle:
2005 Impreza WRX STi
Silver

Default

Quote:
Use the "relative pressure" to monitor boost levels.
you should rather use the 'absolute' value and subtract the 'atmospheric' value. the 'relative' pressure sensor maxes out at 1.27bar and you might be getting extra boost without knowing it.

Quote:
I have a humble feature suggestion that might make things easier for you.

Until all the ecu's can be auto-detected, could you add a feature to specifiy your own memory addresses like in the mmCD program for DSM's?

Even if it's just a text file that it reads in at startup. Just a simple format:

[ADDRESS] [DESCRIPTION] [D/A] [EQUATION]

Might help in the long run because we could experiment and find what works on our own.

Heck, you could put the whole table you currently have out there.
i started coding this last weekend already in the new app - glad to see people are thinking...

Quote:
dood this prog sucks, I wasted 15 bucks on a USB to serial cable. The damn thing won't connect
somebody help this 'dood' please. murrdogg24 - i suspect its your implementation of it thats giving you problems. many others on this thread have it working with the COBB AP cable. if it is the software however i will gladly fix it. what area are you in? maybe somebody here is nearby?

calvin.
calvinc is offline   Reply With Quote
Old 06-21-2005, 09:22 AM   #280
willguidry
Scooby Specialist
 
Member#: 16388
Join Date: Mar 2002
Default

Yeah, so now logging to .csv is enabled. Yay!

Yeah....only it doesn't work.

I'm running on a winxp laptop, which means I put the .dll file in the windows\system32 directory instead of the default winnt directory.

Check enable logging by defogger switch.

This is an 05 wrx... can you PLEASE add a simple LOG command instead of using the defogger switch. Cause I don't think it works for everyone.

I've tried numerous things to get this thing to log. While I love the concept, and the fact that this program works (displays Live data) the only part I really care about is the logging feature.

I could do without the Live portion, (who watches it while they drive anyway) ....so Calvin, can you please throw me a bone here? I'm going nuts.

CN I am using the AP cable, 05 wrx, winxp, moved .dll from winnt/system32 to windows/system32, have logging by defogger switch checked, still cannot log.
willguidry is offline   Reply With Quote
Old 06-21-2005, 09:36 AM   #281
DougG
Scooby Newbie
 
Member#: 58975
Join Date: Apr 2004
Chapter/Region: NESIC
Location: NW CT
Vehicle:
2005 WRX Premium Sed
WRB, Cobb TBE, stage 2

Default

I have the exact same car, same year, and AP cable and have run the program under WinXP pro and Win2K. If your live mode works, then you have to select the pulldown tab and check "logging on defog switch" as well as monitor the digital item "defogger switch". Did you do the latter?

Doug

Quote:
Originally Posted by willguidry
Yeah, so now logging to .csv is enabled. Yay!

Yeah....only it doesn't work.

I'm running on a winxp laptop, which means I put the .dll file in the windows\system32 directory instead of the default winnt directory.

Check enable logging by defogger switch.

This is an 05 wrx... can you PLEASE add a simple LOG command instead of using the defogger switch. Cause I don't think it works for everyone.

I've tried numerous things to get this thing to log. While I love the concept, and the fact that this program works (displays Live data) the only part I really care about is the logging feature.

I could do without the Live portion, (who watches it while they drive anyway) ....so Calvin, can you please throw me a bone here? I'm going nuts.

CN I am using the AP cable, 05 wrx, winxp, moved .dll from winnt/system32 to windows/system32, have logging by defogger switch checked, still cannot log.
DougG is offline   Reply With Quote
Old 06-21-2005, 09:37 AM   #282
crystalhelix
Scooby Guru
 
Member#: 35313
Join Date: Apr 2003
Chapter/Region: MAIC
Location: SpryRacing.com AgileAuto.com
Vehicle:
Spry Forester
Silver Spark

Default

Yes, I realize my ECU wasn't recognized but I also wanted to mention defogger switch did not work for me. But I like the idea, please keep the function.

Justin
crystalhelix is offline   Reply With Quote
Old 06-21-2005, 10:04 AM   #283
willguidry
Scooby Specialist
 
Member#: 16388
Join Date: Mar 2002
Default

Quote:
Originally Posted by DougG
as well as monitor the digital item "defogger switch". Did you do the latter?

Doug
I have the defogger switch checked....but I do not have the digital item "defogger switch" checked.

Will try that tonight. Thank you SOOO much.

Hope it works.
willguidry is offline   Reply With Quote
Old 06-21-2005, 10:44 AM   #284
drfrink24
Scooby Specialist
 
Member#: 36369
Join Date: May 2003
Chapter/Region: MWSOC
Location: Rochester, MN
Vehicle:
2004 WRX STi
Java Black

Default

Quote:
Originally Posted by willguidry
Hope it works.

It will. I made the same mistake myself. You need to read the help text though, it says it in there that the digital item must be checked. If you think about it, it makes sense... If you're not logging the defogger switch data (on/off), how will the program know when to cut a log file?
drfrink24 is offline   Reply With Quote
Old 06-21-2005, 10:45 AM   #285
Quack
Scooby Specialist
 
Member#: 57264
Join Date: Mar 2004
Chapter/Region: MWSOC
Location: Aurora, OH
Vehicle:
2004 18g Wagon - WRB
PDX Tuned - 329whp/315wtq

Default

^^^yep, the key to loggind is selecting the "defogger switch" on the digital data
Quack is offline   Reply With Quote
Old 06-21-2005, 11:01 AM   #286
willguidry
Scooby Specialist
 
Member#: 16388
Join Date: Mar 2002
Default

Nice.

And it makes perfect sense. I never saw it in any documentation either on the website or found any helpfiles in my .zip.

Which is why I wasn't a fan of this application. No RTFM included with the application.

I'm guessing you are referring to a helpfile in the new full release. I just downloaded the update files to patch to newest version.

Thanks again guys!
willguidry is offline   Reply With Quote
Old 06-21-2005, 11:32 AM   #287
calvinc
Scooby Newbie
 
Member#: 73190
Join Date: Oct 2004
Location: South Africa
Vehicle:
2005 Impreza WRX STi
Silver

Default

Quote:
Yeah, so now logging to .csv is enabled. Yay!
yes, logging was enabled as of v1.0.39

Quote:
I have the defogger switch checked....but I do not have the digital item "defogger switch" checked.
yes you have to have both the trigger checked and be monitoring the data item. i should make it automatically select the defog switch data item...v2

Quote:
I never saw it in any documentation either on the website or found any helpfiles in my .zip.
i hate writing documentation. thats why i put the quick-help stuff in v1.0.39

calvin.
calvinc is offline   Reply With Quote
Old 06-21-2005, 11:38 AM   #288
Quack
Scooby Specialist
 
Member#: 57264
Join Date: Mar 2004
Chapter/Region: MWSOC
Location: Aurora, OH
Vehicle:
2004 18g Wagon - WRB
PDX Tuned - 329whp/315wtq

Default

calvin, i can write something up for you when i get a chance
Quack is offline   Reply With Quote
Old 06-22-2005, 01:17 AM   #289
skoobywrx
Scooby Specialist
 
Member#: 28088
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
05 WRB STi
06 Outback

Default

got it to connect via usb-serial adapter
however it doesnt see the RPM's
skoobywrx is offline   Reply With Quote
Old 06-22-2005, 01:45 AM   #290
STirocket
Scooby Specialist
 
Member#: 84006
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Auburn, WA
Vehicle:
2005 Impreza WRX STi
WRB with Goldies

Default

Heh.... you guys....... This is just WAY too cool for words

I gotta tell ya I've been tuning various cars, some very high performance cars, for over 40 years... Yeah that makes me old But I'm also a computer junkie since before DOS, and I think this stuff with new cars and computers is just WAY more fun than you should be able to have with your clothes on I bought my rex in March and just got my AP last weekend and flashed to S1. I downloaded all this cool software today and got it up and running tonight. I can't hardly believe it!!! it collects over 75 parameters in real time, that is so amazing I'm almost speechless. WHAT FUN!!!!!!!!!!

It didn't recognize my ECU so I'll have to send in the file and pic tomorrow. I have a 2005 USDM STi, kinda surprised that model hasn't been nailed yet (maybe it didn't like the Cobb S1 flash)... I just wanted to give props to the guys contributing to this project, I have a long history with the Linux open source community, but I want you to know that when you're ready to accept money for all your hard work I'm ready to throw it at ya. You guys do good work, especially you Calvin...
STirocket is offline   Reply With Quote
Old 06-22-2005, 04:16 AM   #291
calvinc
Scooby Newbie
 
Member#: 73190
Join Date: Oct 2004
Location: South Africa
Vehicle:
2005 Impreza WRX STi
Silver

Default

Quote:
This is just WAY too cool for words
if you think DL1 is cool just wait for the next application - ecuExplorer. i get excited each time i write new code for it...gonna be awesome!

Quote:
however it doesnt see the RPM's
this is a problem with the default installation path of the pci.exe upgrade file. you most likely have 2 on you pc now. check a few pages back, there is a detailed explanation on how to correct it.

Quote:
I have a 2005 USDM STi, kinda surprised that model hasn't been nailed yet
reason a large number of the USDM ecu types havent yet been recognised is because I live in south africa which makes it almost impossible to get access to and test it on the USDM vehicles. also the issue of differing firmware.

Quote:
but I want you to know that when you're ready to accept money for all your hard work
my software and the contributions will never be for sale so i cant accept the cash, but when/if i'm in the US you can buy me a beer.

calvin.
calvinc is offline   Reply With Quote
Old 06-22-2005, 07:45 AM   #292
DougG
Scooby Newbie
 
Member#: 58975
Join Date: Apr 2004
Chapter/Region: NESIC
Location: NW CT
Vehicle:
2005 WRX Premium Sed
WRB, Cobb TBE, stage 2

Default

Quote:
Originally Posted by skoobywrx
got it to connect via usb-serial adapter
however it doesnt see the RPM's
That is what many of us are seeing. Those of us that have Windows NT or Windows 2000 should accept the default installation locations for the base installation file as well as the pci.exe and DL1.sfx.exe upgrade files.

If you have Windows 98SE or Windows XP, you should accept the default installation directories for the install package-dl1.exe and the DL1.sfx.exe files. The pci.exe file MUST be redirected to extract/intall into the C:\windows\system32 directory. If you let it extract into the default directory (c:\winnt\system32), it will cause trouble like not displaying the RPM data, etc.

If you are having trouble with RPM data and are running Windows98SE or XP, delete the PCI.dll file in both the C:\windows\system32 and the C:\winnt\system32 directories and reinstall the pci.exe into the c:\windows\system32 directory.
DougG is offline   Reply With Quote
Old 06-22-2005, 09:49 AM   #293
calvinc
Scooby Newbie
 
Member#: 73190
Join Date: Oct 2004
Location: South Africa
Vehicle:
2005 Impreza WRX STi
Silver

Default v1.0.40 now available for download

v1.0.40 is now available for download from - www.tari.co.za/products.htm

it has vehicle speed back in, resizing for the resolution-troubled users, and new columns in the live data tab for min and max values. you had no way of knowing what they were before unless you were logging to a file. easy way to tell now.

there is also another menu option to either show/hide the quick-help frame. if you choose to hide it then the window is expanded nicely to give a much broader view of the live data tabs, useful for seeing all columns.

if you have problems let me know.

in v1.0.41 i aim to include the following:
- lambda to afr conversion
- injector duty cycle as %
- proper ecu type detection

calvin.
calvinc is offline   Reply With Quote
Old 06-22-2005, 10:09 AM   #294
crystalhelix
Scooby Guru
 
Member#: 35313
Join Date: Apr 2003
Chapter/Region: MAIC
Location: SpryRacing.com AgileAuto.com
Vehicle:
Spry Forester
Silver Spark

Default

sweet, too bad I have to wait til Saturday when I get back from a business trip. Nice work Calvin!

Justin
crystalhelix is offline   Reply With Quote
Old 06-22-2005, 10:33 AM   #295
CBR600F4
Scooby Newbie
 
Member#: 80785
Join Date: Feb 2005
Location: San Diego, CA
Default

Very good!!! Next step is to figure out the address of the IAM (Ignition Advance Multiplier), which is a very quick way to know if our reflashed ECUs are working properly with the gasoline we have access to (I'm running the AccessPORT Stage1 91 Oct map, instead of the specific California version, so I'm really curious about this stuff...).
It's also useful to see if the famous 5s Vishnu trick to bump the IAM to 16 after a reset really works for us...
CBR600F4 is offline   Reply With Quote
Old 06-22-2005, 10:45 AM   #296
calvinc
Scooby Newbie
 
Member#: 73190
Join Date: Oct 2004
Location: South Africa
Vehicle:
2005 Impreza WRX STi
Silver

Default

all the 'trick' does is put the ECU over its learning thresholds. the load, boost, throttle, etc has to exceed certain values before it will start learning and pushing the boundaries.

this usually works for me:
1) reset
2) find long road with slight incline
3) put in 4th and floor it from about 2500RPM

your IAM will go up under those conditions. dont be fooled into thinking you're gonna get a 16 IAM regardless of fuel, knock, etc. the IAM will advance up to whatever value the ECU thinks is safe. so long as it doesnt bounce around and remains stable your ECU is fine.

or, if you like to live dangerously, get your ECUTEK tuner to change the initial IAM to 16 so that after a reset it will start off at 16 instead of 8.

calvin.
calvinc is offline   Reply With Quote
Old 06-22-2005, 10:57 AM   #297
Undepelo
Scooby Specialist
 
Member#: 34960
Join Date: Apr 2003
Chapter/Region: MAIC
Location: MD
Vehicle:
What would baby
Jesus say of OT?

Unhappy

05 USDM STi...pleeeease!!!
Undepelo is offline   Reply With Quote
Old 06-22-2005, 11:27 AM   #298
drees
Scooby Specialist
 
Member#: 25905
Join Date: Oct 2002
Chapter/Region: SCIC
Location: San Diego, CA
Vehicle:
2003 Silver Wagon
Tuned with Enginuity

Default

Hey calvin, great work. I think this was mentioned before, but I'll bring it up again: Have you thought about releasing the source as well under the GPL or BSD or some other open source license along with the binaries so that other hackers (like me) can help contribute? Maybe even host it on sourceforge? Maybe this is already done and I'm not aware of it!
drees is offline   Reply With Quote
Old 06-22-2005, 12:43 PM   #299
bofh
Scooby Specialist
 
Member#: 59287
Join Date: Apr 2004
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
2007 WRB WRX
2004 WRB WRX (RIP)

Default

Quote:
Originally Posted by calvinc
my software and the contributions will never be for sale so i cant accept the cash, but when/if i'm in the US you can buy me a beer.
This is very cool, and I respect you for it. That said, have you considered postcard ware? It is basically, "If you like a use the software, send me a post card from your location." A few freeware apps have done this. You just have to make sure the dumb Americans understand about customs duty on the claimed value of gifts... But you will give us a chance to show our thanks, and get a cool collection of things from around the world.
bofh is offline   Reply With Quote
Old 06-22-2005, 06:45 PM   #300
CBoldman
Scooby Specialist
 
Member#: 11411
Join Date: Oct 2001
Chapter/Region: SWIC
Default

I would also like to see IAM in the next version. If anyone has a delta dash system, contact calvin and maybe we can get this feauture added.

Calvin, I am very glade you were able to address the screen resolution. Im a Mac guy and I was able to get ahold of an old crappy laptop that did not support a descent resolution. Thanks again, -Chris
CBoldman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Does ANYONE make a free flasher/logger for Pre-2001 subie ECUs? kaisersouse General Community 2 09-23-2009 05:38 PM
free data logger 03bluwrx Factory 2.0L Turbo Powertrain 4 05-18-2008 07:44 PM
!!FREE!! Subaru Leather Sedan Interior !!FREE!! xcntrk75 MAIC Private Classifieds 10 11-12-2007 07:17 AM
New Issue of Subaru Drive Magazine Available Online - Free Subaru Safety DVD Offer Jon [in CT] News & Rumors 16 05-19-2006 08:38 PM
Free Subaru Bigred14 Texas Impreza Club Forum -- TXIC 11 02-08-2002 01:17 PM


All times are GMT -4. The time now is 01:44 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.