Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-23-2005, 12:39 PM   #26
Quack
Scooby Specialist
 
Member#: 57264
Join Date: Mar 2004
Chapter/Region: MWSOC
Location: Aurora, OH
Vehicle:
2004 18g Wagon - WRB
PDX Tuned - 329whp/315wtq

Default

Calvin-
does the Advance Multiplier work? i only get a reading of "0"

btw, this is an '05 ECU in an '04 wagon.

going to sent the file and picture of the ecu.
* Registered users of the site do not see these ads.
Quack is offline   Reply With Quote
Old 05-23-2005, 01:29 PM   #27
TheMadScientist
Scooby Guru
 
Member#: 23717
Join Date: Aug 2002
Chapter/Region: NESIC
Location: Beverly, MA
Vehicle:
2005 Big red

Default

***SUBSCRIBE***
I will be trying this today.

TMS
TheMadScientist is offline   Reply With Quote
Old 05-23-2005, 02:02 PM   #28
CMJ
Scooby Specialist
 
Member#: 39235
Join Date: Jul 2003
Location: L.A., CA
Default

Quote:
Originally Posted by Quack
Calvin-
does the Advance Multiplier work? i only get a reading of "0"

btw, this is an '05 ECU in an '04 wagon.

going to sent the file and picture of the ecu.
The advance multiplier is at a different address for different ECU revisions. He has not been able to code for each ecu revision yet.
CMJ is offline   Reply With Quote
Old 05-23-2005, 02:04 PM   #29
scooterforever
Scooby Specialist
 
Member#: 55011
Join Date: Feb 2004
Location: New England
Vehicle:
2002

Default

Quote:
Originally Posted by stanh04wrx
Anyone happen to know if the obd2 cable from an Elmscan (digimoto) box would work?
I haven't run this software yet (will tonight) but I doubt the Elmscan cable would work. I am running Mike's data logger from openecu.org, and that too worked with either the AP or the Delta Dash cable, but not the Elmscan cable (I tried it). The issue is the voltage of the cable needs to be stepped down for the computer, and the AP and DD cables do this, but the Elmscan cable does not. There are instructions out there on the web (forget the address) on how to assemble the necessary voltage-step-down components, but... I didn't want to wait so I ordered a "replacement" cable from Cobb for $60 give or take.
scooterforever is offline   Reply With Quote
Old 05-23-2005, 02:34 PM   #30
Quack
Scooby Specialist
 
Member#: 57264
Join Date: Mar 2004
Chapter/Region: MWSOC
Location: Aurora, OH
Vehicle:
2004 18g Wagon - WRB
PDX Tuned - 329whp/315wtq

Default

Quote:
Originally Posted by scooterforever
I am running Mike's data logger from openecu.org
i didn't see that on the site...
Quack is offline   Reply With Quote
Old 05-23-2005, 03:13 PM   #31
Jaxx
NASIOC Supporter
 
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Boise,Idaho,USA
Vehicle:
The 93 Imp W/EJ20K
flat black

Default

it worked perfectly with my obd-2.com cable which has no electronics in it what so ever

wish it would do A/F ratio vs lambda

does this log to csv yet? i can't seem to make that part of it work

Last edited by Jaxx; 05-23-2005 at 04:00 PM.
Jaxx is offline   Reply With Quote
Old 05-23-2005, 04:10 PM   #32
colby
Scooby Newbie
 
Member#: 15918
Join Date: Mar 2002
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
08 STI/02 PGT WRX
DGM / Orange

Default

The cable that I designed for openecu.org is for sale on tactrix.com. It basically is a USB to OBD2 connection in a very compact package. Aside from logging like other adapters, it also has Subaru specific abilities to reflash ECUs. I will be releasing some basic flash reading / writing tools for the 02-05 WRXs within then next couple of weeks. At that point things at openecu.org will start moving more quickly, i hope

Colby
colby is offline   Reply With Quote
Old 05-23-2005, 04:24 PM   #33
ride5000
Scooby Guru
 
Member#: 32792
Join Date: Feb 2003
Chapter/Region: NESIC
Location: lincoln, ri
Vehicle:
2003 GGA MBP
12.9 / 105+

Default

nice! gotta get me a cable...
ride5000 is online now   Reply With Quote
Old 05-23-2005, 05:49 PM   #34
scooterforever
Scooby Specialist
 
Member#: 55011
Join Date: Feb 2004
Location: New England
Vehicle:
2002

Default

Quote:
Originally Posted by Jaxx
it worked perfectly with my obd-2.com cable which has no electronics in it what so ever

wish it would do A/F ratio vs lambda

does this log to csv yet? i can't seem to make that part of it work
Hmm... well, I'll give it a try!
scooterforever is offline   Reply With Quote
Old 05-23-2005, 06:15 PM   #35
fatray
Scooby Specialist
 
Member#: 18150
Join Date: Apr 2002
Chapter/Region: MAIC
Location: Baltimore MD
Vehicle:
2002 WRX Wagon EJ207
Velocity Red, Liberal kit

Default

Would be nice if it worked for the UTEC. I am trying it now, dosn't work with UTEC.
fatray is offline   Reply With Quote
Old 05-23-2005, 06:57 PM   #36
MMBOOST
Scooby Specialist
 
Member#: 24140
Join Date: Sep 2002
Location: SFBA
Vehicle:
02 Impreza WRX
http://www.logmapper.com

Default

MMBOOST is offline   Reply With Quote
Old 05-23-2005, 08:14 PM   #37
CMJ
Scooby Specialist
 
Member#: 39235
Join Date: Jul 2003
Location: L.A., CA
Default

Quote:
Originally Posted by Jaxx
does this log to csv yet? i can't seem to make that part of it work
Not until the next revision.
CMJ is offline   Reply With Quote
Old 05-23-2005, 08:31 PM   #38
MRF582
Scooby Guru
 
Member#: 48219
Join Date: Nov 2003
Chapter/Region: MAIC
Location: Pittsburgh, PA
Vehicle:
. Always drive
the race line .

Default

Quote:
Originally Posted by colby
The cable that I designed for openecu.org is for sale on tactrix.com. It basically is a USB to OBD2 connection in a very compact package. Aside from logging like other adapters, it also has Subaru specific abilities to reflash ECUs. I will be releasing some basic flash reading / writing tools for the 02-05 WRXs within then next couple of weeks. At that point things at openecu.org will start moving more quickly, i hope

Colby

What's the difference between the generic version and the WRX version? they are both for the same price. also, what is different about this cable that allows it to write to ECUs?

btw, thanks to calvinC and you for taking the initiative into this.
MRF582 is offline   Reply With Quote
Old 05-23-2005, 08:56 PM   #39
scoobdude
Scooby Specialist
 
Member#: 50699
Join Date: Dec 2003
Chapter/Region: TXIC
Location: austin
Vehicle:
2004 WRX
Platinum Silver

Default

**another confirmation here that the cobb ap cable works**

few questions though:

1) in order to get the software to work i selected com 1, however in my BIOS the serial port is listed as com port 2. this maybe some of the confusion. any clarification for the masses may help but its working for me as of now.

2) i will send you a picture of my ecu probably tomorrow, however i am running an 04 cobb ap and the ecu identifier has been changed. i will send both in my response unless you desire a specific one to be listed.

once again... Thanks a bunch!!!!

Joe
scoobdude is offline   Reply With Quote
Old 05-23-2005, 09:00 PM   #40
colby
Scooby Newbie
 
Member#: 15918
Join Date: Mar 2002
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
08 STI/02 PGT WRX
DGM / Orange

Default

The "WRX" version supplies a regulated voltage to a pin on the OBD connector which supplies the ECU with a voltage to reprogram it's flash memory. With the appropriate software, you can then use this to reflash your ECU. This pinout is appropriate for 2002-2005 WRX's and USDM STI's and FXT's.

The "generic" version is basically the "WRX" version with this pin removed. If you have a different model Subaru that doesn't use the same programming pin, or a non Subaru car that still has a ISO-9141-2 interface, you can use this version to do things like OBD2 and Subaru SSM logging without the ability to reflash.

Both versions are the same price because I basically only manufacture the "WRX" version and then have to take time to remove parts for the "generic" version. I thought it was worth offering though.

Colby
colby is offline   Reply With Quote
Old 05-23-2005, 09:03 PM   #41
colby
Scooby Newbie
 
Member#: 15918
Join Date: Mar 2002
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
08 STI/02 PGT WRX
DGM / Orange

Default

Quote:
Originally Posted by MMBOOST
in case people aren't aware - a cable like this is only for plugging into a hardware interface box on the DE-9 side. There are no electronics in this cable - you can't plug this into your computer's RS-232 port directly - you need interface hardware.

Colby
colby is offline   Reply With Quote
Old 05-23-2005, 10:27 PM   #42
0260B4U
Scooby Specialist
 
Member#: 33249
Join Date: Feb 2003
Chapter/Region: South East
Location: Jax, FL. Riverside/Avondale
Vehicle:
2003 WRX
white

Default

SUBSCRIBE, since I really dont know much bout all of it, but gotta learn sometime.

Can I use my gameboy?

But really, what is the minumum piece of electronics is required? Just a PDA?
0260B4U is offline   Reply With Quote
Old 05-23-2005, 10:39 PM   #43
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by 0260B4U
SUBSCRIBE, since I really dont know much bout all of it, but gotta learn sometime.

Can I use my gameboy?

But really, what is the minumum piece of electronics is required? Just a PDA?


...man....Shaun has a delta dash....use that.....
Uncle Scotty is offline   Reply With Quote
Old 05-23-2005, 11:06 PM   #44
crazymikie
Scooby Specialist
 
Member#: 56321
Join Date: Mar 2004
Chapter/Region: NESIC
Location: Hopkinton, MA
Vehicle:
2006 Honda El Camino
Green

Default

Quote:
Originally Posted by Quack
i didn't see that on the site...
http://openecu.org/viewtopic.php?t=24

Not my logger. I just did some work on it to add a few parameters.

BTW- I have a scanning program that will help locate IAM and load on ECUs. Let me know if it would be helpful.


Mike
crazymikie is offline   Reply With Quote
Old 05-24-2005, 12:26 AM   #45
scooterforever
Scooby Specialist
 
Member#: 55011
Join Date: Feb 2004
Location: New England
Vehicle:
2002

Default

Quote:
Originally Posted by crazymikie
http://openecu.org/viewtopic.php?t=24

Not my logger. I just did some work on it to add a few parameters.

BTW- I have a scanning program that will help locate IAM and load on ECUs. Let me know if it would be helpful.


Mike
Oops, sorry for the attribution error. Mike helped me get up and running on it, though!

Calvin -- good program. Am looking forward to logging functionality. The program seemed to work on my ECU, although it didn't recognize it. Am sending you the ECU model # picture in a separate email right now.

Last edited by scooterforever; 05-24-2005 at 09:33 AM.
scooterforever is offline   Reply With Quote
Old 05-24-2005, 03:59 AM   #46
calvinc
Scooby Newbie
 
Member#: 73190
Join Date: Oct 2004
Location: South Africa
Vehicle:
2005 Impreza WRX STi
Silver

Default

time-zones make instant answer/replies quite difficult - you're just gonna have to bear with me... :-)

Quote:
Calvin-
does the Advance Multiplier work? i only get a reading of "0"

btw, this is an '05 ECU in an '04 wagon.

going to sent the file and picture of the ecu.
CMJ is quite right. in the first version i released i wasnt aware that subaru changed the location of some data items between the different ecu's, and that location is for my ecu - 2005 STi AUS/SA spec. (AJ870-8840).

Quote:
...man....Shaun has a delta dash....use that.....
does deltadash pick up the AM on that specific ecu? if so...shaun please PM me.

mike - please PM me about your software to automatically get the AM, etc. or if you could find the location and then mail it to me with the ecu type. thanks.

Quote:
does this log to csv yet? i can't seem to make that part of it work
CMJ right again - not in the version you have. the 1 i'm currently working on has lots more features. view 'news' page on website for full list of whats coming.

Quote:
wish it would do A/F ratio vs lambda
again, only in the upcoming version.

Quote:
Would be nice if it worked for the UTEC. I am trying it now, dosn't work with UTEC.
UTEC doesnt understand SSM. doesnt UTEC have its own diagnostics apps?

colby's openport connector is the best i have seen available so far, and the big plus is the support for the voltage needed during a flash. if any of you need connectors, get that one.

regards,
calvin.
calvinc is offline   Reply With Quote
Old 05-24-2005, 04:27 AM   #47
ride5000
Scooby Guru
 
Member#: 32792
Join Date: Feb 2003
Chapter/Region: NESIC
Location: lincoln, ri
Vehicle:
2003 GGA MBP
12.9 / 105+

Default

Quote:
Originally Posted by calvinc
if any of you need connectors, get that one.
...just did!

this is cool. looking forward to playing with it.

-ken
ride5000 is online now   Reply With Quote
Old 05-24-2005, 12:29 PM   #48
MMBOOST
Scooby Specialist
 
Member#: 24140
Join Date: Sep 2002
Location: SFBA
Vehicle:
02 Impreza WRX
http://www.logmapper.com

Default

Quote:
Originally Posted by colby
in case people aren't aware - a cable like this is only for plugging into a hardware interface box on the DE-9 side. There are no electronics in this cable - you can't plug this into your computer's RS-232 port directly - you need interface hardware.

Colby
I'm confused about this because there are folks here who are saying they are using a cable "with no electronics" and its working. Look at Jaxx's post (#31 in this thread)


p.s. have I mentioned I had the obd-2.com website? Its crap. Its so unorganized. I would never give my $ directly to a business like that.
MMBOOST is offline   Reply With Quote
Old 05-24-2005, 12:47 PM   #49
crazymikie
Scooby Specialist
 
Member#: 56321
Join Date: Mar 2004
Chapter/Region: NESIC
Location: Hopkinton, MA
Vehicle:
2006 Honda El Camino
Green

Default

You need some optoisolators in the cable since the car is running 12V and the laptop serial port is running 5V.

A very simple cable will suffice- there are plenty of schematics on the web. Just look for an ISO OBD interface...or buy Colby's so you can reflash your own ECU


Mike
crazymikie is offline   Reply With Quote
Old 05-24-2005, 01:11 PM   #50
MMBOOST
Scooby Specialist
 
Member#: 24140
Join Date: Sep 2002
Location: SFBA
Vehicle:
02 Impreza WRX
http://www.logmapper.com

Default

mike,

so then these cables that are supposedly without electronics that work, either Jaxx might eventually fry his laptop or the isolators are built into the cable?
MMBOOST is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Does ANYONE make a free flasher/logger for Pre-2001 subie ECUs? kaisersouse General Community 2 09-23-2009 06:38 PM
free data logger 03bluwrx Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 05-18-2008 08:44 PM
!!FREE!! Subaru Leather Sedan Interior !!FREE!! xcntrk75 MAIC Private Classifieds 10 11-12-2007 08:17 AM
New Issue of Subaru Drive Magazine Available Online - Free Subaru Safety DVD Offer Jon [in CT] News & Rumors 16 05-19-2006 09:38 PM
Free Subaru Bigred14 Texas Impreza Club Forum -- TXIC 11 02-08-2002 02:17 PM


All times are GMT -4. The time now is 10:29 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.