Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-05-2005, 11:26 PM   #1
i_c_the_light
Scooby Guru
 
Member#: 88618
Join Date: Jun 2005
Chapter/Region: SCIC
Location: New Zealand
Vehicle:
1994 Legacy
"The Silver Slug"

Default Erratic reverse lights

I'm having problems with my reverse lights recently on my 1990 Legacy and it's gotten to the stage where I've had to take them out for safety reasons. At random times they'll come on no matter what gear. Even in neutral and all 5 forward gears they'll still be on as long as the ignition is on and will stay on for a lengthy period of time. Does anyone know what's causing them to stay on and how can it be fixed? Is it electrical or mechanical? Warrant is due on the 20th so it's vital I get this sorted ASAP.
* Registered users of the site do not see these ads.
i_c_the_light is offline   Reply With Quote
Old 06-06-2005, 03:49 AM   #2
John UK
Scooby Newbie
 
Member#: 81042
Join Date: Feb 2005
Location: Oxford UK
Vehicle:
2000 5 door turbo
Silver

Default

Probably a faulty switch.
If it's under warranty, put the problem to a garage.

John

Last edited by John UK; 06-06-2005 at 07:56 AM.
John UK is offline   Reply With Quote
Old 06-06-2005, 06:44 AM   #3
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Most likely a shorted reverse switch on the trans. Should be simple enough to test and replace if needed.
Mulder is offline   Reply With Quote
Old 06-07-2005, 11:54 PM   #4
i_c_the_light
Scooby Guru
 
Member#: 88618
Join Date: Jun 2005
Chapter/Region: SCIC
Location: New Zealand
Vehicle:
1994 Legacy
"The Silver Slug"

Default

Thanks for that. Now for the fun part of going under.
i_c_the_light is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fun With Daytime/Reverse Lights scoobyimprza Interior & Exterior Modification 5 10-10-2002 02:16 PM
Reverse light wont go off Burnout Interior & Exterior Modification 4 09-21-2002 11:16 PM
brightest reverse lights M E R C U R Y Interior & Exterior Modification 7 03-18-2002 05:48 PM
Reverse lights always on after changing clutch.... Joe Alejandro Transmission (AT/MT) & Driveline 3 12-28-2001 09:47 AM
('93-'01) Reverse lights not engaging, 5speed OBSS Impreza Forum 3 04-10-2001 02:34 PM


All times are GMT -4. The time now is 07:01 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.