Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-08-2005, 10:43 PM   #1
Extraze
Scooby Specialist
 
Member#: 16980
Join Date: Mar 2002
Location: QC, Canada
Default Hazard button light went out... Anyone else ?

pretty strange, i mean, the car is not even 2 years old and the hazard button light just went out ... and funny enough, my buddies 04 OBS just did the same thing ...

anyone else with a burnt hazard button light ?
* Registered users of the site do not see these ads.
Extraze is offline   Reply With Quote
Old 06-08-2005, 10:48 PM   #2
ATX25RS
Scooby Guru
 
Member#: 4597
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Laredo, Texas
Vehicle:
2011 Mitsu Outlander
Sport (Ex-Suby owner X3)

Default

it lights up? i dont remember if mine does...i dont think it does.
ATX25RS is offline   Reply With Quote
Old 06-09-2005, 04:42 PM   #3
Extraze
Scooby Specialist
 
Member#: 16980
Join Date: Mar 2002
Location: QC, Canada
Default

Quote:
Originally Posted by ATX25RS
it lights up? i dont remember if mine does...i dont think it does.
you gotta be kidding me ... (see picture below)

anyone else with a burnt Hazard light ?


Extraze is offline   Reply With Quote
Old 06-09-2005, 10:05 PM   #4
smdandb2
Scooby Specialist
 
Member#: 70656
Join Date: Sep 2004
Chapter/Region: RMIC
Location: Trampoline Land
Vehicle:
Old Mazda3 Hatch
Shelby Lancer #623

Default

Son of a <askjdkadjka>!!!!!!!!!!!!!!!!!!!!!!!!!!!

The 02's got jipped! I want a light in my hazard switch!
smdandb2 is offline   Reply With Quote
Old 06-09-2005, 11:05 PM   #5
Extraze
Scooby Specialist
 
Member#: 16980
Join Date: Mar 2002
Location: QC, Canada
Default

Quote:
Originally Posted by smdandb2
Son of a <askjdkadjka>!!!!!!!!!!!!!!!!!!!!!!!!!!!

The 02's got jipped! I want a light in my hazard switch!
I used to have an 02 ... and the hazard DID light up ... your light is probably burnt also ...
Extraze is offline   Reply With Quote
Old 06-09-2005, 11:34 PM   #6
satrya
Scooby Specialist
 
Member#: 5887
Join Date: Apr 2001
Chapter/Region: BAIC
Location: Fremont, CA USA
Vehicle:
2002 GDAA
797

Default

<-- has an 02, & hazard light still works since new
satrya is offline   Reply With Quote
Old 06-09-2005, 11:54 PM   #7
ATX25RS
Scooby Guru
 
Member#: 4597
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Laredo, Texas
Vehicle:
2011 Mitsu Outlander
Sport (Ex-Suby owner X3)

Default

Quote:
Originally Posted by Extraze
you gotta be kidding me ... (see picture below)

anyone else with a burnt Hazard light ?


hold on brb
ATX25RS is offline   Reply With Quote
Old 06-10-2005, 12:02 AM   #8
cboggess
Scooby Specialist
 
Member#: 30804
Join Date: Dec 2002
Chapter/Region: SWIC
Vehicle:
87 Yugo
Red

Default

Ok, I just checked and mine still works.
cboggess is offline   Reply With Quote
Old 06-10-2005, 12:02 AM   #9
ATX25RS
Scooby Guru
 
Member#: 4597
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Laredo, Texas
Vehicle:
2011 Mitsu Outlander
Sport (Ex-Suby owner X3)

Default

nope no light...then again i have an RS....meybe it was one of the luxiries not include in the RS
ATX25RS is offline   Reply With Quote
Old 06-10-2005, 01:24 AM   #10
wrxpeed
Scooby Specialist
 
Member#: 49958
Join Date: Dec 2003
Location: in your mom's pants...and MN
Vehicle:
'03 Cobra DSG
SOLD '02 WRB WRX

Default

i have an '02, don't think mine was every on, i bought it 2 years used, so i've had it for almost 2 years, never noticed it wasn't on.
wrxpeed is offline   Reply With Quote
Old 06-10-2005, 07:14 AM   #11
DrD
Scooby Guru
 
Member#: 22412
Join Date: Aug 2002
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2012 Legacy 2.5GT
Ice Silver Metallic

Default

if you remove the switch, the bulbs are readily replaceable - they come out of the side of the switch (same for most of the other switches in the car - foglights, cruise control (for pre-04's), etc.)
DrD is offline   Reply With Quote
Old 06-10-2005, 11:47 AM   #12
smdandb2
Scooby Specialist
 
Member#: 70656
Join Date: Sep 2004
Chapter/Region: RMIC
Location: Trampoline Land
Vehicle:
Old Mazda3 Hatch
Shelby Lancer #623

Default

Where would one find said bulb? Dealership?

I have a bunch of white LEDs, maybe I'll do some riggins!
smdandb2 is offline   Reply With Quote
Old 06-10-2005, 05:21 PM   #13
DrD
Scooby Guru
 
Member#: 22412
Join Date: Aug 2002
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2012 Legacy 2.5GT
Ice Silver Metallic

Default

dealership will probably say you need to buy a new switch...

for bulbs, there are lots of places to try
www.farnsworthelectronics.com/miniaturelightbulbs.htm
www.bulbs.com
www.1000bulbs.com
www.topbulb.com

etc. - the bulbs in the switches are wire terminal - you need to remove them from the little holder to replace them - measure the bulb and see what you need, then look around to find it.
DrD is offline   Reply With Quote
Old 06-10-2005, 07:18 PM   #14
Zypper
Scooby Newbie
 
Member#: 5201
Join Date: Mar 2001
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
'02 WRX Wagon
'11 Versys 650

Default

Wow I disassembled my hazard switch and there was one really burnt out bulb. who knew.

Last edited by Zypper; 06-10-2005 at 08:40 PM.
Zypper is offline   Reply With Quote
Old 06-10-2005, 09:17 PM   #15
DrD
Scooby Guru
 
Member#: 22412
Join Date: Aug 2002
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2012 Legacy 2.5GT
Ice Silver Metallic

Default

pulling the switch apart, the bulb is 3.35mm in diameter, 6.45mm long, and has wire terminals which are 10mm long.

I think the bulb you are looking for is a 7219 (12V, 0.06A) - it's the right size and voltage (there are others this size that are 5V or 28V - the former will burn out quickly since the car will drive it at 12V and the latter will be too dim)

www.topbulb.com has them for $0.99/ea
DrD is offline   Reply With Quote
Old 06-10-2005, 10:31 PM   #16
wrxpeed
Scooby Specialist
 
Member#: 49958
Join Date: Dec 2003
Location: in your mom's pants...and MN
Vehicle:
'03 Cobra DSG
SOLD '02 WRB WRX

Default

Quote:
Originally Posted by DrD
pulling the switch apart, the bulb is 3.35mm in diameter, 6.45mm long, and has wire terminals which are 10mm long.

I think the bulb you are looking for is a 7219 (12V, 0.06A) - it's the right size and voltage (there are others this size that are 5V or 28V - the former will burn out quickly since the car will drive it at 12V and the latter will be too dim)

www.topbulb.com has them for $0.99/ea
thanks pal. i never knew that lit up seeming that it never has. I'll have to get one stat.

Bryan
wrxpeed is offline   Reply With Quote
Old 06-12-2005, 02:59 PM   #17
Uncle Ben
*** Banned ***
 
Member#: 28628
Join Date: Nov 2002
Chapter/Region: VIC
Location: Slurrey, B.C. Canada
Vehicle:
2003 WRX Sedan
World Rally Blue Pearl

Default

I thought mine used to light up! My dealership said it doesn't, those sonsabitches.

Maybe I'll just used this opportunity to get one of those JDM red hazard buttons
Uncle Ben is offline   Reply With Quote
Old 06-13-2005, 09:57 PM   #18
Extraze
Scooby Specialist
 
Member#: 16980
Join Date: Mar 2002
Location: QC, Canada
Default

ok ... so i got the switch apart ... and no, the bulb cannot be removed from the sides, you have to completelly disassemble the switch in order to get to it ...

now the bulb is in this rubber container ... do i have to pull on it or can i buy a bulb with that exact rubber container ?

i'll snap a pic ...
Extraze is offline   Reply With Quote
Old 06-13-2005, 10:40 PM   #19
Extraze
Scooby Specialist
 
Member#: 16980
Join Date: Mar 2002
Location: QC, Canada
Default

here :

Extraze is offline   Reply With Quote
Old 06-13-2005, 10:41 PM   #20
Extraze
Scooby Specialist
 
Member#: 16980
Join Date: Mar 2002
Location: QC, Canada
Default

so ... do i need to remove the bulb from the rubber piece or will the new bulb come with that rubber piece ?
Extraze is offline   Reply With Quote
Old 06-13-2005, 10:47 PM   #21
DrD
Scooby Guru
 
Member#: 22412
Join Date: Aug 2002
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2012 Legacy 2.5GT
Ice Silver Metallic

Default

the new bulb is just the bulb with the wire leads coming off of it - you unthread the wires from the rubber holder, then thread in the new bulb the same way.
DrD is offline   Reply With Quote
Old 06-14-2005, 11:08 AM   #22
smdandb2
Scooby Specialist
 
Member#: 70656
Join Date: Sep 2004
Chapter/Region: RMIC
Location: Trampoline Land
Vehicle:
Old Mazda3 Hatch
Shelby Lancer #623

Default

Its probably easier to just buy a new switch. It probably costs no more than $30... haha. I pulled mine apart in an attempt to put in a white LED... eff that shiz! It took me 2 hours to actually get the switch back together, haha.

Hopefully my S203 button arrives soon!
smdandb2 is offline   Reply With Quote
Old 06-14-2005, 12:08 PM   #23
avk
Scooby Specialist
 
Member#: 17252
Join Date: Apr 2002
Chapter/Region: Tri-State
Location: NJ
Vehicle:
'06 WX8
59E

Default

Just unwrap the wire leads, remove the burnt bulb, put in the new one the same way, and snip the loose ends. RadioShack has these bulbs for 1.49 a pair, always had.
avk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hazard Button Light? 02REX4LIFE Interior & Exterior Modification 14 02-28-2008 01:56 AM
Fog light went out! chopaholix Texas Impreza Club Forum -- TXIC 10 02-19-2004 10:38 PM
AC control light went out... mykrrrr Mid West Subaru Owners Club Forum -- MWSOC 4 09-09-2003 01:59 AM
my brake lights went out spiralsmurf Electrical & Lighting 4 01-29-2003 02:24 AM
Receiver back light went out... Cuppster Car Audio, Video & Security 2 01-18-2001 12:22 AM


All times are GMT -4. The time now is 08:21 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.