Welcome to the North American Subaru Impreza Owners Club Friday October 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-09-2005, 03:15 PM   #1
RSimport
Scooby Specialist
 
Member#: 24718
Join Date: Sep 2002
Chapter/Region: MAIC
Location: Potomac MD
Vehicle:
05 impreza RS
white

Default Engine Problems Need Help!!!

Alright, a few weeks ago I posted saying my car was having idle problems. Well, today I took it in to get inspected(in PA) and they couldn't even get the car to start. Turns out I need a new coil pack. So, I ran down to my local subaru dealership picked one up and installed it. So, I sit down and start the car same damn thing as before but it at least started. It seems to be misfiring on the 4th cylinder. At that point I replaced the spark plug wire to the 4th cylinder and the same thing.So, we did get the car running and it seems when ever we beat on the maf censor it helps for a couple seconds but then goes back to misfiring.

So, my questions

What else could make this happen? Has anyone else had problems like this?
Thats all I can really think of right now any input would be great. Thanks!

Chris
* Registered users of the site do not see these ads.
RSimport is offline   Reply With Quote
Old 06-09-2005, 07:40 PM   #2
orndog
Scooby Specialist
 
Member#: 34670
Join Date: Mar 2003
Chapter/Region: South East
Location: Atlanta
Vehicle:
2013 No gears!
Saltine American

Default

Get a new MAF sensor.
Put it on.
If it helps = profit.
If it doesn't = return it.
orndog is online now   Reply With Quote
Old 06-10-2005, 08:40 AM   #3
Subie Gal
GC84Ever
Super Moderator
 
Member#: 301
Join Date: Sep 1999
Chapter/Region: NWIC
Location: WA
Vehicle:
1970 FF-1 & '70 Van
02 WRX/01 RS

Default

electrical parts are not an item you can return...
all sales are final via subaru

which car do you have?
Jamie
Subie Gal is offline   Reply With Quote
Old 06-10-2005, 08:50 AM   #4
Perdue
Scooby Specialist
 
Member#: 57431
Join Date: Mar 2004
Chapter/Region: MAIC
Location: Charleston, WV
Vehicle:
98 Legacy GT
04 Dakota QC 4x4

Default

I didn't see your other post, but did you change the spark plug itself? if not, I'd try that also; if so, I'd take it back out and make sure that the plug is gapped correctly.

If the Coil Pack, Plug Wires, and Spark Plugs aren't the problem, try cleaning the MAF Sensor. Take it off and use some rubbing alcohol (medical grade and clear) and some q-tips to GENTLY clean the wire in the sensor. From there, I'm not sure.
Perdue is offline   Reply With Quote
Old 06-10-2005, 11:59 AM   #5
orndog
Scooby Specialist
 
Member#: 34670
Join Date: Mar 2003
Chapter/Region: South East
Location: Atlanta
Vehicle:
2013 No gears!
Saltine American

Default

Quote:
Originally Posted by Subie Gal
electrical parts are not an item you can return...
all sales are final via subaru

Jamie
Autozone.
orndog is online now   Reply With Quote
Old 06-10-2005, 12:54 PM   #6
Perdue
Scooby Specialist
 
Member#: 57431
Join Date: Mar 2004
Chapter/Region: MAIC
Location: Charleston, WV
Vehicle:
98 Legacy GT
04 Dakota QC 4x4

Default

I was actually told that the MAF Sensor was a dealer only part...if that's true (I haven't checked), then Autozone isn't going to help any either.
Perdue is offline   Reply With Quote
Old 06-10-2005, 01:40 PM   #7
orndog
Scooby Specialist
 
Member#: 34670
Join Date: Mar 2003
Chapter/Region: South East
Location: Atlanta
Vehicle:
2013 No gears!
Saltine American

Default

Depends on the vehicle. Advance Auto does list 3 for a 1998 Legacy L.
orndog is online now   Reply With Quote
Old 06-10-2005, 05:00 PM   #8
RSimport
Scooby Specialist
 
Member#: 24718
Join Date: Sep 2002
Chapter/Region: MAIC
Location: Potomac MD
Vehicle:
05 impreza RS
white

Default

alright just got the car, back it wasn't the maf itself because that part is like 355.00 it was a sensor that was apart of the maf which was only 50 bucks now the car runs great. Thanks for the input guys

Chris
RSimport is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help ASAP with smoking engine problem! PLEASE HELP! DJS_02_WRX Newbies & FAQs 14 10-10-2009 09:59 AM
engine problems..need help.. fosingwo Subaru Conversions 5 10-27-2006 03:09 PM
Engine problems - Need help ASAP! Soon2BturbodRS Normally Aspirated Powertrain 13 06-25-2005 06:08 PM
engine problems..need help gotawd Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 01-10-2005 09:00 PM
toyota engine problem, need help. spike Off-Topic 25 01-11-2004 05:25 AM


All times are GMT -4. The time now is 07:10 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.