Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-13-2005, 06:36 PM   #1
OvenMitts
Scooby Newbie
 
Member#: 46278
Join Date: Oct 2003
Chapter/Region: South East
Location: Knoxville
Vehicle:
96 Impreza
"brighton"

Default I need some help diagnosing a steering problem

OK, here's my problem- when taking low-lateral-G right turns, my car starts to weave as if i was cranking and uncranking (sometimes jerking) the steering wheel some, but it feels perfectly normal during left turns. I've searched for play/looseness with the wheels on and off, but I couldn't find anything. This occurs with two different sets of wheels. I'm not sure if its related, but I'm also getting some brake vibration and squeal.

My car is a 1996 Impreza with a WRX steering rack that was damaged before it was put on, but the bent parts were replaced. Its also got WRX hubs that were in the wreck that might have gotten beat up some. I've got AGX's and Prodrive springs, and the car was recently aligned with zero toe all around.

I'm thinking its either a bad wheel bearing or ball joint, but I'd like to wait on the word from NASIOC before I tear into anything major.

Thanks, -Matt
* Registered users of the site do not see these ads.

Last edited by OvenMitts; 06-13-2005 at 06:43 PM.
OvenMitts is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need some help diagnosing a wobbly steering system raceckr Brakes, Steering & Suspension 6 04-08-2010 09:31 AM
Need some help diagnosing my dyno, it has some issues (VW Gti) DivineStrike Off-Topic 98 02-01-2009 01:05 AM
Need some help diagnosing a clutch problem rmang27 Transmission (AT/MT) & Driveline 2 06-25-2007 07:08 AM
I need your help diagnosing this noise/problem Six Stars Factory 2.0L Turbo Powertrain 18 03-21-2007 09:23 AM
need some help diagnosing a noise AndrewF844 Texas Impreza Club Forum -- TXIC 13 08-11-2005 04:22 AM


All times are GMT -4. The time now is 09:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.