Welcome to the North American Subaru Impreza Owners Club Tuesday July 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-16-2005, 02:04 AM   #1
svek
*** Banned ***
 
Member#: 82259
Join Date: Mar 2005
Chapter/Region: BAIC
Location: koledge at csus
Vehicle:
1999 impreza 2.2L
Brilliant Red <4EAT Club>

Default CEL

when i start my car in the morning (noon) to go to work i have a CEL. all the way to work it stays on. when i leave (8 pm) it isnt on but halfway home it turns on. i havent gotten the code pulled because well im lazy. i just wanted to know if you guys have any thoughts on what it could be. i have 60k miles on the car. there are NO engine mods. none. any thoughts on what kind of cel happens @ 60k with no mods?
* Registered users of the site do not see these ads.
svek is offline   Reply With Quote
Old 06-16-2005, 09:44 AM   #2
DreddRS25
Scooby Specialist
 
Member#: 51642
Join Date: Dec 2003
Chapter/Region: TXIC
Location: San Antonio, Texas
Vehicle:
2001 Impreza RS
BRP

Default

Loose gas cap? Did you just fill up recently?

I got a P0483? Fan Rationality Malfunction Hasn't seemed to cause any performance loss, but this seems like something a dealer would need to look at.

I would say get that code read when possible.
DreddRS25 is offline   Reply With Quote
Old 06-16-2005, 10:42 AM   #3
Nanners
Scooby Newbie
 
Member#: 66306
Join Date: Jul 2004
Chapter/Region: W. Canada
Location: MD of Rocky View, AB
Vehicle:
2001 2.5 RS Sedan
4EAT BRP

Default

I threw my first cel at 61.7K miles. Stock with the exception of the brake calipers/rotors.

In my case it was a faulty front air fuel sensor. P0130 which was probably caused by my failure to avoid a large pothole and the CEL hit about 5 minutes after the fact.

Since it sounds like your CEL is a solid light better get used to the "did you just fill up with gas" question as you might hear it a lot...

Kurt
Nanners is offline   Reply With Quote
Old 06-16-2005, 11:52 AM   #4
piker28
Scooby Guru
 
Member#: 22664
Join Date: Aug 2002
Location: north nj
Default

no offense but people like you(my friend is the same) should be smacked with a rolled up newspaper

get the thing read, it takes like 5 mins, and can help you alot, maybe something is wrong with the car

oh and id have to guess gas cap but i dunno since theres no info to tell
piker28 is offline   Reply With Quote
Old 06-16-2005, 02:37 PM   #5
svek
*** Banned ***
 
Member#: 82259
Join Date: Mar 2005
Chapter/Region: BAIC
Location: koledge at csus
Vehicle:
1999 impreza 2.2L
Brilliant Red <4EAT Club>

Default

Quote:
Originally Posted by piker28
no offense but people like you(my friend is the same) should be smacked with a rolled up newspaper

get the thing read, it takes like 5 mins, and can help you alot, maybe something is wrong with the car

oh and id have to guess gas cap but i dunno since theres no info to tell

well theres no autozone withing 100 miles of where i live. our local mechanic says he cant do it either. thats why i havent gotten it checked. i just checked my gas cap and its fine. i got the cel when i had about 3/8 of a tank left. the rest of the time there was no cel. im going to fill up today.
svek is offline   Reply With Quote
Old 06-16-2005, 04:13 PM   #6
LetItSnow
Scooby Specialist
 
Member#: 38222
Join Date: Jun 2003
Chapter/Region: Tri-State
Location: Cicero, NY
Vehicle:
'10 &'12 Foresters
another Miata convert

Default

The downside is, nobody even knows where you live to offer up a free reading, either (your house - where?) If you were willing to meet me locally, I'd do it up, no problem. The newspaper thing is true, though; without a code, we simply can't have any idea. You may as well be asking us how much loose change is in your console!
LetItSnow is offline   Reply With Quote
Old 06-16-2005, 04:39 PM   #7
Hayes
Scooby Specialist
 
Member#: 11808
Join Date: Oct 2001
Location: Cape Coral,FL
Default

Sounds like time to buy a code reader if that's not too much trouble.
Hayes is offline   Reply With Quote
Old 06-16-2005, 07:30 PM   #8
piker28
Scooby Guru
 
Member#: 22664
Join Date: Aug 2002
Location: north nj
Default

well only half the newspaper thing is true i mean he has no where close to get it read so its not truely his fault
piker28 is offline   Reply With Quote
Old 06-16-2005, 08:59 PM   #9
svek
*** Banned ***
 
Member#: 82259
Join Date: Mar 2005
Chapter/Region: BAIC
Location: koledge at csus
Vehicle:
1999 impreza 2.2L
Brilliant Red <4EAT Club>

Default

ok i updated my location. i filled up my tank today too. still a cel. im going to talk to the dealership tomorow and see if they can do it for me. hopefully they wont charge me any money
svek is offline   Reply With Quote
Old 06-16-2005, 09:09 PM   #10
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Svekie ol' boy.....the dealer will do NOTHING for free.....unless ya got a boy(girl) on the inside what can fix ya up, like....

....so....if that 'aint happenin'....ya gotsta hook up with somebody whats got a scanner, or shell out for one....a decent one cost ya ~100 clams or so...

...if ya waz closer, Uncle would pull da code and fix what ya got for cheap
Uncle Scotty is offline   Reply With Quote
Old 06-16-2005, 09:15 PM   #11
piker28
Scooby Guru
 
Member#: 22664
Join Date: Aug 2002
Location: north nj
Default

just post in your region section asking anyone with one that can help you out, and buy them a hamburger for the help hah
piker28 is offline   Reply With Quote
Old 06-16-2005, 09:28 PM   #12
svek
*** Banned ***
 
Member#: 82259
Join Date: Mar 2005
Chapter/Region: BAIC
Location: koledge at csus
Vehicle:
1999 impreza 2.2L
Brilliant Red <4EAT Club>

Default

damn the dealer. what a bastard. they want $40 for 1 center cap. thats $120 for a set!!

back on topic. ill put it up here and at i-club. the sac & reno section at i-club is pretty good.
svek is offline   Reply With Quote
Old 06-16-2005, 09:45 PM   #13
99subi
Scooby Guru
 
Member#: 78118
Join Date: Dec 2004
Chapter/Region: Tri-State
Location: Westchester NY
Vehicle:
2002 Corvette coupe
05 Legacy

Default

gas floats man im tellin you
99subi is offline   Reply With Quote
Old 06-18-2005, 11:40 PM   #14
svek
*** Banned ***
 
Member#: 82259
Join Date: Mar 2005
Chapter/Region: BAIC
Location: koledge at csus
Vehicle:
1999 impreza 2.2L
Brilliant Red <4EAT Club>

Default

ok i got the error code pulled.

p1130
svek is offline   Reply With Quote
Old 06-18-2005, 11:49 PM   #15
shoeler25
Scooby Newbie
 
Member#: 52202
Join Date: Jan 2004
Chapter/Region: MWSOC
Location: Dayton OH
Vehicle:
2001 2.5RS

Default

That has something to do with the front O2 sensor. Any mods to the car? And Ive heard that a hard hit on the suspension can mess up the O2 sensors.
shoeler25 is offline   Reply With Quote
Old 06-18-2005, 11:55 PM   #16
piker28
Scooby Guru
 
Member#: 22664
Join Date: Aug 2002
Location: north nj
Default

no he coulda just have it died and youll need to buy a new one and replace it, semi costly but easy to do
piker28 is offline   Reply With Quote
Old 06-18-2005, 11:55 PM   #17
svek
*** Banned ***
 
Member#: 82259
Join Date: Mar 2005
Chapter/Region: BAIC
Location: koledge at csus
Vehicle:
1999 impreza 2.2L
Brilliant Red <4EAT Club>

Default

Quote:
Originally Posted by shoeler25
That has something to do with the front O2 sensor. Any mods to the car? And Ive heard that a hard hit on the suspension can mess up the O2 sensors.
mods are:

-rear sway bar
-rims / tires
-audio crap
-legacy spoiler


so basically nothing to do with the engine.



edit: what does the 02 sensor do? when it goes "faulty" what consequences are there? do i have to replace it? can i wiggle around some wires and fix it?
svek is offline   Reply With Quote
Old 06-19-2005, 12:23 AM   #18
piker28
Scooby Guru
 
Member#: 22664
Join Date: Aug 2002
Location: north nj
Default

replace, if its bad you will get crap gas mileage
piker28 is offline   Reply With Quote
Old 06-20-2005, 12:29 AM   #19
shoeler25
Scooby Newbie
 
Member#: 52202
Join Date: Jan 2004
Chapter/Region: MWSOC
Location: Dayton OH
Vehicle:
2001 2.5RS

Default

Correct me if im wrong, but basically the front O2 gets an exhaust reading before the cat, then compares it with a reading from the rear O2 to determine cat efficiency. And it does a couple more things as well. And like piker said, it has most likely just died and needs to be replaced, my comment on hard hits was just a suggestion as to something that could have caused it to die. Since you have no engine mods, it was a possibility, or something got screwed up in the wires, like a short or something. And I believe if the car is running rich that can foul up the O2 sensors.
shoeler25 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL and flashing cruise control light generalganja Newbies & FAQs 15 01-31-2011 05:17 PM
Need some help please cel plus more!!!! thrasher679 Factory 2.0L Turbo Powertrain 1 06-04-2010 09:21 AM
Recurring CEL, yet "no problem codes found". Datalogs included karnick Engine Management & Tuning 4 06-03-2010 09:40 PM
Anyone with Borla header and CEL, did the ECU recall fix the CEL? Suba_Roo Normally Aspirated Powertrain 14 01-25-2003 12:53 AM
CEL or no CEL? chuglobal Factory 2.0L Turbo Powertrain 12 03-25-2002 03:23 PM


All times are GMT -4. The time now is 02:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.