Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-21-2005, 11:23 AM   #1
ScoobyFool
Scooby Newbie
 
Member#: 89693
Join Date: Jun 2005
Default Subaru wont start

Wuts up everyone, new here and got a question.

I just bought a 1994 subaru legacy L, engine runs strong and no leaks at all. I was driving on the highway going about 65-70 when all of a sudden the car would accelerate, it lost power. I put it into neutral and the car quit. Pulled over and the car wouldnt start. Just cranks and turns over but nothing.

We thought that maybe the fuel pump went out as the car has 166,000 miles. I replaced the fuel pump and fuel filter, checked the timing belts, all the fuses and the batter is fully charged. But it still wont start. Any ideas? I used to have a Honda before and when this happened I would just jump the ECU to see if it was throwing a code, read the code and see whats wrong. Can anyone tell me how to jump the ECU as well.

Any thoughts would be appreciated.

Thanks.
* Registered users of the site do not see these ads.
ScoobyFool is offline   Reply With Quote
Old 06-21-2005, 11:45 AM   #2
chrisarella
Scooby Specialist
 
Member#: 35584
Join Date: Apr 2003
Chapter/Region: South East
Location: www.chrisarella.com
Vehicle:
1965 FFR Roadster
Coyote + TR-6060

Default

Wirelessly posted (Treo 600: Mozilla/4.0 (compatible; MSIE 6.0; Windows 95; PalmSource; Blazer 3.0) 16;160x160)

Even though the battery is charge you may not be getting spark. Pull the spark plug wires to see if you're getting spark. then check you're plugs. Also, sheck you're throttle body to see if either the butterfly is getting stuck, or that fuel is reaching there at all. This would be a good time to wipe it out with throttle body cleaner as well. I'm sure that hasn't been done in a while.
chrisarella is offline   Reply With Quote
Old 06-21-2005, 12:09 PM   #3
Oquipah
Scooby Newbie
 
Member#: 9689
Join Date: Aug 2001
Chapter/Region: MAIC
Vehicle:
1998 Legacy GT
Silver

Default

Starter? Alternator?

Locate these and grab a hammer. My old Civic did this to me once. Tap the starter with the hammer and see if it'll start.

Peace,
Oquipah
Oquipah is offline   Reply With Quote
Old 06-21-2005, 12:27 PM   #4
rallykeith
Scooby Newbie
 
Member#: 34989
Join Date: Apr 2003
Chapter/Region: Tri-State
Location: Reading PA
Vehicle:
06 2.5i wagon
88 RX

Default

Instructions on how to get and determine ECU codes:
http://www.legacycentral.org/library...ture/codes.htm

I'd also suggest checking the connections to the MAF. I had one that had major idle issue and would stall that threw no codes and wound up being the MAF

Also, check the "New Generation" forum over at the USMB www.ultimatesubaru.net/forum

Keith
rallykeith is offline   Reply With Quote
Old 06-21-2005, 01:56 PM   #5
ScoobyFool
Scooby Newbie
 
Member#: 89693
Join Date: Jun 2005
Default

Thanks for the replies,

Well I have already checked the spark plugs and wires and spark comes out. Car is turning over so dont think its the starter, altenator out cuz battery is full charged.

Thanks for the link for the codes.

But I will definately check the MAF, do you know where its located on my car? I do think that this is something fuel related, car was running PERFECT and no leaks and motor is strong......man any other ideas welcome, I will let you guys know if I figure it out.
ScoobyFool is offline   Reply With Quote
Old 06-21-2005, 03:12 PM   #6
gtwagon941
Scooby Specialist
 
Member#: 16874
Join Date: Mar 2002
Chapter/Region: NWIC
Location: Beaverton, OR
Vehicle:
2008 2008 Audi RS 4
2014 Audi S Q5

Default

MAF is located on passenger side front. Part of the intake.

Jared
gtwagon941 is offline   Reply With Quote
Old 06-21-2005, 03:22 PM   #7
abosworth
Scooby Specialist
 
Member#: 53856
Join Date: Jan 2004
Chapter/Region: NESIC
Location: NoVerm Brah......
Vehicle:
2012 Speed3
Red Mica

Default

If you look at the air box you will see it. It has an electrical conector and it is right on the tube that goes into the air box.
abosworth is offline   Reply With Quote
Old 06-21-2005, 11:09 PM   #8
ScoobyFool
Scooby Newbie
 
Member#: 89693
Join Date: Jun 2005
Default

Update.....

Ok, I have found the problem!! The timing belt slipped, now need to find out WHY. We think that it may be the water pump, as there was some metal debris around that area, I PRAY that it is the water pump and no other damage happened.
ScoobyFool is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help!! Car wont start!! 1997 subaru legacy 2.5 GT BallzToTheWallz Normally Aspirated Powertrain 1 02-16-2010 11:20 AM
93 subaru wont start jahred187 Service & Maintenance 5 11-28-2009 11:55 AM
Alarm wont stop going off, car wont start!! felixk Car Audio, Video & Security 3 08-20-2009 05:10 PM
Parking lights wont work now car wont start inevitable_101 Electrical & Lighting 0 07-21-2009 04:51 PM
Help my Subaru wont start BadGoat Newbies & FAQs 15 04-02-2009 11:20 AM


All times are GMT -4. The time now is 10:06 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.