Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-22-2005, 01:39 PM   #1
maxesti
Scooby Newbie
 
Member#: 89766
Join Date: Jun 2005
Default Braging of my WERRY BAD result

Hallo

Im from norway (so you have to excuse the bad language) and have a 04 STI
that wondt go over 290 bhp and 380 nm.

I just dont know what`s wrong and nobody can give me a answer so I was told
this is the place to ask.

Here are my spes.:

MY2004 WRX STI 2.0l euro:
De cat exshost from Hayward & Scott
2.5" uppipe, 3"/2.5" downpipe, 2.5"
midsection with silenser
2.5" back box
JR Air Filter
Walbro 255lt Fuel Pump
Motec M800 with auto ic/spray and antilagg
APS SR40 Turbocharger
APS top mount intercooler


The guy that maped this car is the best in norway when it comes to maping
rally cars. He is driving group-n rally himself and is mapping most group-n
rally cars in norway. Also a lot of street cars.

Whit original ic and turbo i got 290bhp and 380 nm with 1.5 bar turbopresure
at max boost down to 1.2bar at the top.

I dont think this is a werry god result.

Then i bought the APS sr40 turbo and APS TMIC and the turbo charged 1 bar.
We turned the presure up to 1.4bar and this was the max presure we got. We
had to close the Waste Gate hose to get 1.6 bar.

We got almost the same result as I got with the original turbo and ic. 290
bhp and 380 nm.

I have mesured the back pressure in the uppipe and it is 2.5 bar when the
turbo is charging 1.5 bar. Is this the problem???

I also tried on a different exshoust (4.5" downpipe, 3" midt and 2.5" back
box. and still same result.

The motec is telling me that it uses 60% of the total fuel capasity and the
air temp in the ic ic is 50-60 degreas at the top.

Can you please tell me whats wrong???
How mouch BHP and NM shuld this car deliver whit this upgradses???

I would be werry happy If you can help me whit this problem

Best regards

Jorgen Lind
* Registered users of the site do not see these ads.
maxesti is offline   Reply With Quote
Old 06-22-2005, 01:53 PM   #2
Swine
Scooby Specialist
 
Member#: 16197
Join Date: Mar 2002
Chapter/Region: South East
Location: Georgia
Vehicle:
05 LGT 18G-beater
12' Coyote Stang M6

Default

It seems like another Motec problem. I think another guy had the same problem as you on his motec ecu?

Why are you running a motec? There really is no need for one at your level of modifications.
Swine is offline   Reply With Quote
Old 06-22-2005, 02:02 PM   #3
04RCSTI
Scooby Specialist
 
Member#: 65694
Join Date: Jul 2004
Chapter/Region: South East
Location: Miami
Vehicle:
MDC Forever
Black '06 STI

Default

5432

+1 ^

No need for that kind of EM on an SR40
04RCSTI is offline   Reply With Quote
Old 06-22-2005, 02:35 PM   #4
STiTuner
Scooby Specialist
 
Member#: 5778
Join Date: Apr 2001
Chapter/Region: South East
Vehicle:
09 135i
Jet Black

Default

are you using the PnP motec or you made a harness for it?

would you mind posting the log files?
STiTuner is offline   Reply With Quote
Old 06-22-2005, 03:15 PM   #5
maxesti
Scooby Newbie
 
Member#: 89766
Join Date: Jun 2005
Default

Quote:
Originally Posted by STiTuner
are you using the PnP motec or you made a harness for it?

would you mind posting the log files?

Send me your mail and i send you the map
maxesti is offline   Reply With Quote
Old 06-22-2005, 03:40 PM   #6
Kingpin
Vendor
 
Member#: 41252
Join Date: Aug 2003
Chapter/Region: SWIC
Location: 602-795-3036
Vehicle:
Twin 2005 600WHP
FormulaD/TimeAttack Sti's

Default

Yikes! The turbine backpressure is way to high. This is why SR40's never made the power they should. The turbine housing is to small and the wheel is also to small. The Only SR turbo that I have seen make decent power is the SR55.

Clark
Kingpin is offline   Reply With Quote
Old 06-22-2005, 03:57 PM   #7
wrxin8or
Scooby Newbie
 
Member#: 51390
Join Date: Dec 2003
Chapter/Region: South East
Location: WRXAtlanta.com FTW
Vehicle:
2007 G35

Default

He is using motec because he is running antilag
wrxin8or is online now   Reply With Quote
Old 06-22-2005, 05:16 PM   #8
RiftsWRX
Scooby Guru
 
Member#: 6124
Join Date: Apr 2001
Chapter/Region: MWSOC
Location: Glendale Hts, IL, USA
Vehicle:
2000 NFR AP1 S2000
'07 Honda FIT sport (5MT)

Default

1.4 BAR, that's 20.3 PSI, which is basically perfect.

Some will agree with me, some won't, but I've made plenty of good power on a SR40 at 20.5PSI, around 11.5:1 AFR, and a max of 24 degrees of advance.

STI's here (on dynopacks) make an average of 370-380 WHP on 93, and 390's on a 93/100 mix. My own personal 2.2L made 367 WHP on 100 octane, 334 WHP on 93.

Turbo works great, if you tune it right.

Personally, anything over 21-22 PSI is a waste, so don't even try. 20.5 Proved itself to be the magic number in the work I've done with SR40's. IMHO it's a gem, cost prohibitive, but a gem nonetheless.

Jorge (RiftsWRX)
www.ProjectWRX.com
RiftsWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS : weekend sale,open For Offers!! PRICES LOWERED LetumAWD SCIC Private Classifieds 130 08-23-2013 09:03 AM
Comcast can GTFO of my house RallyGuy2k Texas Impreza Club Forum -- TXIC 81 07-04-2010 03:43 PM
Something is fishy about the history of my car... tdc17 General Community 5 06-02-2010 03:04 PM
Car chase ends in front of my apt. building with bad results. Erudition Off-Topic 42 12-12-2005 06:38 PM
here is a pic of my baby.. bad pic though SCRAPPYDO General Forum Archive 4 08-09-2000 08:57 AM


All times are GMT -4. The time now is 10:53 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.