Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Baja Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-23-2005, 01:48 PM   #1
2003Baja
Scooby Newbie
 
Member#: 52985
Join Date: Jan 2004
Chapter/Region: Tri-State
Location: Pennsylvania
Default Baja losing oil?

I did an oil change over 1,000 miles ago, and at a gas station I went to check my oil. The dip stick had NO OIL on it! . I know subaru turboed models eat oil but I have an N/A

Was just wondering if anyone else had this problem. I did check my oil plug and filter and all was tight. There was some oil on the plug/pan but I'm pretty its sure it was from the last change. When I did the change I didnt find any washers in the bottom of the oil container like my moms sonata so I am pretty sure all is sealed......

EDIT: Ok, after adding THREE QUARTS of oil, all is restored. There seems to be a problem with the drain plug. (it was oily again) Oil is getting by it somehow, and I took out the plug just to see if it had a washer and it did. Well I'll see soon enough if the bottom the oil pan its slick again
* Registered users of the site do not see these ads.

Last edited by 2003Baja; 06-23-2005 at 06:46 PM.
2003Baja is offline   Reply With Quote
Old 06-23-2005, 07:05 PM   #2
Hawk296
Scooby Specialist
 
Member#: 14555
Join Date: Jan 2002
Chapter/Region: MWSOC
Location: Troy, MI
Vehicle:
1995 Impreza L
Baja

Default

try replacing the crush washer on the drain plug
Hawk296 is offline   Reply With Quote
Old 06-23-2005, 08:21 PM   #3
Samirr76
Scooby Guru
 
Member#: 4835
Join Date: Mar 2001
Chapter/Region: Tri-State
Location: Fl33tw00d, PA
Vehicle:
2003 Baja 5MT
Yellow w/ 220,000 miles

Default

yes there is a washer, thats why its leaking.
Samirr76 is offline   Reply With Quote
Old 06-24-2005, 08:08 PM   #4
2003Baja
Scooby Newbie
 
Member#: 52985
Join Date: Jan 2004
Chapter/Region: Tri-State
Location: Pennsylvania
Default

I'll go and order one ASAP. Talked to a local mechanic, he said the same thing. How much will it be u think it be?

Thanks!

Watch out for them pitbulls lol! (I stopped hard for one today and the ten 2x6x8's slid and pinned my hand against the steering wheel. Hurt my hand pretty good. Love how people at the home depto stopped/slowed down to watch how I loaded those big things into my baja )
2003Baja is offline   Reply With Quote
Old 06-27-2005, 04:27 PM   #5
opimax
Scooby Newbie
 
Member#: 85940
Join Date: Apr 2005
Default

I did my first change on my 05 N/A Sunday at 2k it was down a quart. I will be watching...

Mark
opimax is offline   Reply With Quote
Old 06-27-2005, 06:22 PM   #6
Samirr76
Scooby Guru
 
Member#: 4835
Join Date: Mar 2001
Chapter/Region: Tri-State
Location: Fl33tw00d, PA
Vehicle:
2003 Baja 5MT
Yellow w/ 220,000 miles

Default

We go up to 5k miles between oil changes and havent burnt any oil, not a drop.
Samirr76 is offline   Reply With Quote
Old 06-27-2005, 09:13 PM   #7
BajaT05
Scooby Specialist
 
Member#: 78337
Join Date: Dec 2004
Chapter/Region: MAIC
Location: KORF
Vehicle:
2005 Baja Turbo
Regal Blue Pearl

Default

You can use the washer up to two times, no more....
BajaT05 is offline   Reply With Quote
Old 06-27-2005, 09:26 PM   #8
nurseman
Scooby Newbie
 
Member#: 85518
Join Date: Apr 2005
Thumbs up oil loss

i did my first oil change on my 05 baja turbo at 3K miles. i noted that i had to put 5 qts in to fill it even though the manual states a 4.1 capcity. but i would say it ate atleast a quart in that 3k miles. as well my car doesnt leak oil and on my 02 impreza rs with 110k miles i never changed the crush washer and never burn leaked oil ever. the washer is 89cents at the dealer
nurseman is offline   Reply With Quote
Old 06-27-2005, 09:55 PM   #9
Flowmastered87GL
WCSS Drunk
Moderator
 
Member#: 8914
Join Date: Aug 2001
Chapter/Region: NWIC
Location: Portland Oregon
Vehicle:
2005 Baja Sport
Regal Blue Pearl

Default

Alot of times if you go to the dealer and say you have a filter already but forgot the washer last time they will just GIVE it to you.

Its nicer to them though if you buy an extra filter with 2 washers when you are there (one for now and one to use with that new filter)
Flowmastered87GL is offline   Reply With Quote
Old 06-29-2005, 03:18 PM   #10
BajaT05
Scooby Specialist
 
Member#: 78337
Join Date: Dec 2004
Chapter/Region: MAIC
Location: KORF
Vehicle:
2005 Baja Turbo
Regal Blue Pearl

Default

Is the Factory filter better than a K&N oil filter?
BajaT05 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Did up/downpipe yesterday, now losing oil from turbo vicinity. Jard Factory 2.0L Turbo Powertrain 12 08-16-2004 12:47 PM
Losing Oil EJ205rulezall Service & Maintenance 4 06-06-2004 11:15 PM
Losing oil? redoktober_99 Service & Maintenance 4 07-31-2002 04:57 PM
Losing Oil HudsoN456 Normally Aspirated Powertrain 33 12-10-2001 02:02 AM
OT: Causes for an engine to lose oil pressure under loads? AaronB Technical Forum Archive 6 06-06-2000 10:24 PM


All times are GMT -4. The time now is 04:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.