Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-27-2005, 04:26 PM   #1
trbowrx
Scooby Specialist
 
Member#: 50770
Join Date: Dec 2003
Chapter/Region: MAIC
Location: VA
Vehicle:
08 STi
04 536whp STi Sold!

Default utec question changing to MBC from utec boost

what setting do i have to change on the utec if i want to change from the utec controlling boost, to using a manual boost controller? sorry for the nooob question but i just want to make sure i dont screw anything up!
* Registered users of the site do not see these ads.
trbowrx is offline   Reply With Quote
Old 06-27-2005, 05:35 PM   #2
trbowrx
Scooby Specialist
 
Member#: 50770
Join Date: Dec 2003
Chapter/Region: MAIC
Location: VA
Vehicle:
08 STi
04 536whp STi Sold!

Default

anyone?
trbowrx is offline   Reply With Quote
Old 06-27-2005, 05:43 PM   #3
TurbojonLS
Scooby Guru
 
Member#: 38772
Join Date: Jun 2003
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2 Cars, No Bling

Default

If you install the MBC correctly, it doesn't matter what you have the in any boost sections of the UTEC - the MBC will be the only thing between the boost source & the wastegate, so it will be the only thing controlling boost.
TurbojonLS is offline   Reply With Quote
Old 06-27-2005, 05:43 PM   #4
dosage0
Scooby Newbie
 
Member#: 42323
Join Date: Aug 2003
Location: VF35, Pinks
Vehicle:
2004 WRX
Silver - UTEC, Tuna, TBE

Default

The other two maps run off of MAP, so if you set boost to ECU control and use the EBC, the fuel / timing will work anyway.
dosage0 is offline   Reply With Quote
Old 06-27-2005, 08:28 PM   #5
trbowrx
Scooby Specialist
 
Member#: 50770
Join Date: Dec 2003
Chapter/Region: MAIC
Location: VA
Vehicle:
08 STi
04 536whp STi Sold!

Default

so i dont have to change anything in the settings?
trbowrx is offline   Reply With Quote
Old 06-27-2005, 08:42 PM   #6
tmarcel
Scooby Specialist
 
Member#: 7555
Join Date: Jun 2001
Chapter/Region: South East
Location: Charlotte NC
Default

Quote:
Originally Posted by trbowrx
so i dont have to change anything in the settings?

Boost will likely come on quicker. What this means is that you will probably have to change some of your vertical % columns (both timing and fuel) in UTEC to make up for the change in boost response. You will need to reference your AFR though to do this.
tmarcel is offline   Reply With Quote
Old 06-27-2005, 11:26 PM   #7
hippy
Scooby Specialist
 
Member#: 36528
Join Date: May 2003
Location: florida
Vehicle:
2002 Impreza Wrx
Silver

Default

I don't think so. If you're using the basemap(which it seems like you might be), you should be fine tuningwise if you use an mbc or the utec boost control. You might get part throttle full boost though. Make sure that when you're below the tps crossover(which is set in the parameter section of the utec(in the olf section if you're using utecs olf mode)), the boost doesn't go that high. If the boost goes above say 8psi(or so) below the tps crossover, it would probably be wise to either lay off the throttle so the boost goes down, or push the throttle past the tps crossover point.

peace
hippy is offline   Reply With Quote
Old 06-27-2005, 11:43 PM   #8
tmarcel
Scooby Specialist
 
Member#: 7555
Join Date: Jun 2001
Chapter/Region: South East
Location: Charlotte NC
Default

TPS is set to IIRC 25% so I don't think he'll get too high of boost. Try putting it down to 20% cross-over though.
tmarcel is offline   Reply With Quote
Old 06-28-2005, 07:15 AM   #9
hippy
Scooby Specialist
 
Member#: 36528
Join Date: May 2003
Location: florida
Vehicle:
2002 Impreza Wrx
Silver

Default

That depends on his setup and how his utec is set. If he's not using utecs olf mode, the lowest the tps crossover can be set to is something like 60%. Also, a stock wrx turbo can run a lot more then 8psi at 20% tps depending on the rpm and load.

peace
hippy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Switched to Cobb from UTEC Nudzbone Tri-State Area Forum 6 02-06-2008 12:39 PM
likely to change to 4EAT FROM 5MAN Meat Supply Transmission (AT/MT) & Driveline 13 02-07-2007 02:08 PM
Thinking of going to Link from UTEC. Kwyjibo Engine Management & Tuning 8 02-22-2004 05:09 PM
I felt power loss after going back to MBC from Unichip/MBC txl146 Factory 2.0L Turbo Powertrain 2 08-09-2003 10:01 PM
power expected to gain from UTEC with my mods? whiterabbit Engine Management & Tuning 3 02-17-2003 12:50 PM


All times are GMT -4. The time now is 10:58 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.