Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-29-2005, 02:51 PM   #1
wrxwhip
Scooby Specialist
 
Member#: 80343
Join Date: Jan 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
1993 T67 Supra
Graphite

Default Turbo Timer Help

Hello,

I recently got a Blitz FATT DCII turbo timer and harness. I tried installing it today on my 2005 wrx. I followed the instructions on various sites. I ran into a problem though. It seems that the turbo timer is not turning on, I think there is no power. Also, I did all the other steps such as splicing into the Keyless Entry, the dark green wire with the black stripe. Then I spliced the purple wire from the TT to the green wire connected to the E-Brake. The one part I didn't do is cut the grey wire near the security unit by the ebrake. I cant find a grey wire in that area. There is a group of 3 wires, a white one, black one, and red one. The white one has a few grey boxes on it. I am not sure which one of those wires I am supposed to cut and/or splice into. Also, there is a grey wire that is part of the harness itself that is not connected to anything. Also there are two black wires that are part of the harness that are not connected. The one of the two black wires is spliced into the Keyless Entry (the green wire with the black stripe) Please let me know if I did anything wrong or if I need to do something to gain power for the turbo timer. Also, when I started the car it started fine, its just the Turbo Timer did not turn on. Thanks.

Cliff
* Registered users of the site do not see these ads.
wrxwhip is offline   Reply With Quote
Old 06-29-2005, 04:52 PM   #2
coyote73176
Scooby Specialist
 
Member#: 36576
Join Date: May 2003
Chapter/Region: Tri-State
Location: (No Longer) CT / Poughquag, NY
Vehicle:
2k2 WRB wrx WAGON
16G'd & FMIC'd

Default

When I installed my TT (same one you have) I grounded to the two black wires that were on the TT harness. I didn't have to tap anything in with the keyless entry (but this may be because I don't have an alarm). As far as tapping the line into the e-brake, I didn't bother with this either because I wasn't sure which wire it was (didn't have a voltmeter handy when I did the install).

Sorry if this doesn't help much.

I just double checked the install instructions (and of course noticed I have the FATT DC, not the DCII).

My harness had (2) black wires ---> I grounded both

The TT had a purple wire that was supposed to be connected to the e-brake, but I just grounded that one as well.

It may also be different with the 05's because of the immobilizer.
coyote73176 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Razo RE40 Turbo Timer Help Needed! ginjaninja Factory 2.0L Turbo Powertrain 1 09-12-2002 07:37 PM
hks turbo timer help Fast turbo 21 Factory 2.0L Turbo Powertrain 2 05-14-2002 01:11 PM
Blitz turbo timer help Si2WRX Factory 2.0L Turbo Powertrain 0 04-16-2002 09:03 PM
Erratic turbo timer, Help! linus011 Factory 2.0L Turbo Powertrain 3 02-25-2002 10:45 PM
Slight problem with my Turbo timer - help! djerickd Factory 2.0L Turbo Powertrain 2 09-26-2001 12:06 PM


All times are GMT -4. The time now is 06:56 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.