Welcome to the North American Subaru Impreza Owners Club Wednesday May 6, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-30-2005, 01:41 AM   #1
ChronicSTI
Scooby Newbie
 
Member#: 89019
Join Date: Jun 2005
Location: Costa Mesa, CA
Vehicle:
2005 STI
Grey Metallic

Default Apexi Turbo Timer Help!

Hey i installed it today and it doesnt turn on, I hope i put the hks wire harness in the right spot, It was the only connection that I saw that fit the hks harness, I have been looking for hours online and cant find someone who has pictures of exactly where the harness goes. Does anyone know? I saw a good step-by-step tutorial with pics a few weeks ago and cannot find the site again =( does anyone have a pic or know a site that has a pic? I know for sure the ground is good and I ran the gray wire to the parking brake. I left the O2 sensor wire disconnected for now. Please someone let me know where the correct place the harness should be is.
* Registered users of the site do not see these ads.
ChronicSTI is offline   Reply With Quote
Old 06-30-2005, 12:10 PM   #2
kloze
Scooby Newbie
 
Member#: 88486
Join Date: Jun 2005
Default

I dont know if it is the same but, what was the model number of the HKS harness and for the WRX i just found the BLUE clips wayyyyy to the right of the steering column. I had to remove the lower dash part to get to it and it was still a bit difficult.
I didnt do the ebrake of the 02 wire.
kloze is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apexi Turbo Timer Help! ScoobySubby Electrical & Lighting 9 06-05-2007 06:27 AM
Apexi Turbo Timer Help Death Electrical & Lighting 0 08-21-2005 09:01 PM
apexi turbo timer, help JWerty1 Electrical & Lighting 1 02-11-2004 01:13 PM
Apexi Turbo Timer Help!!!! RVwrx Electrical & Lighting 0 01-15-2004 10:23 PM
apexi turbo timer help spacemonkey Electrical & Lighting 6 04-15-2003 06:53 PM


All times are GMT -4. The time now is 09:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.