Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-02-2005, 12:16 PM   #1
Kevin Thomas
Street Racing Instructor
Moderator
 
Member#: 110
Join Date: Jul 1999
Location: 1997 OBS, 1996 SVX, 1988 RX
Vehicle:
1989 1989 XT6

Default Hesitation and Almost Stalling

1997 2.2ltr Subaru Outback Sport Wagon AWD/Auto

While sitting idle in traffic, car sometimes hesitate and acts as if it is going to cut off. Almost feel like an engine misfire or something. Checked ignition and #1 cylinde part that connects to the spark plugs had some greenish residue on it. Instead of sanding it down and cleaning it, I purchased a new one and installed it. Also changed spark plug wires and new plugs. New fuel filter was added as well. New vacuum hoses were added to the Minnam intake and tightened securely. Air filter was cleaned and the Maf sensor was spray cleaned with electrical cleaner and the bolts on it tightened snugly. Throttle body didn't have any excess oil or residue inside. PCV valve was changed out maybe 5k miles ago or so.

It does not hesitate once I start driving. This only happens while idle at a light.....sometimes. What could it be? Any suggestions on what else to troubleshoot. I'm trying to save the larger maintenance items for last like getting the injectors cleaned.
* Registered users of the site do not see these ads.
Kevin Thomas is offline   Reply With Quote
Old 07-02-2005, 12:23 PM   #2
orndog
Scooby Specialist
 
Member#: 34670
Join Date: Mar 2003
Chapter/Region: South East
Location: Atlanta
Vehicle:
2013 No gears!
Saltine American

Default

AC kicking in maybe?
orndog is offline   Reply With Quote
Old 07-02-2005, 01:24 PM   #3
gtwagon941
Scooby Specialist
 
Member#: 16874
Join Date: Mar 2002
Chapter/Region: NWIC
Location: Beaverton, OR
Vehicle:
2008 2008 Audi RS 4
2014 Audi S Q5

Default

maybe try some of the injector cleaner you can buy at the store??

Jared
gtwagon941 is offline   Reply With Quote
Old 07-02-2005, 01:29 PM   #4
LetItSnow
Scooby Specialist
 
Member#: 38222
Join Date: Jun 2003
Chapter/Region: Tri-State
Location: Cicero, NY
Vehicle:
'10 &'12 Foresters
another Miata convert

Default

I get this, too, but it seems to be only when it's wet outside. I'm thinking that it's something to do with the IAC. I'm going to pull mine and lube it up when I remember to buy a new gasket for it.
LetItSnow is offline   Reply With Quote
Old 07-02-2005, 03:37 PM   #5
Kevin Thomas
Street Racing Instructor
Moderator
 
Member#: 110
Join Date: Jul 1999
Location: 1997 OBS, 1996 SVX, 1988 RX
Vehicle:
1989 1989 XT6

Default

Quote:
Originally Posted by LetItSnow
I get this, too, but it seems to be only when it's wet outside. I'm thinking that it's something to do with the IAC. I'm going to pull mine and lube it up when I remember to buy a new gasket for it.
I forgot all about the idle air control valve. The car does have about 128k miles on it. It can not hurt to change it out. I will look into it. Thanks!
Kevin Thomas is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hesitation and surging acceleration originalozzyo Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 12 06-10-2010 04:52 PM
hesitation and stalling after fmic jakesurfin Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 22 09-13-2009 12:28 PM
a beep and almost stall? mikeyp973 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 4 07-26-2008 04:04 PM
put stage 2 modifications on, CEL and almost stalls b0nd18t Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 20 06-24-2008 09:46 PM
UTEC installed.. and barely idle almost stalling.. Diversion Engine Management & Tuning 94 05-05-2005 10:42 AM


All times are GMT -4. The time now is 12:49 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.