Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-08-2005, 07:09 PM   #1
koolaideprived
Scooby Newbie
 
Member#: 25936
Join Date: Oct 2002
Chapter/Region: RMIC
Location: Waving from the Circus Train
Vehicle:
2008 Forester XT
WRB

Default Clicking from left dash

I've been driving my 93 Legacy for a good 6 years now, almost 185,000 with no problems. Lately there is a clicking that comes from the left dash that only seems to occur after 15 minutes or so of driving. Yesterday I was rolling to a stop and noticed that the engine RPM was going up slightly with each click, and when I was fully at a stop each click would make the car want to start moving and a little more brake pressure was required. Obviously the car is an Auto. Anybody have any clue as to what could be up? I'm wanting to head this off before it becomes serious.
* Registered users of the site do not see these ads.
koolaideprived is offline   Reply With Quote
Old 07-08-2005, 07:32 PM   #2
kpalena
Scooby Specialist
 
Member#: 82431
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Battle Ground, WA
Vehicle:
2006 06 wrx limited
CGM

Default

Try shifting into neutral at each stop. It could be a number of things. It might be a stuck valve in the tranny. $$$.

It could also be totally unrelated. I have a 93 with a stuck selaniod in the the heater relay area. The car clicks after it warms up. I just have to turn the heating system off. If I press the "off" button in, the car clicks. If I hit the buttom half way, so that the others pop out but the "off" button does not click in, the clicking stops. Just a thought.
kpalena is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
clicking from front left brakes six1five Brakes, Steering & Suspension 17 09-29-2010 02:23 AM
loud clicking noise from left head ttownriver Normally Aspirated Powertrain 4 07-10-2009 07:29 PM
Clicking sound from under dash wcbjr Normally Aspirated with bolt-on Forced Induction Powertrain 12 11-30-2002 03:21 PM
Bad Clicking from the left side of the car! Subie Gal Brakes, Steering & Suspension 2 04-26-2001 12:44 AM
Clicks from dash while braking? Layman General Forum Archive 6 03-17-2001 03:38 AM


All times are GMT -4. The time now is 09:58 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.