Welcome to the North American Subaru Impreza Owners Club Thursday May 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-14-2005, 10:15 AM   #1
ScoobArmada
Scooby Specialist
 
Member#: 12974
Join Date: Dec 2001
Chapter/Region: MAIC
Location: Arlington, VA
Vehicle:
2005 STi
Whiter than Faded BRP

Question Flashing CEL and Dealer?

Over the last couple weeks, I've had my check engine light flash at me two different times after 3rd gear runs. The light only flashes, never stays on, so it looks like I am having misfires...? I can feel what feels like the car pulling timing or missing, wavering power like I was modulating the throttle even though it's on the floor the whole time. I've always noticed over 5k RPMs. It's also performed like this a few times even when the light hasn't flashed afterwards.

Car is stock except for a muffler only (not turboback or even catback) and has 8500 miles on it.

Anyways, now that the light has flashed at me twice now, I'm guessing this isn't totally in my head. Would Beyer be my best bet for service?

Any recommendations appreciated.



CN: Car seems to be misfiring, should I go to Beyer?
* Registered users of the site do not see these ads.
ScoobArmada is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-14-2005, 11:01 AM   #2
WRXWagon2112
Scooby Specialist
 
Member#: 23524
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Suburbia in MD
Vehicle:
2010 FXT
OBP

Default

Does it flash yellow or red? Yellow usually means something wrong with the emissions system. Red would mean something with the engine itself.

--Alan
WRXWagon2112 is offline   Reply With Quote
Old 07-14-2005, 11:01 AM   #3
ToesWRX
Scooby Specialist
 
Member#: 20798
Join Date: Jul 2002
Chapter/Region: MAIC
Location: Rockville, MD
Vehicle:
1886 Daimler
Motor Carriage

Default

I have a CEL checker/code reader/CEL clearer, if you need to see what kind of code you're pulling the next time your light comes on I can help.

-Jeremy
ToesWRX is offline   Reply With Quote
Old 07-14-2005, 11:16 AM   #4
Jard
In the silly seat
Moderator
 
Member#: 34935
Join Date: Apr 2003
Chapter/Region: MAIC
Location: Silver Spring, MD
Vehicle:
SPB- 2002 ****ing
WRX again

Default

Do you have a boost gauge?

I bet it's boost creep.
Jard is online now   Reply With Quote
Old 07-14-2005, 11:24 AM   #5
ScoobArmada
Scooby Specialist
 
Member#: 12974
Join Date: Dec 2001
Chapter/Region: MAIC
Location: Arlington, VA
Vehicle:
2005 STi
Whiter than Faded BRP

Default

Quote:
Originally Posted by WRXWagon2112
Does it flash yellow or red? Yellow usually means something wrong with the emissions system. Red would mean something with the engine itself.
--Alan
Wow this is complete news to me, I had no idea it could flash red. In my case, it is flashing yellow.

Quote:
Originally Posted by ToesWRX
I have a CEL checker/code reader/CEL clearer, if you need to see what kind of code you're pulling the next time your light comes on I can help.
-Jeremy
Thanks for the offer. If I delay on the dealer, I'll let ya know as I want to get the code.

Quote:
Originally Posted by Jard
Do you have a boost gauge?

I bet it's boost creep.
Unfortunately, I don't yet. But I didn't consider boost creep, since its hot as hell out and the exhaust is still the restrictive stock parts except for the muffler. I thought boost creep was a more violent fuel cut, rather than a smoother fading in and out of power, which is what I'm feeling. I've been wrong before though...


I really appreciate all the help so far guys.
ScoobArmada is offline   Reply With Quote
Old 07-14-2005, 11:36 AM   #6
slim speedy
Scooby Specialist
 
Member#: 2254
Join Date: Sep 2000
Chapter/Region: MAIC
Location: Chantilly, VA
Vehicle:
1992 Sentra SE-R
1999 Infiniti G20

Default

I am pretty sure you can only pull a code while the CEL light is on. If it just flashes I think the code is reset as soon as it goes back off. But if you want I can bring my laptop next time I see you and we can try, just let me know.
slim speedy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Flashing CEL and no codes Lyger AccessPort 6 02-11-2008 06:46 PM
Having problems with flashing CEL and pulled timing chriswrxvf39 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 09-15-2005 09:27 AM
Flashing CEL and rough running '02 subiewrx Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 12 03-05-2005 12:57 PM
flashing cel and bad hesitation mounce_m Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 9 10-02-2003 12:34 AM
MY02 WRX Flashing CEL and Loss of Power after cornering. Help! SWITCH Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 05-12-2003 07:10 PM


All times are GMT -4. The time now is 08:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.