Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-14-2005, 12:50 PM   #1
opious
Scooby Newbie
 
Member#: 57718
Join Date: Mar 2004
Chapter/Region: Tri-State
Location: Woodstock, NY
Vehicle:
99 Impreza OBS WGN
Silver now w/ 20mm rear!P

Unhappy No nightmares left... it's a reality

So... I bought my 99 OBS 2.2l 3 weeks ago today (117,000 miles). I had the oil changed the day after I got it and changed the air filter. i checked the oil the next day and the level was good, although the oil was darker than i thought it would be. i checked under the car for leaks and made sure everything was tight. one of my breaks locked up when i left a mavis after getting 2 new tires put on the front (this warped one of the rotors, so i haven't been driving it like hell because it feels like death when i hit the breaks at 65. i'm getting them replaced today.).
so here's the problem...
2000 miles later...
...i checked the oil level two days ago because the car started running a bit rough... and the oil didn't show on the dipstick . i put a quart in and it came up to the very bottom of the stick, so i put another in and it came up to the empty marking... i figured the oil may just need to take a trip around the block, so i went down to the gas station and filled it up and checked the oil... still at E. it took a whole 'nother quart to fill it up to the hot full marking .
the mechanic who's doing my breaks said that it looked as if the headders had been changed within the last 15,000 miles, and the car isn't leaking any oil out of the engine so it must be burning it up inside.
so... i've been loving this car... anyone got any sugestions as to the best course of action? the seals should be under warranty but nobody around here honors the "America's Choice Vehicle Protection Contract"
* Registered users of the site do not see these ads.
opious is offline   Reply With Quote
Old 07-14-2005, 05:26 PM   #2
opious
Scooby Newbie
 
Member#: 57718
Join Date: Mar 2004
Chapter/Region: Tri-State
Location: Woodstock, NY
Vehicle:
99 Impreza OBS WGN
Silver now w/ 20mm rear!P

Default

...anyone? anyone at all?
opious is offline   Reply With Quote
Old 07-14-2005, 05:56 PM   #3
PJ2.5RS
Scooby Newbie
 
Member#: 33697
Join Date: Mar 2003
Location: Long Island, NY
Default

Quote:
Originally Posted by opious
the seals should be under warranty but nobody around here honors the "America's Choice Vehicle Protection Contract"
looks like your only course of action is to travel to someone who does honor it I've never heard of it, but it's some type of extended warranty?..
PJ2.5RS is offline   Reply With Quote
Old 07-14-2005, 07:04 PM   #4
Siper2
Scooby Guru
 
Member#: 1134
Join Date: Mar 2000
Chapter/Region: MAIC
Location: Dillsburg, PA
Vehicle:
2007 BMW 328xi wagon
Silver

Default

True, PJ.

Though, keep in mind: if someone wants to charge you a huge amount for engine work, I wouldn't bother. People are selling whole WRX engines for the ~$1K mark sometimes, so you can certainly get an n/a EJ25 for $800 or quite a lot less, if you look around.

Point being - a lot of people here care for their engines well, and when they swap, the old engine would be a good "new" one for you. And there's almost always a gaggle of clubbers that'll volunteer to help you install it, in exchange for beer and pizza.

=S2=
Siper2 is offline   Reply With Quote
Old 07-14-2005, 08:07 PM   #5
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

My 2.5L has 145,000 miles on it and uses a couple quarts between 3000mi oil changes. I still beat the crap out of - auto-x, open track days, drag strip. In the past couple years there have been probably half a dozen times that I've had to add 2 quarts to get it up to the normal level. Not ideal, certainly, but the engine keeps running happily along.

Pat Olsen
'97 Legacy 2.5GT sedan
Patrick Olsen is offline   Reply With Quote
Old 07-14-2005, 08:18 PM   #6
only1agam
Scooby Specialist
 
Member#: 56183
Join Date: Feb 2004
Chapter/Region: South East
Unhappy

http://forums.nasioc.com/forums/show...t=losing+faith

^funny thats my OBS's horror story man its a 99 OBS NOW with 131000 miles and i've changed some indicator combo thing, all 4 struts, rear wheel bearings, and one or 2 other things.. idk wat to say.. i think its just my bad luck considering i found my car to be flooded as well bc of rust underneath the seats
only1agam is offline   Reply With Quote
Old 07-14-2005, 08:41 PM   #7
2003Baja
Scooby Newbie
 
Member#: 52985
Join Date: Jan 2004
Chapter/Region: Tri-State
Location: Pennsylvania
Default

Dont think that your alone when it comes to problems. I changed my oil at 21,000 and forgot to replace the crush washer. Lost 3 quarts of oil. I didnt notice this till 22,000 miles when I smelled oil burning off of the header! Replaced the washer, cleaned everything, and now at 24,289 miles (I know its time for an oil change and another 1.79 washer) I still smell oil stopped or when the heat is on! Stuff happens. Hopefully my car will last me till they stop producing baja's and I can get either a legacy turbo, or WRX (parents are worrying about part availibility issues once production stops even though I LOVE my little AWD truck, and I do mean LOVE!) or hit 100,000 miles to replace my subaru with another subaru. This little problem wont stop me from loving subaru. Its a car, and a damn good one. All cars have their flaws you know.
2003Baja is offline   Reply With Quote
Old 07-14-2005, 09:03 PM   #8
Kostamojen
Scooby Guru
 
Member#: 2272
Join Date: Sep 2000
Chapter/Region: BAIC
Location: haha XD
Vehicle:
2013 Subaru 599 :P
Galaxy Blue Sexy

Default

Ya, sounds like upgrade time to me.
Kostamojen is offline   Reply With Quote
Old 07-15-2005, 04:56 PM   #9
opious
Scooby Newbie
 
Member#: 57718
Join Date: Mar 2004
Chapter/Region: Tri-State
Location: Woodstock, NY
Vehicle:
99 Impreza OBS WGN
Silver now w/ 20mm rear!P

Default

thanks so much for all the input! anyone know which engines are direct bolt on? the ej25 would be nice, but wouldn't i have to replace the exhaust headers at the very least?
opious is offline   Reply With Quote
Old 07-15-2005, 05:04 PM   #10
kattz
Scooby Newbie
 
Member#: 39032
Join Date: Jun 2003
Location: Neutral Zone
Vehicle:
2006 Forester LLBean
Grnt Red/Ttnm Silver

Default

Does it smoke at all? How about when you first start it? A "used" 2.2 WRK motor would be a good bet, but maybe your heads and valve guides are just worn out...
kattz is offline   Reply With Quote
Old 07-15-2005, 09:59 PM   #11
Kostamojen
Scooby Guru
 
Member#: 2272
Join Date: Sep 2000
Chapter/Region: BAIC
Location: haha XD
Vehicle:
2013 Subaru 599 :P
Galaxy Blue Sexy

Default

Quote:
Originally Posted by opious
thanks so much for all the input! anyone know which engines are direct bolt on? the ej25 would be nice, but wouldn't i have to replace the exhaust headers at the very least?
Ya, I guess you would have to replace the header section... But you can get those basically for free from club members

All EJ motors are "bolt on" motors, the problem is the wiring and ECU's. Im not sure of the wiring involved with the EJ22 to EJ25 upgrade is, but it might not be complicated at all and the ECU might even be able to run the EJ25.
Kostamojen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Second gear has no teeth left ncarn8 Transmission (AT/MT) & Driveline 13 02-23-2005 12:11 AM
Reporter paid $240,000 by Bush admin to boost no child left behind act. plunk10 Political Playground 52 01-10-2005 10:19 PM
No Sound Left Side - Right Side Fine - Help Please. links_courses Car Audio, Video & Security 16 05-01-2004 12:39 PM
No oil left in a 2 month old wrx ookky Factory 2.0L Turbo Powertrain 31 02-07-2004 02:29 PM
No student left behind a2cpc Political Playground 0 10-21-2003 10:58 AM


All times are GMT -4. The time now is 02:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.