Welcome to the North American Subaru Impreza Owners Club Friday March 6, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-27-2005, 05:43 PM   #1
LESLIEx317537
Scooby Newbie
 
Member#: 35350
Join Date: Apr 2003
Location: Long Island, NY
Vehicle:
2004 Impreza WRX STi
Java Black Pearl/Gunmetal

Question Green Connector under steering dash in 04 STi.

I was looking under the dash of my car today by the steering wheel, behind the intercooler spray button area and noticed a black plug, and then two green plugs that fit together that aren't connected.

I have fog lights and a fog light switch so I know it's not that.

Does anyone know what that green connector is, it only has 1 wire to it.
Can someone look under the dash and tell me if the green plug is connected or disconnected.

Thanks.
* Registered users of the site do not see these ads.
LESLIEx317537 is offline   Reply With Quote
Old 07-27-2005, 06:14 PM   #2
darksands
Scooby Specialist
 
Member#: 75122
Join Date: Nov 2004
Chapter/Region: SCIC
Location: Im in a glass case of emotion
Vehicle:
2005 Impreza WRX
Crystal Gray

Default

yea, its for diagnostics. Its not suppose to be connected. If you have a accessport, in order to flash base maps or alter the ecu, you would haveto connect the two green connectors and have a special plug for the black plug. Its normal.

Again, those plugs are used for ecu diagnostics and it perfectly normal so no worries
darksands is offline   Reply With Quote
Old 07-27-2005, 07:05 PM   #3
LESLIEx317537
Scooby Newbie
 
Member#: 35350
Join Date: Apr 2003
Location: Long Island, NY
Vehicle:
2004 Impreza WRX STi
Java Black Pearl/Gunmetal

Default

Thank you... Now to work ont he fog light / highbeam issue.
LESLIEx317537 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Noticed a green connector under the dash disconnected? ret63 Car Audio, Video & Security 8 05-06-2010 09:12 PM
06 sti steering wheel in 04 sti??? BruinsHockeySTI Interior & Exterior Modification 0 11-26-2009 11:01 PM
Green connectors under driverside dash plus a white one tmarcel Engine Management & Tuning 10 03-03-2006 12:15 PM
The unhooked green connector under the dash? fizzak Newbies & FAQs 6 12-22-2005 11:43 PM
green connectors under steering column??? Jon Cox South East Region Forum 13 08-07-2002 02:32 PM


All times are GMT -4. The time now is 04:10 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.