Welcome to the North American Subaru Impreza Owners Club Saturday February 13, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-28-2005, 01:30 AM   #1
Gordata
*** Banned ***
 
Member#: 86891
Join Date: May 2005
Chapter/Region: Tri-State
Location: Bronx, NY
Vehicle:
2002 WRX Wagon VF22
Silver

Default Clunk noise from front passenger side suspension

Ok, I have searched but all the other Clunk noise threads have not gotten resolved. I am going to try to explain my problem as best as I can to see if You guys can help me find out what is making this noise.
Car: 02 wrx wagon 5spd, Tein Basic Coilover.
I get this noise from the passanger side front suspension. When I am driving and I press the brakes to come to a complete stop, I get a Clunk noise like something comes out of place, and then when I start driving again and I let out the Clutch, I get the clunk like whatever it out of place, gets back into place. Its driving me crazy, If I hit a Bump while braking, I get the sounds too. I thought it was brake related but I changed the brakes today and I check everything to see if anything was Loose. I thought maybe it was the spring in the front Coilover but I am so puzzled. Any Info would be appreciated.
* Registered users of the site do not see these ads.
Gordata is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-28-2005, 06:51 AM   #2
turbo2ner
Scooby Specialist
 
Member#: 89385
Join Date: Jun 2005
Location: Loading...
Vehicle:
many most all
WRB/blk/blk/blk/slvr/wht

Default

Grease the swaybar end links. Turn up radio. Drink a beer.
turbo2ner is offline   Reply With Quote
Old 07-28-2005, 11:35 AM   #3
Gordata
*** Banned ***
 
Member#: 86891
Join Date: May 2005
Chapter/Region: Tri-State
Location: Bronx, NY
Vehicle:
2002 WRX Wagon VF22
Silver

Default

I dont want to Lose a Tire. A passanger can feel the Noise with the radio up and so can I when I am driving.
Gordata is offline   Reply With Quote
Old 07-28-2005, 02:08 PM   #4
fastgsx
Scooby Newbie
 
Member#: 68238
Join Date: Aug 2004
Chapter/Region: South East
Default

if the swaybar thing is a no go...
maybe it has something to do with one of the CO's and putting the stock susp. back on might help in determining the cause. I havent done this personally, but maybe put just the front susp. on and see what happens. Just drive around the block to see if it fixes anything. In anycase, you'll be under the car and might see something else that is wrong/broken.

Good Luck!
fastgsx is offline   Reply With Quote
Old 07-28-2005, 07:26 PM   #5
Hokie Guy
Scooby Newbie
 
Member#: 56294
Join Date: Mar 2004
Vehicle:
05 STi
Silver

Default

Im having something very similar, see:
http://forums.nasioc.com/forums/showthread.php?t=806345

Thanks

Justin
Hokie Guy is offline   Reply With Quote
Old 07-28-2005, 08:13 PM   #6
Gordata
*** Banned ***
 
Member#: 86891
Join Date: May 2005
Chapter/Region: Tri-State
Location: Bronx, NY
Vehicle:
2002 WRX Wagon VF22
Silver

Default

I am putting back my stock Front shock and springs as we speak. I will keep you guys posted as I am determine to find out what the hell is making that noise. I am up to my head into this. I dont sleep, All I think about is the clunk noise(I think the wife is going to leave me cause of this).
Gordata is offline   Reply With Quote
Old 07-29-2005, 09:06 PM   #7
Gordata
*** Banned ***
 
Member#: 86891
Join Date: May 2005
Chapter/Region: Tri-State
Location: Bronx, NY
Vehicle:
2002 WRX Wagon VF22
Silver

Default

Ok Guys, I changed the two front Strut and spring to the factory ones and the same sound is still there. I am starting to think it is a Engine Mount or the Transmission Mount. I am going to change those out next week.
Gordata is offline   Reply With Quote
Old 11-04-2005, 12:10 AM   #8
Gordata
*** Banned ***
 
Member#: 86891
Join Date: May 2005
Chapter/Region: Tri-State
Location: Bronx, NY
Vehicle:
2002 WRX Wagon VF22
Silver

Default

The Sounds was coming from my Anti Lift Kit, Upgraded to STI ones and Problem is Gone .
Gordata is offline   Reply With Quote
Old 11-04-2005, 12:20 AM   #9
darksands
Scooby Specialist
 
Member#: 75122
Join Date: Nov 2004
Chapter/Region: SCIC
Location: Im in a glass case of emotion
Vehicle:
2005 Impreza WRX
Crystal Gray

Default

Hahaha... you have the perrin ones huh??? I got that exact same clunk with the perrin ones. Got them replaced brand new and then sold them. Now I have Whiteline and no clunk.

I thought the STi ones were the same as the WRX ones. I have an 05 though so maybe different than 02.
darksands is offline   Reply With Quote
Old 11-04-2005, 12:34 AM   #10
Ryokosman
Scooby Newbie
 
Member#: 69997
Join Date: Sep 2004
Chapter/Region: South East
Location: AR
Vehicle:
12 Impreza Premium
Silver

Default

Gah! But why do the perrin's cause the clunk?!?!?! I've checked everything. I'm just living with it at this point.
Ryokosman is offline   Reply With Quote
Old 11-04-2005, 04:21 AM   #11
darksands
Scooby Specialist
 
Member#: 75122
Join Date: Nov 2004
Chapter/Region: SCIC
Location: Im in a glass case of emotion
Vehicle:
2005 Impreza WRX
Crystal Gray

Default

because their peices dont fit well onto the car. its loose.
darksands is offline   Reply With Quote
Old 11-04-2005, 05:03 AM   #12
llhype12ll
Scooby Specialist
 
Member#: 73073
Join Date: Oct 2004
Chapter/Region: SCIC
Location: Anaheim/ LBC/ hayward
Vehicle:
2006 EVO IX
GG

Default

Quote:
Originally Posted by turbo2ner
Grease the swaybar end links. Turn up radio. Drink a beer.

+1
llhype12ll is offline   Reply With Quote
Old 11-04-2005, 11:34 AM   #13
Ryokosman
Scooby Newbie
 
Member#: 69997
Join Date: Sep 2004
Chapter/Region: South East
Location: AR
Vehicle:
12 Impreza Premium
Silver

Default

Quote:
Originally Posted by darksands
because their peices dont fit well onto the car. its loose.
Any piece in particular you think would be allowing the movement? I'm up for mods???
Ryokosman is offline   Reply With Quote
Old 11-04-2005, 11:59 AM   #14
Gordata
*** Banned ***
 
Member#: 86891
Join Date: May 2005
Chapter/Region: Tri-State
Location: Bronx, NY
Vehicle:
2002 WRX Wagon VF22
Silver

Default

They redesigned it because of all the complaint of People having issues with it, There New Ones are Ok... I would get the Whiteline Comfort Kit. Not To expensive and does the job Right...
Gordata is offline   Reply With Quote
Old 11-04-2005, 12:08 PM   #15
Ryokosman
Scooby Newbie
 
Member#: 69997
Join Date: Sep 2004
Chapter/Region: South East
Location: AR
Vehicle:
12 Impreza Premium
Silver

Default

Crap. I don't need comfort. My cars not a daily driver anymore... So the red ones are OK just the black ones clunk...
Ryokosman is offline   Reply With Quote
Old 07-18-2006, 04:26 PM   #16
Hokie Guy
Scooby Newbie
 
Member#: 56294
Join Date: Mar 2004
Vehicle:
05 STi
Silver

Default

when i replaced the front pads it took care of the noise......no more clunking.
Hokie Guy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
06 Sti Pop/clunk from front passenger side help! Osus14 Brakes, Steering & Suspension 7 06-09-2010 11:09 PM
Clunking noise from front suspension, please help diagnose coldfire7 Brakes, Steering & Suspension 12 10-26-2009 02:16 PM
Clunking from front passenger side under torque& acceleration, intermitent though wrxgrocerygetter Brakes, Steering & Suspension 9 01-16-2007 06:07 PM
Bad clunking noise from front pass side when going over bumps? (05 STi) Optimus Prime Brakes, Steering & Suspension 16 06-24-2006 11:18 PM
Clunk in the front passenger side suspension MF-DIF Brakes, Steering & Suspension 6 04-07-2006 03:45 PM

All times are GMT -4. The time now is 05:04 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.