Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-28-2005, 06:56 PM   #1
derffred
Scooby Newbie
 
Member#: 92259
Join Date: Jul 2005
Chapter/Region: Tri-State
Location: North Jersey
Vehicle:
2005 Legacy GT
ABP

Default MY2005 questions/problem

So, i just purchased MY2005 Legacy GT... it's really fast and all, but i noticed on the MPG meter on the center console.. the slightest bit of throttle bring MPG way down.. it seems like it only meters it by throttle postion, not by A/C Clutch on, or Turbo Boost or anything like that.. and, i have a problem with my door, it seems like it's only the R/F.. making turns or slightly leaning on the door panel, the door ajar light comes on on the Instrument Cluster and the Overhead Light turns on... it has 800 miles... you really have the slam the door hard for it not to do that... and last question about performance... when it comes to racing off the line... what RPM should i launch at? All/Any advice is appreciated..
* Registered users of the site do not see these ads.
derffred is offline   Reply With Quote
Old 07-28-2005, 07:17 PM   #2
gtwagon941
Scooby Specialist
 
Member#: 16874
Join Date: Mar 2002
Chapter/Region: NWIC
Location: Beaverton, OR
Vehicle:
2008 2008 Audi RS 4
2014 Audi S Q5

Default

for the door issue-go to the dealer and have them adjust the latch.

I think you'll see that when you go into boost it drops even lower on that gauge. I know on my Mom's 05 GT when you push the pedal to the floor that little computer drops to something around 5mpg. I'm sure it isn't super precise, it is to be used for reference.

.02

Jared
gtwagon941 is offline   Reply With Quote
Old 07-28-2005, 07:34 PM   #3
derffred
Scooby Newbie
 
Member#: 92259
Join Date: Jul 2005
Chapter/Region: Tri-State
Location: North Jersey
Vehicle:
2005 Legacy GT
ABP

Default

okay... and about launching off the line? where should hold the RPMs?
derffred is offline   Reply With Quote
Old 07-29-2005, 02:55 PM   #4
ciscofreak
Scooby Newbie
 
Member#: 33176
Join Date: Feb 2003
Chapter/Region: NWIC
Location: Silverdale, WA
Vehicle:
06 STi
White

Default

You know there are two modes, one that shows real-time mileage and one that shows the average mileage based on the tripometers.

I figure you know this, I just wanted to make sure.
ciscofreak is offline   Reply With Quote
Old 07-29-2005, 04:32 PM   #5
rogerd
Scooby Specialist
 
Member#: 59934
Join Date: Apr 2004
Vehicle:
2005 Legacy GT Wagon
Atlantic Blue

Default

But anyway you cut it, if you drive the GT to enjoy it, you will not get good fuel economy.
rogerd is offline   Reply With Quote
Old 07-29-2005, 10:09 PM   #6
jim1969
Scooby Specialist
 
Member#: 34877
Join Date: Apr 2003
Chapter/Region: Tri-State
Vehicle:
2005 Legacy GT sedan

Default

My fuel economy sucks. Especially when filling up with 93 costs about $41.
jim1969 is offline   Reply With Quote
Old 07-30-2005, 03:29 PM   #7
AKLGT
Scooby Guru
 
Member#: 85199
Join Date: Apr 2005
Chapter/Region: AKIC
Location: Anchorage
Vehicle:
2012 turbo rollersk8
EvolvedAK's hood ornament

Default

yes, i have to drive like a grandma just to average just under 19.5 mpg on a tank! otherwise, if i'm hauling ass, i'm lucky to get 13-14 mpg.

don't know on launching. i'm assuming you must have a MT? I have an AT and unfortunately, aside from doing the gas/brake thing to 2000 rpms, i can't rev mine up safely to launch from 3500+ for that turbo spool.
AKLGT is offline   Reply With Quote
Old 07-30-2005, 05:03 PM   #8
PHATsuby
Scooby Guru
 
Member#: 13617
Join Date: Dec 2001
Chapter/Region: MWSOC
Location: MN
Vehicle:
2001 Legacy GT back
to stock is a project too

Default

for a launch(if you know how to do it properly) i would say rev to about 5k, then SLIP it out do not dump it or you will have issues, remember it is AWD, dont slip it excessively but you want the clutch to take the shock mainly rather than the drivetrain.

Ben
PHATsuby is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
('93-'01) fog light question/problem NateDogg Impreza Forum 0 07-10-2001 07:37 AM
exhaust question problem. 123 wrx 4 me Factory 2.0L Turbo Powertrain 4 06-20-2001 05:45 PM
Question/Problem with amp fuses. Please read. Andrew Car Audio, Video & Security 0 05-25-2001 09:55 PM
('93-'01) General transmission question/problem jeremy c Impreza Forum 3 05-24-2001 12:25 AM
Spark plug question/problem sbsnyder Normally Aspirated Powertrain 1 04-28-2001 04:47 PM


All times are GMT -4. The time now is 01:03 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.