Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-31-2005, 02:22 PM   #1
supermoose
Visiting NASIOC Timeout
 
Member#: 9093
Join Date: Aug 2001
Location: SF
Vehicle:
1995 RHD STi RA Ver2
swap starr

Default HELP!. swap done, and fuel pump wont fire

word. wrapped up my RHD swap. spliced in wire for fuel pump and pump wont fire. relay is plugged in, any ideas?

JDM sti v2 RA into 1993 L manual.

gearbox neutral and rev. plugged in, DCCD lights up, everything else is go
* Registered users of the site do not see these ads.
supermoose is offline   Reply With Quote
Old 07-31-2005, 03:04 PM   #2
bbbwrx
Scooby Specialist
 
Member#: 32734
Join Date: Feb 2003
Chapter/Region: RMIC
Default

Just because the relay is plugged in doesn't mean it is working.

There should be a couple other relays that are the same size. Make sure the part they are controling works(ex.if it is the horn relay honk the horn to make sure that relay is good.) Then switch them.

Just a though. It should be either that the wiring or the pump itself

Ben
bbbwrx is offline   Reply With Quote
Old 07-31-2005, 03:22 PM   #3
scoobydorift
Scooby Specialist
 
Member#: 43128
Join Date: Sep 2003
Location: SLC
Vehicle:
92 RWD, 96 FWD
05 AWD

Default

I forget the pin but you should be able to ground the "fuel pump relay wire" at the ecu. When you ground that wire it will click over the pump Realy. If you do not hear the realy click over, something else is wrong. either Relay is broken or something is not hooked up right.
Let me know if you want me to explain it more.
Thanks
Rick


ps. hi ben
scoobydorift is offline   Reply With Quote
Old 07-31-2005, 10:15 PM   #4
supermoose
Visiting NASIOC Timeout
 
Member#: 9093
Join Date: Aug 2001
Location: SF
Vehicle:
1995 RHD STi RA Ver2
swap starr

Default

fuel pump relay wire... hmm.

the pump is a working unit, was working the day that i pulled the motor (2 weeks ago). how do i ground out the fuel pump relay wire at the ECu?
supermoose is offline   Reply With Quote
Old 07-31-2005, 10:17 PM   #5
supermoose
Visiting NASIOC Timeout
 
Member#: 9093
Join Date: Aug 2001
Location: SF
Vehicle:
1995 RHD STi RA Ver2
swap starr

Default

how do i test relays? all hte fuese are good.

neerrr.. sux. hahah
supermoose is offline   Reply With Quote
Old 08-01-2005, 06:39 AM   #6
supermoose
Visiting NASIOC Timeout
 
Member#: 9093
Join Date: Aug 2001
Location: SF
Vehicle:
1995 RHD STi RA Ver2
swap starr

Default

roar. it runs, just had to wiggle SMJ R1 a bit. its frekin flipping stupendously fast.
supermoose is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to swap my stock cluster back in but fuel pump wont stop priming fourage20 Interior & Exterior Modification 1 03-26-2009 11:33 AM
Fuel Pump wont prime!! 02ej257 Factory 2.0L Turbo Powertrain 2 12-08-2006 03:45 PM
Hydra- Fuel pump wont turn off when hydra is powered up...whats the cause? White 2.5rs Other Engine Management 9 10-17-2006 09:06 PM
Shortblock swapped, injectors 2 & 4 wont fire. dmross Subaru Conversions 6 09-06-2006 09:15 PM
fuel pump wont turn on after motor install. oldbluwrx Factory 2.0L Turbo Powertrain 7 07-15-2005 11:01 AM


All times are GMT -4. The time now is 06:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.