Welcome to the North American Subaru Impreza Owners Club Thursday May 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-01-2005, 07:51 AM   #1
2fas4u
Scooby Specialist
 
Member#: 90691
Join Date: Jul 2005
Chapter/Region: MAIC
Location: Manchester, Maryland
Vehicle:
2005 STI / 2009 STI
Blue

Default Burning rubber smell from engine compartment

Well, got a chance this weekend to pop the hood and look for the cause of my burning rubber smell. I recently had an Injen TBE installed and thought it might have to do with this..

Sure enough the AC drain hose was right up against the down pipe and burned off to the pipe. What ass hats!!! You pay all of that good money and they leave something like that. My friend says maybe they did not see it but it sounds like laziness to me. In any event it is fixed and I thought I would post for the new folks if they do a search......
* Registered users of the site do not see these ads.
2fas4u is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-01-2005, 09:14 AM   #2
SQC120
Scooby Guru
 
Member#: 39677
Join Date: Jul 2003
Chapter/Region: Tri-State
Vehicle:
2008 Land Rover
02 WRX

Default

same thing is happening to me right now..
but its not completely burned off so im trying to salvage it.
SQC120 is offline   Reply With Quote
Old 08-01-2005, 11:51 AM   #3
23b_Rex
Scooby Specialist
 
Member#: 79394
Join Date: Jan 2005
Location: reston
Vehicle:
02 gda
wrb

Default

just another reason to install everything yourself
23b_Rex is offline   Reply With Quote
Old 08-01-2005, 12:54 PM   #4
2fas4u
Scooby Specialist
 
Member#: 90691
Join Date: Jul 2005
Chapter/Region: MAIC
Location: Manchester, Maryland
Vehicle:
2005 STI / 2009 STI
Blue

Default

yes indeed!
2fas4u is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Burning rubber smell, plus smoke from back of engine bay? kirbykirb Legacy Forum 7 01-19-2009 06:17 PM
Rubber burning smell from engine compartment ctown Normally Aspirated Powertrain 3 02-23-2005 10:55 PM
Burning rubber smell from front of the car Scott4DMny Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 9 02-23-2005 12:08 AM
Foul hot smell from engine compartment after only driving a couple miles bovid4585 Outback Forum 10 01-23-2004 12:20 AM


All times are GMT -4. The time now is 12:41 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.