Welcome to the North American Subaru Impreza Owners Club Wednesday March 4, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-01-2005, 01:27 PM   #1
supermoose
Visiting NASIOC Timeout
 
Member#: 9093
Join Date: Aug 2001
Location: SF
Vehicle:
1995 RHD STi RA Ver2
swap starr

Default anyone familiar with JDM elec OG AC?

yoot. my 95 sti RA AC was all perfect, now its blowing hot air. any ideas? drove along, turned off. then turned back on and it was hot?
* Registered users of the site do not see these ads.
supermoose is offline   Reply With Quote
Old 08-01-2005, 02:57 PM   #2
kaos200
Scooby Guru
 
Member#: 2692
Join Date: Oct 2000
Chapter/Region: SCIC
Location: SoCal
Default

check to see if the compressor is switching on, if not its either 1) fuse. 2) relay (doubt it) 3) short (possible since Im assuming your car was swapped/rewired)
kaos200 is online now   Reply With Quote
Old 08-01-2005, 04:35 PM   #3
supermoose
Visiting NASIOC Timeout
 
Member#: 9093
Join Date: Aug 2001
Location: SF
Vehicle:
1995 RHD STi RA Ver2
swap starr

Default

oh. cable was loose :P
supermoose is offline   Reply With Quote
Old 08-01-2005, 05:33 PM   #4
Jaxx
NASIOC Supporter
 
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Boise,Idaho,USA
Vehicle:
The 93 Imp W/EJ20K
flat black

Default

hey RAs aren't suposed to have AC any way ..
Jaxx is offline   Reply With Quote
Old 08-01-2005, 07:11 PM   #5
supermoose
Visiting NASIOC Timeout
 
Member#: 9093
Join Date: Aug 2001
Location: SF
Vehicle:
1995 RHD STi RA Ver2
swap starr

Default

RA V-limiteds do have AC :P

hahah. i win. i live in texas, no AC is the death.
supermoose is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
B&G coilovers.. Is anyone familiar with these? thrashvr6 Brakes, Steering & Suspension 1 06-06-2001 09:46 AM
Anyone familiar with FJO engine management? Rob K Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 04-23-2001 07:53 AM
Anyone familiar with Viper 300? pajono Car Audio, Video & Security 3 04-05-2001 10:58 PM
Anyone familiar with Focal? Revrend Car Audio, Video & Security 9 02-07-2001 12:46 AM


All times are GMT -4. The time now is 01:13 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.