Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > SVX Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Old 08-14-2001, 06:43 PM   #1
Flatfour
Scooby Newbie
 
Member#: 906
Join Date: Feb 2000
Location: Austin TX
Angry What's wrong with this picture?

Well this sucks..

Needless to say the svx is down for a day!

Never seen this happen to a subaru before..

What's worse , my wife now gets the WRX to take to work!!

Would have had it fixed in a few hours if part folks around here were better, I dont get them till 11am tommorow..

Oh yeah, can anyone tell what happened?
* Registered users of the site do not see these ads.
Flatfour is offline  
Old 08-14-2001, 08:15 PM   #2
glenstiles
Scooby Newbie
 
Member#: 2827
Join Date: Nov 2000
Location: Woodland, CA
Vehicle:
2002 WRX wagon
Silver, baby, silver

Default

??? what is it? looks important, my guess is a mounting plate for attaching an accesory bracket to the block?
glenstiles is offline  
Old 08-15-2001, 08:14 AM   #3
Flatfour
Scooby Newbie
 
Member#: 906
Join Date: Feb 2000
Location: Austin TX
Default

Yep ,
It holds the timing belt tensioner and idler ...

The bolt holding the idler snapped off, as you can see..

I had to drill and extract it, etc. The belt itself also cut through the plactic timing cover...what a mess... anyway, get all the parts at 11am today..should be rolling again by 12!...still find it odd, bolt must have been over tightened...
Flatfour is offline  
Old 08-16-2001, 07:26 AM   #4
Flatfour
Scooby Newbie
 
Member#: 906
Join Date: Feb 2000
Location: Austin TX
Default

Back on the road.
Had to use a salvage yard for the bolt though, Subaru parts will not sell it without the whole Idler...$118 I was quoted..

Anyway , i hadnt done Subie timing belts in over a year, good refresher..
Flatfour is offline  
Old 08-16-2001, 12:20 PM   #5
topher
Banned
 
Member#: 6966
Join Date: May 2001
Default

thats funny, i just figured out that my belt cover waas rubbing against the belt eaating it up. For now i just took the cover off, but dont know what i will do for long term.
topher is offline  
Old 08-16-2001, 01:52 PM   #6
Flatfour
Scooby Newbie
 
Member#: 906
Join Date: Feb 2000
Location: Austin TX
Default hmmm

Well, I hope you arent running it that way!
One pebble or stick and the belt's gone..

It obviously shouldnt run like that , I would check all your idlers.
If the cover is cut through..get one from salvage ,,They are $118 new...!

Good luck..
G
Flatfour is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What's wrong with this picture part II! (Now with more brucelee) brucelee Off-Topic 86 09-04-2007 08:23 PM
What's wrong with this picture? Or: match made in heaven! mad-dog999 New England Impreza Club Forum -- NESIC 2 01-31-2002 04:17 PM
Hmm, what's wrong with this picture... Penphoe Vancouver Impreza Club Forum -- VIC 6 11-01-2001 11:44 PM
What's wrong with this picture? [freeman] Canada Region Forum 24 05-08-2001 10:39 AM
('93-'01) Pop Quiz: What's wrong with this picture? Strider Impreza Forum 15 05-02-2001 03:27 PM


All times are GMT -4. The time now is 04:04 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.