Welcome to the North American Subaru Impreza Owners Club Tuesday July 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid West Subaru Owners Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid West Subaru Owners Club Forum -- MWSOC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-18-2000, 07:37 AM   #1
gnurider
Scooby Newbie
 
Member#: 455
Join Date: Oct 1999
Location: muscatine, ia, 52761
Vehicle:
2000 Impreza 2.5rs
aspen white

Unhappy possible balancing issues?

because of my offroad jaunts and fun in knee deep parking lots, i think ive encountered a balancing issue. @ speeds of >65mph the car starts shakin, has n e 1 else experienced this, im thinking i should get the balancing checked, but do u guys reccomend walmart or is there a place in the chicago land, (only a couple hr drive) also does excessive shaking affect the awd? we r getting another storm within the next couple of hours, so that is why im holding off on going to get this done maybe this weekend ill get it done, any info will b greatly appreciated.
* Registered users of the site do not see these ads.
gnurider is offline   Reply With Quote
Old 12-18-2000, 07:44 AM   #2
omahasubaru
Scooby Guru
 
Member#: 1594
Join Date: Jun 2000
Chapter/Region: MWSOC
Location: Gretna, NE
Vehicle:
1995 WRX
2002 Legacy

Post

could be snow frozen on/in your rims somewhere, or on other parts of the suspension.

I notice a very mild shaking and excessive road noise about 65 mph on my car too, but I think it is due to the snow/ice tires! Hee hee.

Never hurts to look at balance, might as well get an alignment while your at it too.
omahasubaru is offline   Reply With Quote
Old 12-18-2000, 07:45 AM   #3
Revision
Scooby Guru
 
Member#: 242
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: Carol Stream, IL USA
Vehicle:
MY05 PSM GGA !STOCK
MY99 RS-RIP / MY95 MX-5

Post

Naw, just blow the snow & ice out from your rims.
Revision is offline   Reply With Quote
Old 12-18-2000, 07:45 AM   #4
gtguy
Scooby Guru
 
Member#: 2184
Join Date: Aug 2000
Location: Highland Park, Ill., USA
Vehicle:
2005 Legacy GT wagon
Platinum Silver Metallic

Post

Make sure that you don't have anything in your rims. After similar fun in the snow, I was driving home from the office one day, and got the shimmies above 50 mph! When there's a lot of snow or mud in the rim, it throws off the balance. After a couple of days above freezing, coupled with a wash, the car was fine again, at 80-plus mph.

Kevin
gtguy is offline   Reply With Quote
Old 12-18-2000, 07:46 AM   #5
Revision
Scooby Guru
 
Member#: 242
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: Carol Stream, IL USA
Vehicle:
MY05 PSM GGA !STOCK
MY99 RS-RIP / MY95 MX-5

Post

Can we all try not posting at the SAME time.
Revision is offline   Reply With Quote
Old 12-18-2000, 08:03 AM   #6
Matthew Nelson
Scooby Newbie
 
Member#: 2174
Join Date: Aug 2000
Location: Overland Park, KS
Vehicle:
2000 Impreza 2.5 RS
Blue Ridge Pearl

Post

I can guarantee you that you've accummulated too much snow on your wheels.

I had the same problem last week after powersliding through several intersections. I had so much snow caked around my wheels (around the inside, that is) that any speed over thirty miles-per-hour started shaking my RS so violently I had to stop and think whether I'd slid into a median or something.

Now that most of the snow/ice has melted from my Impreza, it cruises at high speeds fine (again). Just give it some time or use a bit of hot water to melt the snow.
Matthew Nelson is offline   Reply With Quote
Old 12-19-2000, 08:19 AM   #7
Hebaru
Scooby Newbie
 
Member#: 2206
Join Date: Aug 2000
Chapter/Region: MWSOC
Location: St. Louis, MO, USA
Vehicle:
2001 2.5 RS
Silverthorn Metallic

Have a Nice Day?

Hitting medians doesn't necessarily cause shaking... you just have to aim it right so it destroys the back end and the corner absorbs all of the impact...
Hebaru is offline   Reply With Quote
Old 12-19-2000, 08:28 AM   #8
8Complex

Moderator
 
Member#: 922
Join Date: Feb 2000
Chapter/Region: MWSOC
Location: Schaumburg, IL
Vehicle:
04 FXT
Red

Post

Hebaru - Yeah, I gotta admit, yours was pretty impressive. Also makes me realize how relatively weak this car is, though. I had done about the same thing with an old Volvo of mine and I just had to get a rear cluster, rear bumper, and pound out the body with a sledgehammer on one rear fender.
8Complex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
NEED HELP. Vibration under load, not a tire balance issue... David L. Factory 2.5L Turbo Powertrain 8 09-26-2010 03:07 AM
Balancing Issues with Rota G-forces? Pawlwawl06 Tire & Wheel 8 06-07-2009 02:10 PM
Tire Balance Issue with Rotas Tarmac II Ernest Tire & Wheel 3 12-07-2006 08:54 PM
5MT SVX....clearence/balance issue please help 5spd Alcyone Transmission (AT/MT) & Driveline 10 04-10-2003 09:42 PM
Upgrading the front diff to limited slip, balance issues? Mykl Transmission (AT/MT) & Driveline 3 04-27-2002 04:15 PM


All times are GMT -4. The time now is 02:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.